Jump to content
Sign in to follow this  
kwakS

Problem mit RIS Server

Recommended Posts

Hi Leute,

 

ich habe ein merkwürdiges Problem. Und zwar habe ich zu hause einen RIS Server laufen (zu testzwecken für mein Abschlussprojekt).

Bis vor ein paar Tagen lief es noch ohne Probleme.

Dann irgendwie geht der PXE Boot nicht mehr. Ich bekomme die Fehlermeldung:

TFTP read timeout

TFTP cannot read from connection

 

Ich verstehe nur nicht warum. Ich habe ein RIS check gemacht. Ohne Fehler. Auf der Eventlog zeigt keine Fehler auf. Woran könnte das dann liegen???

Ich weiß Fehlererkennung über die Ferne ist immer schwer aber vielleicht gibt es ja nur eine Lösung :)

Daemon für TFTP läuft...

 

Vielleicht kann mir ja diesbezüglich jemand helfen...

 

Danke jetzt schon mal :)

Share this post


Link to post
Share on other sites

Hallo,

 

hast du einen Standortwechsel vollzogen? Also einen anderen Switch? ist der Switch managebar / Layer 3 und nicht gerade super konfiguriert? anedere Möglichkeit sehe ich nun nich. Wass du mal machen kannst ist dein Client über Cross an den Server anzuschließen. Hast du eventuell Configdaten geändert? Bekommt der Client eine IP?

 

grüße

starfoxx

Share this post


Link to post
Share on other sites

hallo

 

vielleicht mal den RIS service deinstallieren/installieren

 

eventlog nachsehen. evtl. service tftp stopen und neu starten.

 

weis auch nicht genau

 

gruss bergesel

Share this post


Link to post
Share on other sites

der client bekommt beim pxe-boot ne ip. naja und warum das nicht mehr funktioniert weiß ich jetzt auch nicht aber ich habe den server weder umgezogen noch was anderes mit ihm angestellt, naja außer Linux auf den Client zum test installiert. aber das dürfte ja eigentlich nicht das problem hervorgerufen haben....

ich weiß so etwas passiert nicht von heute auf morgen. meistens liegt das prob ja 20 cm vorm bildschirm:)

ich habe eigentlich schon den server sowie den client neu aufgesetzt aber nichts hat geholfen.

 

naja ich habe noch ein paar unstimmigkeiten im system gefunden. ich werde diese erstmal beheben und wie sagt der kaiser so schön : "schau mer mal"...

 

danke nochmals allen...

Share this post


Link to post
Share on other sites

Hmm ich habe jetzt nochmal alles angechaut, die Verknüpfung mit der .sif erneuert den daemon neu gestartet. nix hat geholfen.... irgendwie versteh ich das nicht...

ich habe sogar eine testkonfiguration aus dem netz schritt für schritt nachgespielt. trotzdem findet der den tftp nicht... muß man den vielleicht explizit angeben?? Ich kann mich aber nicht erinnern das beim ersten mal gemacht zu haben....

 

Nun bin ich doch ein wenig ratlos... Aber vielleicht kann mir ja einer helfen...

Share this post


Link to post
Share on other sites

hallo nein

 

den musst du nicht explizit angeben. du hast alle komponenten wieder im netz, wie dhcp, dns, dc, ad, ris

 

hast du die eventlogs angesehen? sollten einträge gemacht werden von tftp.

dhcp ip bereich?

irgendwas wirst du vergessen haben wenn es schon mal funktioniert hat. :confused:

 

beim client den mbr neu schreiben wegen linux

Share this post


Link to post
Share on other sites

jup ich habe alle dienste wieder am laufen...

im eventlog steht nix.

dhcp läuft ja, weil der client auch beim pxe boot ne ip bekommt...

 

ich versteh das alles nicht.... ich bekomm noch die krise

Share this post


Link to post
Share on other sites

Ich meine mit "steht nix drin" lediglich, dass keine Fehler drin stehen. Also der GrovelerDienst ist Fehlerfrei gestartet der Binlsvc ist auch ohne Prob gestartet (alles laut eventlog)

 

drum bin ich ja ein wenig ratlos... alles scheint ohne probs zu laufen nur der sch*** tftp nicht...

der tftp wird doch beim einrichten des RIS erstellt oder täusche ich mich da???

 

**update**

Ich habe noch folgende Fehlermeldung erhalten: "Zeitlimit für die Semaphore wurde erreicht"

Mit googlen bin ich nicht wirklich weitergekommen, was das zu bedeuten hat. Vielleicht hat ja einer von euch eine Idee...

Vielleicht hängt das ja wirklich irgendwie zusammen.

Share this post


Link to post
Share on other sites

Hi,

 

beim client den mbr neu schreiben wegen linux

hast schon gemacht?

Wäre auch mein Tipp gewesen. Schon merkwürdige Sachen erlebt, vorallem wenn man GRUB als bootloader verwendet.

 

lg,m

Share this post


Link to post
Share on other sites

ähm genau den hab ich genommen :cry:

doof das. aber ja das hatte ich schon gemacht.

außerdem hatte ich noch mein notebook (wo nur wxp drauf läuft) mal zum testen missbraucht und da gab es den gleichen fehler... also würde ich glatt sagen, dass es am server irgendwie liegt...

Share this post


Link to post
Share on other sites

So jetzt habe ich den Server neu eingerichtet. DNS und DHCP sowie AD neu aufgebaut aber trotzdem will der RIS Server nicht laufen.

Ich bekomme immernoch den Fehler TFTP time out.

Zwischendurch wurde TFTP gefunden nur dann ist der Download der Datei fehlgeschlagen.

Eventlog zeigt immernoch keine Fehler an.

DNS müsste funktionieren (mit nslookup habe ich meinen pdc angezeigt bekommen)

DHCP funktioniert auch (auch über PXE)

Ich habe auch beim DHCP Server einen manuellen BOOTP Eintrag gemacht (Bootfile etc.)

Trotzdem funktioniert das nicht stabil bzw gar nicht.

So langsam weiß ich nicht woran es liegen könnte.

 

Hat vielleicht einer eine Idee wie man konstruktiv an eine Fehlerlösung rangehen könnte??

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...