Jump to content
Sign in to follow this  
Evoco

DNS Problem

Recommended Posts

Hallo ich habe ein proplem mit meinem Server 2003 Enterprise Edidion.

 

Aufbau meines Netzwerkes:

Router-Server-und ein paar Clients.

Auf dem Server habe ich einen DC eingerichtet, bis dahin kein Problem,aber als ich mit Active Directory arbeiten wollte funktioniert es nur zu hälfte.

Anders ausgedrücht!!!!!

Um Active Directory zum laufen zu bringen muß mein DNS server erstmal laufen und da habe ich die Probleme.

Wenn ich nslookup eingebe bekomme ich Fehlermeldung die lautet:

 

Der Servername für die Adresse 192.168...(IP Adresse vom Server) konnte nicht gefunden werden: non- existent domain Standartserver:Unkown

 

So jetzt steh ich auf den Schlauch??????

Also hier noch ein paar einstellungen die ich habe:

Auf meinem Router ist DHCP aktiv und bei Primären DNS server habe ich die IP Adresse des DCs der auch als DNS läuft.Auf dem DC habe ich unter weiterleitung (im DNS programm) die IP-Adressen der DNS Server vom ISP. Diese Einstellungen habe ich gemacht damit alle DNS abfragen über den DC bzw.DNS Server gehen, damit Active Directory einbandfrei läuft.

 

Könnte mir bitte da jemand helfen????????

Share this post


Link to post
Share on other sites

Hallo und willkommen an Board,

 

auch für Newbies gilt, dass die Boardsuche häufig weiterhilft ;)

 

Stop, stop, nicht suchen, die Lösung für dich:

es fehlt (wie so oft bei DNS-Problemen) die Reverse Lookup Zone bei deinem DNS-Server.

Jetzt kannst du im Board suchen, wie es genau geht, es gibt so ca. 2-20 Anleitungen dafür, weil das Problem sehr oft auftaucht. :)

 

Grüße

Olaf

Share this post


Link to post
Share on other sites

Danke für fie Antwort aber ich habe die reverse lookup zone eingerichtet.

 

bei nslookup steht jetzt

-----------------------------------------------------------------------------------------------------------------

Standardserver: server.name.de

Address: 192.168.1.100

 

> server

Server: server.name.de

Address: 192.168.1.100

 

*** server wurde von server.name.de nicht gefunden: Non-existent domain

----------------------------------------------------------------------------------------------------

Also bei der reverse Lookupzone steht:

 

Ordner name:192.168.1.x Subnet

 

im Ordner steht

Name Typ Daten

(identisch mit übergeordnetem Ordner) Autoritätsursprung (SOA) [17], server.name.de., hostmaster.name.de.

(identisch mit übergeordnetem Ordner) Namenserver (NS) server.name.de.

192.168.1.100 Zeiger (PTR) server.name.de.

192.168.1.11 Zeiger (PTR) personal.name.de.

192.168.1.13 Zeiger (PTR) rst-sony.name.de.

 

 

Was ich noch hinzufügen möchte!!

Wenn ich nslookup mit einer IP-Adresse also nicht Name ausführe bekomme ich eine einbandfreie Antwort.

Wenn ich "nslookup server" eingebe dann bekomme ich wie oben gezeigt eine Fehlermeldung!!!

Und das versteh ich nit!!

 

Was soll ich machen???

Hast de noch ein Tipp??

Share this post


Link to post
Share on other sites

... hmmm...

 

nochmal der Reihe nach:

 

wenn ich einen ersten DC einrichte, dann achte ich immer auf folgende drei Punkte:

 

- Der Server selber hat einen suffix, der genauso lautet, wie der geplante Domänenname.

Bsp: Geplanter Domänenname: "testdom.de" => Servername: "server.testdom.de"

Einzustellen unter Eigenschaften vom Arbeitsplatz => Computername => Ändern => Weitere => Primäres DNS-Suffix

 

- DNS läuft, Forward- und Reverse-Lookupzones sind richtig konfiguriert, d.h. z.B. die Forward-Lookupzone sollte so heißen, wie der Domänenname. In diesem Falle also "testdom.de"

 

- Der Server hat den richtigen DNS-Server eingetragen, im Falle eines Neuaufbaus der Domäne auf der grünen Wiese also sich selber.

 

Hast Du das so aufgebaut ? Dann funktioniert es bei mir eigentlich zu 100 % ...

 

Grüsse

 

schroeder750

Share this post


Link to post
Share on other sites

Danke für die Antwort ich habe die reverse lookup zone eingerichtet.

 

Wenn ich nslookup mit einer IP-Adresse also nicht Name ausführe bekomme ich eine einbandfreie Antwort.

 

Wenn ich "nslookup server" eingebe dann bekomme ich wie unten gezeigt eine Fehlermeldung!

dann steht dort

-----------------------------------------------------------------------------------------------------------------

Standardserver: server.name.de

Address: 192.168.1.100

 

> server

Server: server.name.de

Address: 192.168.1.100

 

*** server wurde von server.name.de nicht gefunden: Non-existent domain

----------------------------------------------------------------------------------------------------

Also bei der reverse Lookupzone steht:

 

Ordner name:192.168.1.x Subnet

 

im Ordner steht

Name Typ Daten

(identisch mit übergeordnetem Ordner) Autoritätsursprung (SOA) [17], server.name.de., hostmaster.name.de.

(identisch mit übergeordnetem Ordner) Namenserver (NS) server.name.de.

192.168.1.100 Zeiger (PTR) server.name.de.

192.168.1.11 Zeiger (PTR) personal.name.de.

192.168.1.13 Zeiger (PTR) rst-sony.name.de.

 

 

Was soll ich machen???

Hast de noch ein Tipp??

Share this post


Link to post
Share on other sites

- Der Server selber hat einen suffix, der genauso lautet, wie der geplante Domänenname.

Bsp: Geplanter Domänenname: "testdom.de" => Servername: "server.testdom.de"

Einzustellen unter Eigenschaften vom Arbeitsplatz => Computername => Ändern => Weitere => Primäres DNS-Suffix

Schon gemacht?

Grüße

Olaf

 

PS: Bitte keine privaten Nachrichten deiner Art :( , ich schaue regelmäßig in jedes Posting, in dem ich geschrieben habe (das nennt sich abonnierte Themen, hast du auch). Es sind noch ca. 53 andere, die auch was von mir möchten...

Share this post


Link to post
Share on other sites

Hallo Tobias,

 

zuerst mal möchte dich auch fragen, ob du die Einstellungen meiner Vorposter so gemacht oder überprüft hast.

Wenn ja und es ist immer noch dieses Problem vorhanden, dann schau bitte mal in den Eigenschaften von Netzwerk(umgebung) >Erweitert >Erweiterte Einstellungen und stelle die Netzwerkkarten in der Reihenfolge ein, dass die für den DNS-Server an oberster Stelle ist.

 

Vielleicht hast du ja noch ein Programm drauf, welches einen DNS-Server intergiert hat. Sowas macht bsw. AVM KEN, wenn man das dort nicht explizit deaktiviert.

Gruß Goscho

 

PS: Deinen Begriff "einbandfrei" kenne ich nur als einwandfrei, aber wer weiß so was schon immer genau.

Share this post


Link to post
Share on other sites

So ich habe den DNS-Surffix überprüft aber der ist richtig eingestellt.

 

Jetzt habe ich auch die Reihenfolge der Netzwerkarten geändert so das die Netzwerkkarte für den DNS-Server an erster Stelle steht.

 

An dem Fehler hat sich aber leider nichts getan!!!!

 

Gruß Tobi

Share this post


Link to post
Share on other sites

Dann gibt es noch eine Einstellung, die das automatische Anhängen des Domänennamens beeinflusst:

Eigenschaften TCP/IP-Protokoll - Erweitert - DNS - Primäre und verbindungsspezifische DNS-Suffixe anhängen und den Haken darunter (Übergeordnete Suffixe des primären DNS-Suffixes anhängen) auch ankreuzen.

 

Damit geht es auf jeden Fall. Oder du hast noch etwas anderes verkonfiguriert, z. B. in den GPOs.

 

Grüße

Olaf

Share this post


Link to post
Share on other sites

So jetzt habe ich auch unter "TCP/IP Einstellung :Übergeordnete Suffixe des primären DNS-Suffixes anhängen", dort einen Haken gesetzt.

 

Leider keine Änderung!!!

Share this post


Link to post
Share on other sites

Tja, dann hast du irgendetwas nicht gemacht, was wir beschrieben haben oder du hast irgendetwas gemacht und uns es nicht gesagt. So wie beschrieben, klappt es immer.

Und solange das Rückwärtsauflösen der Server-IP in den Servernamen nicht gelingt, wirst du Fehler haben im AD.

 

Einzige Idee, die ich noch hätte: DNS-Server komplett neu einrichten.

 

Grüße

Olaf

Share this post


Link to post
Share on other sites

Also ich bin deiner Idee nach gegangen und habe den DNS Server neu aufgesetzt.

Ich habe erstens mit dem Button "DNS Server Konfigurieren" dann "Forward und Reverse Lookupzone erstellen " aus gewählt. Dort habe ich meine Einträge wie Primäre Zone AD integriert, dann Zonenname eingegeben die heißt dörnberg.de.Dann Reverse Lookupzone 192.168.x.

Als ich damit fertig war: DNS neu gestartet, dann nslookup gestartet und Fehlermeldung kam:

*** Der Servername für die Adresse 192.168.1.100 konnte nicht gefunden werden: N

on-existent domain

Standardserver: UnKnown

Address: 192.168.1.100

>

 

So dann habe ich ein PTR eintrag in der Reverse Lookupzone gemacht mit dem Hostname "server" so heißt der Server.

 

Dann wieder nslookup gestartet:

 

Standardserver: server

Address: 192.168.1.100

 

> server

Server: server

Address: 192.168.1.100

 

*** server wurde von server nicht gefunden: Non-existent domain

> 192.168.1.100

Server: server

Address: 192.168.1.100

 

Name: server

Address: 192.168.1.100

 

Also ich weiß nicht was ich falsch gemacht habe?????

 

Es geht einfach nit!!!

Share this post


Link to post
Share on other sites
, dann Zonenname eingegeben die heißt dörnberg.de.

Das ist nicht dein ernst, oder?

Was willst du mit Umlauten im Domänennamen, das hakt doch schon beim IE, wie soll das dann beim MS-DNS klappen?

Share this post


Link to post
Share on other sites

Oh Schitt!!!

Du könntest recht haben.Da habe ich überhaupt nicht dran gedacht!!

 

Gibt es möglichkeiten eine Domäne einen anderen Namen zu geben??

Share this post


Link to post
Share on other sites

Moin Thobias,

 

verstehe ich das richtig, daß Du eh noch keine saubere, lauffähige Domäne hast, weil der dcpromo bisher nicht sauber durchgelaufen ist ?

 

Dann musst Du doch auch noch keine Domäne umbenennen, oder ?

 

Tip von mir: fang unten wieder an. Am Besten Server plattmachen und sauber neu aufsetzen...

Klar, Du könntest jetzt anfangen, umzubenennen, was geht oder was schon da ist, aber willst Du unter diesen Umständen die nächsten Jahre mit einer sooo angefangenen Domäne verbringen ?

Weißt Du, was sich bisher nach all der Testerei alles so in die Registry des Fast-DCs reingepinselt hat ?

Wäre mir zu wackelig, damit jetzt anzufangen...

Mach platt den Server, setz ihn sauber neu auf, vermeide Umlaute und geh am Besten einfach alles so durch, wie es hier gepostet wurde... dann fängst Du sauber mit der Umgebung an ...

 

Wenn irgendwas unklar ist, helfen wir Dir gerne weiter...lieber jetzt zwei Stunden mehr reinstecken und später Ruhe haben... ;)

 

Grüsse und viel Erfolg !!!

 

Ach ja, @Edv-Olaf: Adlerauge !!! ich habe das mit den Umlauten glatt überlesen... :D

 

schroeder750

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...