Jump to content

WSUS: Nach Bluescreen fehlerhafter Updateclient


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo Gemeinde,

 

nachdem mein alter Thread mittlerweile Overtalk ohne Ende hat :rolleyes:, hier ein Neuer mit nem defekten Updateclient.

 

Also, ich habe meine GP so gesetzt, dass alle Clients und Server in der Domäne den WSUS als Updatebezug verwenden. Dabei installiert der WSUS auf die betreffenden Rechner das Update für den Automatic Selfupdate Client.

 

Nun ist da wohl an meinem Notebook was schief gelaufen und bei dem Update dankte es mir mit einem Bluescreen. Nach dem Neustart war keine Verbindung mehr zum WSUS gegeben. Ich bin dann einfach von dort auf die MS Updateseite gegangen und er hat mir mit: "Es wird überprüft, ob der aktuelle Updateclient installiert ist", geantwortet. Scheinbar hat er dort festgestellt, dass der Updateclient fehlerhaft ist und ihn ersetzt. Denn seit diesem Zeitpunkt funktioniert auch wieder die Verbindung zum WSUS.

 

Der WSUS hat nun festgestellt, dass dem Notebook noch ein Update fehlt. Im Status steht auch: Download erfolgreich. Das Notebook installiert aber nicht das Update. Wenn ich es herunterfahre, erscheint bei den Herunterfahroptionen: Updates installieren und dann herunterfahren. Wähle ich das aus, schreibt mir das Fenster: Windows wird heruntergefahren --> Update 1 von 1 wird installiert --> Rechner wird heruntergefahren.

 

Nach dem Neustart ist das Update aber nicht installiert. Soll heißen, er bringt mir beim Runterfahren immer wieder die Option zum Installieren und runterfahren.

Gehe ich auf die Updateseite von MS direkt, stellt sie fest dass mir genau dieses Update fehlt. Quittiere ich es mit 'Installieren' kommt die Fehlermeldung:

 

Die Installation ist fehlgeschlagen. (Ohne weitere Gründe)

 

Konkret geht es um das Update für den Junk E-Mail Filter von Outlook 2003 (KB894384)

 

Meine Vermutung ist nun, dass der Updateclient immer noch fehlerhaft ist.

Es gibt zwar einen zum downloaden. Der ist aber für ein XP ohne SP. Da ich SP2 schon drauf habe, lässt sich dieser leider nicht installieren.

 

Hat jemand einen Rat für mich?

Link to comment

Hi Wildi,

 

Die Installation ist fehlgeschlagen. (Ohne weitere Gründe)

 

Konkret geht es um das Update für den Junk E-Mail Filter von Outlook 2003 (KB894384)

 

Meine Vermutung ist nun, dass der Updateclient immer noch fehlerhaft ist.

Es gibt zwar einen zum downloaden. Der ist aber für ein XP ohne SP. Da ich SP2 schon drauf habe, lässt sich dieser leider nicht installieren.

 

hast du´s schon getestet das Update direkt über Microsoft Upate zu installieren?

 

Evtl. liegts ja auch an der Office Installation selber....

 

http://update.microsoft.com/microsoftupdate/v6/default.aspx?ln=de

 

 

LG Gadget

Link to comment

Hi Kohn,

 

Step 1 war über den WSUS - das geht nicht

 

Durch den Fehler beim Updaten des Automatic Update Client habe ich dann ...

 

Step 2 gemacht:

 

Am Notebook auf die Updatewebsite von MS. Dort kam dann, dass er überprüft ob der Updateclient in Ordnung wäre. Dabei nehme ich schwer an hat er mir den Client wieder repariert, denn darauf hin war das Notebook sofort im WSUS eingetragen.

 

Nachdem der WSUS scheinbar das Junk E-Mail Update dem Notebook rübergeschickt hat, konnte er dieses aber durch o.a. Fehler nicht installieren.

 

Daraufhin wieder auf die MS Updatehomepage und hier habe ich 2 Symptome:

 

1. Die Windows Updates kann er mir nun gar nimma finden. Also der Suchprozess läuft gerade mal 1 Sek. dann der Fehler:

 

Die gewünschte Seite kann nicht angezeigt werden, da auf der Website ein Problem aufgetreten ist.

 

Also ist das Updaten über MS Updatehomepage für Windows schon mal tot. Wohl gemerkt, mit allen anderen Clients würde das gehen.

 

2. Gehe ich auf die Updatehomepage von Office, läuft der Suchprozess wunderbar durch, er zeigt mir auch an dass ich noch das Junk E-Mail Update benötige, klicke ich aber dann auf Installieren kommt sofort:

 

Die Installation ist fehlgeschlagen.

 

Natürlich kann es schon sein, dass sich da irgendwas mit dem Office zwickt, aber ich schiebe den Fehler jetzt eher dem Updateprozess zu.

 

Fahre ich dann den Rechner runter kommt: Update installieren + Herunterfahren (bietet er mir halt an). Mache ich dieses, insatlliert er mir scheinbar das Update aber nach dem Neustart ist es wieder so als ob es nicht installiert wurde. Ich nehme mal an dass er es beim Herúnterfahren zwar versucht aber genausowenig schafft wie über die Homepage. Nur das beim Runterfahren keine Mecker kommt.

 

Im WSUS steht dann auch noch immer das mein Notebook das Update benötigt.

 

Ich habe mal vorsichtshalber geguckt ob irgend was in den Prozessen läuft was ihn vielleicht daran hindert das Update zu installieren - aber das sieht alles recht gut aus.

 

Ne weitere Vorstellung wäre evtl. noch, dass das Update, was vom WSUS zum Notebook erst mal downgeloadet wurde bei der Übertragung fehlerhaft ist. Der WSUS wie auch die MS Homepage glauben ich hätte es schon auf der Platte und dann dieses fehlerhafte verwendet. Und das ginge ja auch nicht

 

*grübel*

Link to comment

Hi Wildi,

 

so habe den WSUS bei uns in der Firma installiert... hab am Anfang auch kleine Probleme gehabt jetzt gehts aber...

 

so jetzt aber zu deinem Prob:

 

- Hast du die Logs schon kontrolliert?

 

Clientlog:

%windir%\WindowsUpdate.log

 

Serverlog:

%ProgramFiles%\Microsoft Windows Update Services\LogFiles\SoftwareDistribution.log and

 

- Hast du den neuesten Windows Installer schon drauf

 

da =>

Note that Office updates do not install on client machines that do not have Windows Installer version 3.0 installed.

 

Download:

http://www.microsoft.com/downloads/details.aspx?displaylang=de&FamilyID=889482fc-5f56-4a38-b838-de776fd4138c

 

- Von welcher Quelle wurde dein Office/Outlook installiert?

Ist die Installationsquelle verfügbar... bei manchen Updates wird die Installationsquelle benötigt. Hast du schon eine Reperaturinstallation versucht?

 

- Hast du das WSUS Client Diagnostic Tool schon laufen lassen?

Download hier unter Support Tools:

http://www.microsoft.com/windowsserversystem/updateservices/support/default.mspx

 

LG Gadget

Link to comment

@Kohn

 

Danke Dir. Ich habe weitestgehend sämtliche Varianten schon versucht/noch mal versucht/neu versucht :)

Alles ohne Erfolg.

Die Diag sieht gut aus. Auch die Logs - aber ...

 

@all

 

Also, mein Problem mit dem Notebook besteht immer noch.

Das Teil war vor dem WSUS schon pepatcht. Es fehlte nur dieses Junk Filter Update.

 

Heute Patchday:

Alle Kisten sind nach Freigabe im WSUS geupdatet worden, ausser das Notebook.

Neben dem Junk Mail Update gehen ihm alle anderen, neuen Updates nun auch ab.

Die Kommunikation zwischen WSUS und Notebook scheint aber zu klappen, denn die Updates wurden zum Notebook geschickt. Das Logging zeigts an und auch der WSUS zeigt mir da erfolgreichen Download. Nur scheinbar lassen sich keine Updates installieren.

 

Ich kann machen was ich will!!!

Auch beim Runterfahren will er mir ALLE updates installieren - tut das augenscheinlich auch - aber sie sind nicht geupdatet.

 

Gehe ich am Notebook auf die Updatehomepage von MS, geht das wie oben geschrieben immer noch nicht.

 

Eigentlich müsste alles in Butter sein. Ich habe auch mal ein intensives Programm installiert um zu prüfen ob überhaupt noch Installationen mit Regzugriff gehen (Zugriffsrechte). Das geht alles. Nur keine MS Updates :(

Link to comment

@danryker

 

Ja, das habe ich auch. Auch hier kommt der Fehler dass das Update nicht installiert werden kann.

 

Aber beim durchwühlen der LOG's ist mir was aufgefallen:

 

----SCHNIPP

 

KBxxxxxx Setup hat folgenden Fehler festgestellt: Die Datei update.ver ist nicht richtig

:

:

:

Die Installation des KBxxxxx wurde nicht abgeschlossen.

Update.exe extended error code = 0xf201

 

----SCHNIPP

 

Diese Meldung taucht in allen Log's der einzelnen KB's auf dem Notebook auf, die nicht installiert wurden.

Leider finde ich niergendwo was über die update.ver :(

Link to comment

Hi Wildi,

 

Leider finde ich niergendwo was über die update.ver :(

 

hab schon was zur Update.ver gefunden:

 

Update.ver

 

Describes the version, size, and hash information for the newer versions of the files currently on the system.

 

Is also irgendein Versionproblem ... wahrscheinlich ist auf dem Schlepptop noch ein OEM Image drauf ... :rolleyes:

 

Da bist du mit deinen Updateproblemen nicht allein....

 

Anyone want a laptop, Dell, Inspiron 8200 nearly new, only missing 14 security patches? If you act now you might be able to get it from me before I'm tempted to chuck it out the window.

 

hier gehts weiter => http://msmvps.com/bradley/archive/2005/03/19/39036.aspx#39042

 

ich würde dem zweiten Post dort folgen:

 

I know this might be oversimplifying things but we adhere to something we call the 15 min rule. If a strange issue like this takes over 15 (sometimes 30)mins to resolve, we nuke the laptop and start fresh with a Ghost image.

 

Regt mich zwar dann auch ein bisserl auf wenn ich den Fehler nicht finden kann... aber was bringts wenn man ewig rum sucht... bin zwar sicher, dass du den Fehler noch finden würdest ;) aber irgendwann is es auch brotlos... :rolleyes:

 

LG Gadget

Link to comment

Danke Dir Kohn,

 

ne OEM is da nicht drauf. Ich habe da meine VL installiert. Ich werde jetzt mal noch Deinen Links folgen und dann geb ich auch auf.

Wollte heute schon das Teil platt machen. Wird vermutlich eh mal wieder Zeit wenn ich denke wieviel ich da zwischenzeitlich installiert/deinstalliert habe :rolleyes:

Wenn sich noch was ergibt poste ich selbstverständlich für die Nachwelt zurück

Link to comment

Was es nicht alles gibt auf dieser Welt :rolleyes:

 

Hab das Notebook neu installiert. In die Domäne aufgenommen. Taucht auch sofort im WSUS Server auf.

Ne Minute später - patsch - Bluescreen.

Leider nur ganz kurz -> irgendwas mit der ntfs.sys

Danach wieder das Gleiche: Rechner im WSUS, auch der Bericht, aber keine Updates mehr möglich. Über keinen Weg!!!

 

OK, dacht ich mir. Nochmal neu, aber diesmal auf die ACER Homepage und gucken ob irgendwas neues an Treibern da ist. Siehe da, ein BIOS Update. DIeses durchgeführt -> Rechner nochmal installiert und nu?

 

JETZT GEHT ES!!!

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...