Jump to content

kleines routing Problem


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo Netzwerkspezies,

ich betreue ein recht großes UNIX-Netzwerk in einem Krankenhaus, nun habe ich ein kleines Problem. Historisch gewachsen gibt es zwei Class-C Adressbereiche. Kein Problem da unsere Solaris Maschine zwei Netzwerkkarten hat. Nun haben wir leider einen Windows 2000 Server mit MS-SQL und Dateifreigaben dazu bekommen. Dieser hat nun nur eine Netzwerkkarte und somit nur eine IP-Adresse. Nun das Problem, um von beiden Adressbereichen auf den W2000-Server zugreifen zu können fungiert die Solaris Maschine als Router. Das funktioniert auch meistens. Leider sieht man in der Netzwerkumgebung den W2000-Server nicht und man muß erst die IP-Adresse eingeben um seine Freigaben zu sehen. Das Hauptproblem ist aber das es einige Clients gibt welche ab und zu die Freigaben mitten während der Arbeit verlieren und auch erst wieder verbinden können wenn man den Client gebootet hat. Wechsele ich mit diesem Client in den Adressbereich des W2000-Servers habe ich keine Probleme mehr.

Nun meine Frage, gibt es die Möglichkeit den W2000-Server ebenfalls mit zwei Netzwerkkarten auszustatten und diese mit verschiedenen Adressbereichen zu belegen damit ich nicht mehr über den Router muß?

 

Viele Grüße

Uwe Dame

Link to comment

Hi !

Wenn das zwei physisch getrennte Netze sind, brauchst Du, wie schon gesagt, eine 2.NW-Karte, die Du in das andere Netz hängst.

Es hört sich aber so an, als wenn das nur eine logische Trennung ist. Da brauchst Du an die bestehende Netzwerkkarte nur eine zusätzliche IP des anderen Subnetzes binden.

Damit ist das Problem der Erreichbarkeit wahrscheinlich schon erledigt.

Wenn das aber so, wie es z.Zt. konfiguriert ist, nicht stabil läuft, ist da was im Argen.

Sollte dieses Routing über die Solaris nur für dieses eine Problem eingerichtet worden sein, kannst Du das danach entfernen.

Wenn auch weiterhin Routing erforderlich ist, kann das auch der W2k-Server übernehmen.

 

zuschauer

Link to comment

hallo,

hatte schon ähnliches Problem, aber bitte beschreib doch mal die Netz-Infrastruktur genauer (was für Clients?, Windows-Domäne mit dabei?, etc.).

Ihr verwendet hochwahrscheinlich keinen WINS-Server (oder LMHOST-Dateien), also ist es normal, das der Netbios-Name des W2K-Servers im anderen Subnet nicht aufgelöst wird, da ja die Broadcasts zur Namensregistrierung bekanntlich nicht geroutet werden.

Aber in grösseren *nix-Netzen (und jetzt auch WIN2000-Domänen) werkelt ja meist sowieso ein DNS-Server, also einfach einen A-Host-Record...oder doch nicht? ;-)

Aber im Ernst, es gibt viele mögliche Ursachen, der Browser-/Suchdienst von Win ist echt ne üble Sache (nur meine unumstößliche private Meinung).

BTW: Mit Multihomed-Systemen kannst Du Dir unter Umständen neuen Ärger einhandeln, wenn auf diesem Server ein Hauptsuchdienst läuft (such mal im Technet danach).

 

Grüsse

 

Karl

Link to comment

Hallo,

erstmal vielen Dank für die Antworten. Nun unsere Intrastruktur etwas genauer. Wir haben ca. 300 PC's im Netz wobei diese sich auf die beiden Adressbereiche 192.2.133.x und 192.2.132.x aufteilen. Das ist so gewachsen, leider. Die Clients sind wild gemischt W95/W96/WME/W2000. Allerdings kein Problem da wir UNIX nur über VT100-Terminalemulation nutzen und den UNIX-Server nur unter seiner IP-Adresse ansprechen. Aus mangel an Bedarf haben wir somit weder DNS- noch WINS-Server irgendwo laufen.

Nun ist eben zusätzlich dieser WIN2000 Server ins Netz gekommen (mit einer Netzkarte und einer Adresse im Bereich 192.2.133.x). Somit müssen alle PC's welche im 132'er Bereich liegen über den UNIX-Host, welcher als Standard Gateway fungiert. Meist funktioniert es aber oft gibt es eben auch Probleme beim "drüberrouten". Es sind keine physisch getrennten Netzwerke.

Ab besten hat mir der Tip mit der zweiten IP-Adresse auf der Netzkarte gefallen. Im Augenblick hat der WINDOWS-Server ja ebenfalls als Standardgateway den UNIX-Host. Muß ich diesen dann rausschmeissen? Und muß ich noch was anderes, außer dem NIC eine zweite Adresse zu verpassen, auf dem Server machen?

Link to comment

Hi vincenz !

Ja, so wie Du das beschreibst, ist das auch ganz normal bei Windows-Netzwerken. Hätte ich vielleicht doch erstmal in Ruhe darüber nachdenken sollen, das ist kein "kleines Routingproblem", sondern ein Problem des Hauptsuchdienstes in MS-Arbeitsgruppennetzwerken.

Also vorab schon mal: Mit 2 IP´s auf dem W2k-Server löst Du das Problem nicht. Dieser Hauptsuchdienst funktioniert folgendermaßen: Im Netzwerk wird unter den PC ausgehandelt, wer den Hauptsuchdienst für das Netzwerk macht. Der PC, der dort gewinnt, macht den Hauptsuchdienst und alle im Netz fragen diesen PC nach anderen Mitgliedern und deren Freigaben, d.h. es werden nur die angezeigt, die der Hauptsuchdienst-PC kennt. Der Gewinner bei den Verhandlungen ist der PC mit dem "besten Betriebssystem" und der längsten online-Zeit, also sehr wahrscheinlich der W2k-Server. Dieser Hauptsuchdient hängt sich aber selber immer nur an ein Subnetz. Das würde bei zwei IP auf dem w2k-Server bedeuten, alle sehen nur ein Subnetz. Welches das ist, ist laut MS Zufall, fifty/fifty. Genau das ist bei Dir eingetreten bei Deinem Test.

Als einzige Lösung für Dein Problem sehe ich den Einsatz eines Wins-Servers auf dem w2k-Server mit nur einer IP. Diesen Wins-Server mußt Du dann an allen beteiligten Clients eintragen. Das Routing über die Solaris-Maschine muß bestehen bleiben. Wenn die Sache läuft, sind Deine "RoutingProbleme" wahrscheinlich gelöst, weil es kein wirkliches Problem des Routings ist.

Dieser Hauptsuchdienst fragt nämlich auch die Informationen der WinsServerDatenbank ab, somit werden beide Subnetze in der Netzwerkumgebung der Clients angezeigt. Aber eben nur, wenn der Hauptsuchdienst selber nur eine IP hat.

Ich geb zu, diese MS-Lösung ist nicht die Feinste, aber damit muß man leben (oder ohne MS leben). :D

 

Gruß Nino

Link to comment

Hi i.robot (karl) !

Bin leider gleich auf den damals letzten Beitrag von vincenz gesprungen und hab dabei Deinen Beitrag übersehen. :(

Da sind wir ja schon mal zwei mit den gleichen Erfahrungen zum Hauptsuchdienst von MS.

Ich glaube aber nicht, daß sich vincenz ein gesamtes Domänenkonzept aufdrängen lassen will.

Bist Du auch der Meinung, daß sein Problem mit einem Wins-Server in einer Arbeitsgruppe lösen läßt ?

Hab ich noch nie probiert, Arbeitsgruppe und Wins-Server...

 

Gruß Nino

Link to comment

hi nino,

um einen Router zu überbrücken brauchst du den WINS und NetBIOS over TCP/IP (kann ja unter W2K/XP deaktiviert werden). DC nicht erforderlich, Server genügt. Ich hab hier z.B. drei entfernte Subnetze (Arbeitsgruppen, keine DOM) per Router zu Router VPN-Verbindung zusammengelegt.

 

Natürlich möchte ich nichts aufzwängen, aber bei der Anzahl an PC in dieser Umgebung (Krankenhaus): wie soll das vernünftig administrierbar sein, von der Sicherheit ganz zu schweigen??!!!

OK, ist ein anderes Prob., aber wenn´s schief geht schreit alles nach dem Admin. Also auch Selbstschutz, sogesehen :-)

Link to comment

Erstmal vielen Dank für die zahlreichen Tips. Wie ich schon schrieb haben wir bis zur Einführung des W2K-Server nie Probleme gehabt da wir von den Clients nur Telnetsessions mit direkter Angabe der IP-Adresse gefahren haben und auch fahren werden. Im Augenblick verbinde ich die Freigaben, bei Rechnern aus dem 132'er Netz, mit z.B. "\\192.2.133.200\Dokumente", was auch funktioniert bis auf Hänger welche durch den UNIX-Router erzeugt werden. Gibt es jetzt nicht z.B. die Möglichkeit das ich eine weitere Netzkarte in den Windows-Server einbaue und diese z.B. mit der Adresse 192.2.132.200 belege? Freigaben würde ich dann z.B. mit "\\192.2.132.200\Dokumente" ansprechen.

Wenn das funktionieren würde, müsste ich noch irgendwas anderes im System einstellen bzw. konfigurieren?

 

Viele Grüße

Uwe

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...