Jump to content

Probleme mit ntbackup


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo zusammen,

 

ich bin schon einige Zeit in diesem Forum unterwegs, hauptsächlich als Leser. Nun habe ich selber ein Problem, was mir wirklich Kopfzerbrechen bereitet. Es geht mal wieder um das viel diskutierte NTBackup.

 

Systembeschreibung und Zielsetzung:

 

Server: SBS 2003 als DC und Exchange

Clients: WXP

 

Seit der Einrichtung des Servers kämpfe ich nun mit dem Backup. Ein tägliches Backup (Mo - Fr) soll laufen und die Daten sollen auf ein HP DDS4-Laufwerk gespeichert werden.

Zur Zeit versuche ich es mit einem cmd-File welches über den Taskplaner gestartet werden soll. Der Task wird unter dem Administrator-Konto ausgeführt.

 

Das Skript sieht wie folgt aus:

 

echo off

 

rsm.exe refresh /LF"Hewlett Packard DDS4 drive"

 

sleep 30

 

for /f "Tokens=1-4 Delims=/ " %%i in ('date /t') do set dt=%%i-%%j-%%k-%%l

for /f "Tokens=1" %%i in ('time /t') do set tm=-%%i

set tm=%tm::=-%

set dtt=%dt%%tm%

 

c:\winnt\system32\ntbackup.exe backup "@C:\Dokumente und Einstellungen\Administrator\Lokale Einstellungen\Anwendungsdaten\Microsoft\Windows NT\NTBackup\data\backup_standard.bks" /n "%computername%-%dtt%" /d "daily %dtt%" /v:yes /r:no /rs:no /hc:on /m normal /j "daily %dtt%" /l:f /p "4mm DDS" /UM

 

rsm.exe eject /PF"%computername%-%dtt% - 1" /astart

exit

 

Problembeschreibung

 

Es treten verschiedene Probleme dabei auf.

 

1. Das Skript wird gar nicht gestartet und es wird auch nichts ins Ereignisprotokoll eingetragen

 

2. Das Skript (Backup) wird gestartet, bricht aber sofort wieder ab. Im Ereignisprotokoll findet sich dann folgender Eintrag:

 

Ereignistyp: Fehler

Ereignisquelle: NTBackup

Ereigniskategorie: Keine

Ereigniskennung: 8017

Datum: 21.10.2004

Zeit: 21:00:29

Benutzer: Nicht zutreffend

Computer: SERVER

Beschreibung:

NTBackup-Fehler: 'Das angeforderte Medium wurde nicht bereitgestellt. Der Vorgang wurde abgebrochen.'

 

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.'>http://go.microsoft.com/fwlink/events.asp.

 

3. Das Skript (Backup) startet, bricht aber mitten im Vorgang ab. Im Ereignisprotkoll findet sich folgender Eintrag:

 

Ereignistyp: Fehler

Ereignisquelle: NTBackup

Ereigniskategorie: Keine

Ereigniskennung: 8019

Datum: 27.10.2004

Zeit: 23:14:59

Benutzer: Nicht zutreffend

Computer: SERVER

Beschreibung:

Vorgang beenden: Es wurden Warnungen oder Fehler gefunden.

Weitere Informationen finden Sie im Sicherungsbericht.

 

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.

 

Die gesamte letzte Woche ist nur das erste Problem aufgetreten, es passierte sozusagen gar nichts.

 

Lösungsversuche:

 

1. Update der Firmware des Bandlaufwerks

 

2. Update der Treiber des Bandlaufwerks

 

3. Administrator angemeldet lassen

 

Ich finde es nur kurios, dass das Skript nicht einmal gestartet wird und auch nichts im Ereignisprotokoll eingetragen wird. Es laufen auch keine anderen Programme zu dem Zeitpunkt (Virenscan usw.).

 

Entschuldigt diesen langen Thread, aber ich denke durch eine genaue Beschreibung könnt Ihr mir vielleicht besser helfen.

 

Gruß

Malte

Link to comment

Das Skript sieht wie folgt aus:

 

echo off

 

rsm.exe refresh /LF"Hewlett Packard DDS4 drive"

 

sleep 30

 

for /f "Tokens=1-4 Delims=/ " %%i in ('date /t') do set dt=%%i-%%j-%%k-%%l

for /f "Tokens=1" %%i in ('time /t') do set tm=-%%i

set tm=%tm::=-%

set dtt=%dt%%tm%

 

c:\winnt\system32\ntbackup.exe backup "@C:\Dokumente und Einstellungen\Administrator\Lokale Einstellungen\Anwendungsdaten\Microsoft\Windows NT\NTBackup\data\backup_standard.bks" /n "%computername%-%dtt%" /d "daily %dtt%" /v:yes /r:no /rs:no /hc:on /m normal /j "daily %dtt%" /l:f /p "4mm DDS" /UM

 

rsm.exe eject /PF"%computername%-%dtt% - 1" /astart

exit

[/b]

 

Habe selber den Fehler gefunden :) . Die Pfadangabe zu ntbackup kann bei einem 2003er Server gar nicht funktionieren (c:\winnt\system32\ntbackup.exe).

 

Die letzte Woche lief das ganze auch ohne Probleme. Mal schauen wie es sich nun auf die Dauer verhält.

 

Gruß

Malte

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...