Jump to content
Sign in to follow this  
Mensch

Anmeldung am SQL-Server

Recommended Posts

Hallo zusammen,

 

bis vor kurzem konnte ich mich für Abfragen über Access ganz normal per NT-Authentifizierung auf den SQL-Server anmelden.

Das geht seltsamerweise seit 2 Tagen nicht mehr.

Bin aber immer noch als Benutzer dort angelegt mit Leserechten für die betreffende Datenbank. Auch ein neu anlegen des Benutzers hat nichts gebracht, ausser dass ich eine bestehende AccessDatei damit nicht mehr benutzen konnte.

 

Folgende Fehlermeldung bekomme ich immer wenn ich mich versuche anzumelden um Daten zu lesen.

 

Microsoft SQL-Server Anmeldung

 

Fehler bei der Verbindung:

SQL State: 'S1000'

SQL Server-Fehler: 0

[Microsoft][ODBC SQL Server Driver] Der SSPI Kontext kann nicht erstellt werden

 

 

Weiss hierzu jemand, was da faul ist ?

Ich vermute der Treiber ist nicht mehr korrekt auf dem PC beziehungsweise muss irgendwas damit defekt sein.

 

Was kann ich da tun? Gibt es eine Möglichkeit wie ich den notfalls wieder aufspielen kann ohne groß das ganze System umkrempeln zu müssen?

 

Vielen herzlichen Dank für jede Hilfe die ihr anbieten könnt.

 

Gruß

 

 

Mika

Share this post


Link to post

Tatsache, der erste Tipp (Link) war Gold wert.

 

Es wurde eine Verbindung zum Server anhand der Server IPAdresse aufgebaut. Das hat er wohl nicht gewollt. Habe nun etwas herumprobiert und anstatt der IPAdresse den DNS-Namen versucht und jetzt geht wieder alles.

 

Bist ein Schatz :)

 

Danke dir!

Share this post


Link to post

So vorhin hab ich meinen PC rebooten lassen und plötzlich hab ich den selben Mist wieder. Was kann das denn sein?

 

Diesmal funktioniert nicht mal das umbenennen der IP in den DNSNamen.

Share this post


Link to post

Danke für den Tipp

 

Jetzt muss ich nur schaun dass ich ne gewisse Menge an Posts habe :) Sonst geht da nix mit PNs versenden.

Share this post


Link to post

Hast du probiert eine Neue ODBC verbindung zu machen?

 

Was passiert dann?

Wurde vielleicht am SQL Server was geändert?

Geht der Ping über IP und über Name?

Vielleicht ist bei dir in deinen IP Konfigurationene ein falscher DNS Server eingetragen ist. Prüfe mit ipconfig /all deine IP Einstellungen.

 

Gruß

 

Bienchen

Share this post


Link to post

Funktioniert alles wunderbar, ich vermute fast dass er immer bei ner Anfrage an den Server irgendwo stecken bleibt und die Anfrage daher noch aktiv ist irgendwo und ich mich deshalb nicht mehr anmelden kann neu. Denn am nächsten Tag geht es seltsamerweise wieder ne Zeit lang und dann is wieder Ende.

 

DNS und IP Eintrag stimmen überein.

 

Weiss jemand wo in der Registry die Daten zur Anmeldung hinterlegt sind? Will da mal nachsehen ob ich da was sehen kann das sich verändert vielleicht.

 

Was er mir immer verstellt bzw. nicht will ist die Authentifizierung.

Am Anfang funktioniert alles wunderbar mit der NT-Auth bei der Anfrage an den SQL. Irgendwann frisst er die aber nimmer und ich komm nur noch per SA-Anmeldung an die Abfragen. Wo kann denn da der Wurm sein?

 

 

Gruß

 

Der Mensch

Share this post


Link to post

Tja,

ich habe selbes Problem.

 

Zu meinem Netzwerk:

 

ADC - Win2003 Server

FS = SQL-Server SP3 Win2000 Server SP4

 

Client XP Prof SP2

 

Zugriff funktioniert funktioniert am anfang und wenn ich eine Zeit (nicht definiert, mal 5 min. mal 30 min.) dann zugreife bekomme ich die Meldung auch vom SSPI.

 

Wenn ich selbes mit einem anderen Client (Win2000) ausprobiere, kann ich so lange ich will nicht zugreifen und das ganze funktioniert einwandfrei.

 

Muß man die logik noch von MS verstehen??

 

Ich bin mit meiner Weisheit am ende.

 

Ping über Name, als auch IP funktioniert.

 

DNS-Server ist konfiguriert und funzt, siehe Ping.

 

Erst nachdem ich mich abgemeldet habe und neu angemeldet habe funktioniert das ganze wieder.

 

Ich bin auch nicht der eizige, ein Bekannter mit SQL-Server und Win2k Server (ohne den 2k3-Server) und einem XP und einem 2000 Client hat genau das selbe problem.

Share this post


Link to post

Hi,

 

das Problem besteht bei mir nach wie vor.

 

Ich habe ein Programm geschrieben, mit dem man sich per NT-Auth am SQL anmeldet um gewisse Abfragen auszugeben.

 

Hier verwendete ich unter anderem bei der Connection zum Server die Option "Persist Security Info=True". Dachte es würde an dieser Option liegen. Hatte davor auf "False" stehen. Leider wars das auch nicht.

Eine offene Verbindung ist es auch nicht, da der User seine Daten für die Abfrage eingibt, dann startet, Verbindung zum Server wird aufgebaut, Abfrage ausgeführt, Verbindungen wieder alle korrekt geschlossen.

 

Das Problem taucht auch erst dann auf, wenn ich das eigene Programm benutzt habe und dann Access 2000 verwende mit dem ich irgend eine Abfrage am Server starte. Wenn ich dann das eigene Programm wieder verwende kann ich mich mit der NT-Auth dort nicht mehr anmelden und bekomme einen Fehler. Das selbe wenn ich jetzt wieder Access verwenden möchte bekomme ich ebenfalls einen Fehler.

 

Meiner Meinung nach werden hier zweierlei Anmeldungen bzw. verschiedene Optionen bei der Anmeldung verwendet, die er irgendwo hinterlegt und die dann beide nicht mehr für die jeweiligen Programme brauchbar sind, bis man eben den PC neu gestartet hat und somit irgendwelche Einträge (wo immer die drinstehen und reingeschrieben werden) gelöscht sind.

 

Leider bin ich nicht viel weiter gekommen und habe bis jetzt nicht raus finden können wo das Problem genau zu finden ist. Jedoch denke ich dass es mit der Verwendung zweier verschiedener Programme zu tun hat, die sich unterschiedlich anmelden am Server.

 

Vielleicht weiss ja noch jemand nen Rat hierzu.

 

Soweit von mir.

 

Gruß

 

 

Der Mensch

Share this post


Link to post

Was ich herausbekommen habe und zur Zeit so mir behelfe:

 

Ich gehe nicht über die Rechteverwaltung des ADC, sondern über die rechteverwaltung des SQL-Servers.

 

Ich baue also eine Verbindung auf mit einem Benutzer der nur auf dem SQL-Server existiert und nicht in dem ADC.

So bleibt meine Verbindung bestehen und bricht auch nicht ab, aber das kann nur eine kurzfristige Lösung sein, weil sonst brauche ich keine 2 Server mit 1 ADC.

 

Es scheint mit der Rechteverwaltung zusammen zu liegen und der Autentifizierung vom Server bei einem XP prof Client.

 

Vieleicht bekommt so einer den Richtigen kick, der uns weiter hilft.

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...