Jump to content
Sign in to follow this  
Kaczy

Routing zwischen 2 NW-Karten

Recommended Posts

Hallo,

 

ich habe 2 Wireless-NW-Karten. Davon Steckt eine in meinem Notebook, und die andere in einem Desktop-PC. Auf beiden Rechnern ist W2k installiert. Und die Rechner sehen sich auch über die Funkkarten. Nun möchte ich aberm dass ich vom Notebook aus einen vollwertigen Zugriff auf das Netzwerk bekommen, also alle Rechner, Drucker, etc. sehe, die sonst noch im Netz sind, und ebenfalls den Zugriff auf den Internetrouter habe.

Dazu ist der Desktop mit einer zweiten Netzwerkkarte ausgestattet, die auf dem Hub steckt. Vom Desktop aus habe ich bereiteits zugriff auf alle NW-Resourcen (Drucker, Router, PC's, Server)

Die Konfiguration sieht wie folgt aus:

Notebook: IP: 192.168.2.1 (WLAN)

Desktop: IP: 192.168.2.20 (WLAN)

Desktop: IP: 192.168.1.20 (LAN)

 

Wie bekommt man hin, das der Desktop zwischen den beiden Karten routet?

 

Ich danke schonmal im voraus.

 

Gruß

Kaczy

Share this post


Link to post
Share on other sites

Hi Kaczy!

Dafür gibt es den Befehl "route"

Wenn du diesen mal auf der CMD-Konsole eingibst, siehst du die Parameter. "route print" gibt dir die aktuelle Routingtabelle aus. mit "route add" kannst du manuell Routen hinzufügen. Zur genauen Synthax gibt dir die W2K Onlinehilfe Auskunft.

Hoffe, dir geholfen zu haben.

Share this post


Link to post
Share on other sites

moin un willkommen onboard :p

 

Notebook: IP: 192.168.2.1 (WLAN)

Desktop: IP: 192.168.2.20 (WLAN)

Desktop: IP: 192.168.1.20 (LAN)

 

nimm bei den WLAN's die sumnetzmaske ( 255.255.255.0 ) deines

normalen lans .

 

wie siehts mit benutzerrechten aus ? hast du einen user angelegt ? oder wie regelst du des?

 

greez basti

Share this post


Link to post
Share on other sites

Hallo,

 

danke für die Antworten.

@Basti:

Wie meinst Du das mit den Subnetzmasken? Ich habe bei beiden Netzen die Maske 255.255.255.0 genommen.

Bei den Benutzerrechten habe ich mir erstmal keine Gedanken gemacht. Ich arbeite mit allen in einer Arbeitsgruppe. und habe aucf jedem Rechner mindestens ein Laufwerk freigegeben. Da kann man sich dann erstmal als Administrator anmelden.

 

@marka:

den befehl route kenne ich bereits, habe aber damit noch nichts hinbekommen. vieleicht könntest Du mir ein Beispiel für meine Konfiguration schreiben, da ich aus den Beispielen der Onlinehilfe nicht ganz schlau gworden bin.

Es müssen doch bestimmt auf dem Desktop 2 Routen eingetragen werden (hin und zurück), damit es klappt, oder?

 

Gruß

Kaczy

Share this post


Link to post
Share on other sites

Nein, das geht nicht. nur nach Desktop: IP: 192.168.2.20 (WLAN).

Da dachte ich ja, das ich auf dem Desktop eine entsprechende Route per Route-Befehl definieren muss, aber wie?

Gruß

Kaczy

Share this post


Link to post
Share on other sites
Original geschrieben von Kaczy

Die Konfiguration sieht wie folgt aus:

Notebook: IP: 192.168.2.1 (WLAN)

Desktop: IP: 192.168.2.20 (WLAN)

Desktop: IP: 192.168.1.20 (LAN)

 

Synthax:

vom Notebook zum lan

route -p add 192.168.2.20 mask 255.255.255.0 192.168.1.20

-p steht für permanente Route

vom lan zum notebook

route -p add 192.168.1.20 mask 255.255.255.0 192.168.2.20

Share this post


Link to post
Share on other sites

des forwarding musst du erst aktivieren .

( das die 2 karten miteinander kommunizieren )

 

Damit du den Eintrag verändern kannst musst du zuerst das Programm Regedit unter (Start/Ausführen/[Regedit]) ausführen und dort folgenden Key suchen.

 

HKEY_LOCAL_MACHINE \SYSTEM\CurrentControlSet\Services\Tcpip \Parameters

 

 

http://www.netfuse.de/techarea/routerw2k/regbig.gif

 

 

Der Wert IPEnabelRouter ist default auf 0 diesen musst du auf 1 setzen damit das Routing aktiviert wird

 

denn neubooten

Share this post


Link to post
Share on other sites

Ich habe jetzt den Eintrag in der Registry auf 1 gesetzt und gebootet.

Leider kann ich schon die 1. genannte Route nicht hinzufügen

Fehler: 'Hinzufügen der Route fehlgeschlagen: Der angegebene Maskenparameter ist ungültig. (Ziel & Maske) != Ziel.'

 

Gruß Kaczy

Share this post


Link to post
Share on other sites

Tausch mal die IP-adressen von Ziel und Gateway...

Hab' ewig nicht mit route add gearbeitet, hab's mir selber gerade aus der Hilfe gezogen. Würd's ja gern probieren, aber dann müsste ich immer hin und herrennen, da ich gerade an'ner Linuxkiste sitze und der W2K-PC keinen Internetaccess hat, könnte ich zwar einrichten, dann müßte ich aber an den Proxy.

Probier's einfach mal, learning by doing - try and error.

Spielen wir die "Was-passiert-dann-Maschine" ;)

Share this post


Link to post
Share on other sites

das wäre ja dann genau die 2. Route, die Du oben geschrieben hast. die gehen beide nicht. Ich denke lt. Fehlermeldung muss es an der Subnetzmaske liegen, oder? Ich habe damit auch rumprobiert, aber ohne erfolg.

Gruß Kaczy

Share this post


Link to post
Share on other sites

Also:

 

route -p add <zielnetzwerk> mask <subnetzmaske> <gatewayadresse>

BSP:

Rechner als Router mit 2 NIC's:

erste NIC: 192.168.1.20

zweite NIC: 192.168.2.20

 

Routing vom 1er ins 2er Netz:

route -p add 192.168.2.0 mask 255.255.255.0 192.168.1.20

 

"Ich will ins netz 192.168.2.0/24 über das GW 192.168.1.20"

 

So müsst's passen...hoffe ich

 

<edit>

Hab's probiert --> klappt!

</edit>

Share this post


Link to post
Share on other sites

Ich bekomme es nicht hin.

Ich habe jetzt

route add 192.168.2.0 mask 255.255.255.0 192.168.1.20

eingegeben.

das Problem ist ja auch noch, das ein 3. Rechner ja auch erst mal wissen muss, wo er die 192.168.2.20 findet.

Das habe ich in meinem Router eingestellt, dort als statische route zum 2er netz (192.168.2.0) den Gateway 192.168.1.20 eingestellt. Dabei brauche ich auch nichtmal im desktop eine route einstellen, das schein so zu gehen (zumindestens ping) in der NW-umgebung ist das notebook nicht zu sehen.

ich denke das liegt an der rückrichtung, die muss dann noch auf dem desktop zum router gehen.

ich kann aber immer noch nicht vom notebook ins 1er netz pingen

 

dazu habe ich dann auch noch

route add 192.168.1.0 mask 255.255.255.0 192.168.2.20

eingebeben.

aber das brachte auch nichts.

 

Gruß Kaczy

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...