Jump to content
Sign in to follow this  
basty

ISAPNP.SYS nachinstallieren?

Recommended Posts

Hallo an Alle,

 

ich habe mit folgendem System Probleme:

 

Brett: ASUS P4C800-E Deluxe, i875,

CPU: Intel P4 HT 2.80 GHz

RAM: 1 GB

HDD: Maxtor 120 GB an S-ATA

OS: Win2k pro (SP4)

 

Der Rechner startet etwa wie folgt:

 

- als erstes kommt der SplashScreen von Asus

- dann scannt der Promise FastTrak 378 1.00.0.37 die IDE Busse

findet nix und

- dann kommt kurz MegaTrends Bios

- dann Win2k, welches meldet:

System konnte nicht gestartet werden, da folgende Datei fehlt

oder beschädigt ist:

\WINNT\SYSTEM32\DRIVERS\isapnp.sys

 

Win CD einlegen, "R" drücken um Setupreparatur zu starten

 

Der Rechner ist etwa 2 Monate alt. Naja. Meine Frage an Euch: Soll ich wirklich die Reparaturkonsole benutzen? Besteht damit die Gefahr von Datenverlust? Oder hat jemand einen anderen Ansatz. (Wie immer sind ungesicherte Daten auf der Platte die Cheffe haben will :eek: )

 

P.S.: Im BIOS wird die Festplatte erkannt..

 

Vielen Dank für jede Antwort,

Grüsse BASTY

Share this post


Link to post

Das gleiche Problem habe ich - Habe schon ziemlich viel rumgesurft und habe diese Info gefunden: Schlau bin auch noch nicht geworden. Werde die Tips aber austesten

 

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Fehlermeldung beim Starten von Windows XP: Isapnp.sys kann nicht geladen werden

 

HDD löschen dürfte nicht ausreichen.

isaPnP.sys kommt vom Bios heraus. Teilweise kommt´s aber manchmal auch vom Betriebssystem. Da die Meldung isaPnP.sys defekt kommt, muss man zuerst sichergehen, dass vom Bios heraus keine Fehler zu erwartern sind. Wenn da alles in Ordnung ist und der Fehler weiterhin besteht, Sind eventuell Bioseinstellungern fehlerhaft oder der Arbeitsspeicher hat ne Macke. Vielleicht ist die CD fehlerhaft? Wir fangen aber lieber mit nem Biosupdate an.

 

Möglichkeit 1

 

Hinter das /fastdetect schreibste noch /SOS /BOOTLOG

also Beispiel:

 

[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional/HOME" /fastdetect /BOOTLOG

 

Dann wird ne NTBTLOG.TXT erstellt wo drinsteht welche Treiber etc geladen wurden und welche fehler aufgetreten sind.

 

Kannst auch noch /SOS dahinter setzen dann wirds auch am Bildschirm angezeigt

 

Ergebnis:

 

 

 

schau auch mal in der msconfig nach

 

Möglichkeit 2

 

Code 2

Abhängig davon, bei welchem Gerät ein Fehler auftritt, wird eine von zwei verschiedenen Meldungen angezeigt. Dieser Code bedeutet, dass das Geräteladeprogramm (DevLoader) ein Gerät nicht geladen hat. Wenn dieses Gerät ein Root Bus DevLoader ist (zum Beispiel ISAPNP, PCI oder BIOS), wird die folgende Meldung angezeigt:

Dieser Gerätetreiber konnte nicht geladen werden, da zwei <Typ> Bustypen vorhanden sind. (Code 2)

 

Fordern Sie beim Hersteller ein aktualisiertes BIOS für den Computer an.

[Windows could not load the driver for this device because the computer is reporting two <type> bus types. (Code 2)

 

Contact your computer manufacturer to get an updated BIOS for your computer.]

 

Dabei ist <Typ> ISAPNP, PCI, BIOS, EISA oder ACPI.

 

Lösungsschaltfläche: Keine

 

Ist das Gerät kein Root Bus DevLoader, wird die folgende Meldung angezeigt:

Das Geräteladeprogramm <Typ> konnte den Gerätetreiber nicht laden. (Code 2)

 

Klicken Sie auf "Treiber aktualisieren", um das Problem zu beheben.

[The <type> device loader(s) for this device could not load the device driver. (Code 2)

 

To fix this, click Update Driver to update the device driver.]

 

Dabei ist <Typ> der DevLoader, wie beispielsweise FLOP, ESDI, SCSI etc.

 

Lösungsschaltfläche: Treiber aktualisieren

 

Zusätzlich zu der empfohlenen Lösung können Sie versuchen, das Gerät aus dem Geräte-Manager zu entfernen, und anschließend den Hardware-Assistenten ausführen.

 

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Share this post


Link to post

Ist doch klar das der Fasttrak Controller keine Platte findet, oder liege ich falsch! Wenn du die Platte im BIOS siehst dann bedeutet das das sie am ICH-5 oder ICH-6 IDE Controller dran hängt! Also am 1. Controller.

Share this post


Link to post

Ja und was heißt das jetzt für mich ?

 

Vielleicht kannst du mir das noch einmal erkären , wäre Super

 

daruma

Share this post


Link to post

Also das ganze sieht so aus:

 

Dein Board hat den Intel Chipsatz 875P, dieser hat einmal die Southbridge ICH5R (R steht für RAID) und zudem hat dein Board noch einen OnBoard Promise SATA RAID Controller. Das heißt du hast 2 von einander unabhängige IDE Controller die theoretisch jeweils 4 IDE Geräte verwalten können! Wenn du also deine Festplatte im BIOS siehst dan bedeutet das das du sie über die Southbridge ansteuerst, deshalb ist sie beim Boot vorgang des Fasttrak Controllers nicht zu sehen!

 

Mache am besten einen BIOS Reset, um wie du schon gefunden hast, sicherzustellen das keine Fehlerhaften werte des BIOS dieses Problem hervorrufen! Wenn das nichts bringt probiere den Fasttrak Controller im BIOS zu deaktivieren da du ihn scheinbar eh nicht brauchst!

 

Wenn du die wichtigen Dateien die dein Cheff unbedingt braucht nicht mit EFS verschlüsselt hast, dann häng die Platte als Sec in einen anderen rechner und boote von einem anderem System. Dann kannst du wenigstens alle wichtigen daten sichern bevor du dich an eine Systemdestabilisierende Reparaturinstallation machst! Denn die 1. Probleme können schon auftauchen wenn auf der Setup CD ein anderes SP drauf ist!

 

Leider kann ich deinen Fehler nicht nachvollziehen da mir sowas noch nie passiert ist (auf Holz klopft).

 

Kleiner Tip: Wenn du Sensible Daten auf deinem Rechner hast dann solltest du entweder 2 oder mehr Festplatten verwenden, oder wenigsten per unterschiedlichen Partitionen, System Daten von Sensiblen Daten trennen! Und natürlich Backups Backups Backups

Share this post


Link to post

Hallo Lockhead,

 

das ist ein ganz frisch aufgesetzter Rechner -> Werde aber ein Sicherungsimage ziehen.

 

Danke für die Super Erklärung . Werde dir und Euch darüber berichten.

 

daruma

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...