Jump to content
KNL

Hyper-V Default Switch vermisst

Recommended Posts

Hallo zusammen,

 

nach aller Inet-Recherche bekomme ich das Problem nicht gelöst. ... Vllcht könnt Ihr mir ja weiterhelfen *hoff ;)

 

Ich habe ein Win10-System mit aktiviertem Hyper-V. Im Hyper-V-Manager ist jedoch kein Default-Switch (Standardswitch) aufgelistet, welcher ja standardmäßig vorhanden, nicht konfigurierbar und ebenfalls nicht löschbar ist.

 

Das Win10-PatchLevel ist : [Version 10.0.18362.418]

 

sfc + dism melden keine Probleme.

 

Dienst stoppen und starten bringt nichts. (net stop/start vmms).

 

Das Hyper-V-Feature habe auch ich schon mehrfach deaktiviert. Rebootet. Wieder aktiviert. Kein Erfolg.

 

Zusätzlich habe ich das hier probiert: https://support.microsoft.com/en-us/help/3101106/you-cannot-create-a-hyper-v-virtual-switch-on-64-bit-versions-of-windo.

 

Gerätemanager sieht gut aus. Der Screen hier ist mit aktivierten "ausgeblendeten Geräten".

image.png.344d16fd92ed47d424f6895d0651d433.png

 

Auch ein Win10 - InPlace-Upgrade brachte keine Erfolg.

 

Wie bekomme ich den Default-Switch wieder bzw. warum fehlt er?

 

Vielen Dank vorab für jegliche Rückmeldung.

 

Mfg KNL

 

P.S. Im MS Tech-Net-Forum hab ich auch Post zu dem gleichen Thema offen ... aber da rührt sich leider nix :|

Share this post


Link to post
Share on other sites

Hi,

 

laut deinem Screenshot hast du einen vSwitch der vermutlich an die einzige NIC gebunden ist. An der Stelle kann dann der Default Switch ja auch nicht mehr, wie auch immer, erstellt werden, da nur eine physikalische NIC vorhanden ist und du pro pNIC nur einen vSwitch haben kannst.

 

Hast du testweise den vSwitch HLS mal gelöscht und das System durchgebootet?

 

Je nachdem was das Win10 sonst noch so tut, wäre der einfachste Weg vermutlich, das System komplett neu zu installieren.

 

Gruß

Jan

Share this post


Link to post
Share on other sites

Moin,

 

ja aktuell ist die einzige NIC der VM mit dem vSwitch HLS verbunden. 

 

Nichts desto trotz müsste doch im "Manager virtuelle Switches..." auch der Default Switch aufgelistet sein. So dass ich die NIC auch an den "Default Switch" binden könnte. So ist es zumindest auf anderen Vergleichs-Systemen die ich hier "zur Hand" habe.

 

Der von mir manuell angelegte externe vSwitch HLS wurde/wird jedes mal gelöscht wenn ich das Hyper-V-Feature deaktivert - gebootet - und später wieder aktiviert habe.  Dies hab ich diverse Male vollzogen.

 

Hmm... ja Neuinstallieren ... sehr schwieriges Thema... wenn da irgend ein Weg drum herumführen würde...

 

Share this post


Link to post
Share on other sites

Mit "netcfg -d" kannst Du die gesamte Netzwerkkonfiguration zurücksetzen. Ich würde Hyper-V deinstallieren, die Konfiguration zurücksetzen und danach Hyper-V wieder installieren.

 

Allenfalls auch in der Registry prüfen, ob noch alte Einträge vorhanden sind nach der Deinstallation von Hyper-V: https://rlevchenko.com/2014/07/28/hyper-v-3-0-interaction-with-registry-and-how-it-was-in-2008-r2/ Einen offiziellen Link von Microsoft zum Thema habe ich leider nicht gefunden. Müsste ja schon irgendwie zu erfahren sein, wo die Konfiguration vom Hyper-V gespeichert ist...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Werbepartner:



×
×
  • Create New...