Jump to content
Sign in to follow this  
mwiederkehr

Netzwerkkarte austauschen bei Server 2016 in Cluster

Recommended Posts

Hallo zusammen

 

Bei einem Windows 2016, welcher Mitglied in einem Cluster mit Hyper-V ist, muss das Board ausgetauscht werden. Damit gibt es auch andere Netzwerk-"Karten". Also andere MAC-Adressen, der Typ der Karten bleibt gleich. Es sind 2x 1 Gig, konfiguriert als Team im Windows für das Management sowie 4x 10 Gig, wovon zwei zu einem vSwitch gehören und zwei ohne Teaming für iSCSI verwendet werden. Auf dem vSwitch basieren ein paar vNICs mit unterschiedlichen VLAN-IDs.

 

Windows wird die neuen Schnittstellen unabhängig von den alten erkennen. Deshalb die Frage, wie man das am besten wieder konfiguriert. Gibt es einen "Trick" über die Registry, um zu sagen "Karte 1 mit MAC X" hat jetzt "MAC Y", so dass alles erhalten bleibt?

 

Sonst hätte ich die entfernten Karten aus dem Gerätemanager gelöscht, die neuen Karten wieder gleich benannt, den Teams hinzugefügt und die vorgängig per netsh gesicherte IP-Konfiguration wieder eingespielt. Bleiben das Team und der vSwitch erhalten, wenn die zugehörigen Adapter gelöscht werden? Oder besser erst die neuen Karten dem Team und vSwitch hinzufügen und dann die alten löschen?

 

Vielleicht hat ja schon mal jemand eine solche Übung gemacht, besten Dank jedenfalls für eure Tipps.

Share this post


Link to post
Share on other sites

Nein das wird nix. Du wirst per Powershell das Team bearbeiten müssen (weils per GUI abstürzen dürfte) und entfernst dort die nicht mehr vorhandenen NICs und steckst die neuen wieder rein. Die MAC interessiert beim Team ja nicht. Für deine iSCSI Adapter wirst du afaik einfach alles "neu konfigurieren" müssen. Aber auch da ist die MAC im Endeffekt egal.

Share this post


Link to post
Share on other sites

Vielen Dank für die Antwort! Es hat geklappt und zwar noch besser als ich gehofft habe: die 10 Gig-Adapter waren DAC und dort ist die MAC logischerweise auf dem SFP+-Modul => bei den vier 10 Gig-NICs hat sich also nichts geändert.

 

Bei den beiden 1 Gig-Adaptern fürs Management war das Verhalten wie folgt: nach dem Start mit den neuen NICs war das Team noch vorhanden, einfach in der GUI nicht mehr sichtbar. Nach dem Löschen der entfernten NICs aus dem Gerätemanager war das Team dann auch in der PowerShell weg und konnte problemlos wieder erstellt werden.

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...