Jump to content

Server 2012 IPV6 + DNS mehrere Adapter + Hyper-V


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hi zusammen,

 

hab einen kleinen Bug der mich mittlerweile in den Wahnsinn treibt :-(

Windows Server 2012 Standard mit mehrere NIC's

1. NIC = DC statische IP z.B. 192.168.10.1

2. NIC = Hyper-V Switch also ohne Protokollbindung

3. Adapter = vEthernet(Hyper-V Adapter) mit der statischen IP z.B. 192.168.10.5

4. NIC = nicht in Betrieb

5. NIC = nicht in Betrieb

 

Problem Nummer 1: IPV6 prio statt IPV4

Leider hat noch nicht jeder Softwarehersteller von IPV6 gehört, zumindest macht es den immer öfter den Anschein. Dies hat zufolge, dass viele Applikation schlicht weg nicht korrekt unter IPV6 arbeiten. Andererseits ist das Protokoll bereits so im Betriebssystem verbreitet, dass die Deaktivierung ebenfalls zahlreiche Problem zu folge hat.

Ganz interessant ist, dass es Windows hier füllig schnuppe ist welche Adapter und Protokollreihenfolge konfiguriert wurde, es antwortet immer Primär mit IPV6.

Das Thema konnte ich über die Regedit lösen: REG_DWORD DisabledComponents mit dem Wert 4120. Hiermit haben sich meine Server zumindest schon mal auf IPV4 besonnen ohne das die IPV6 gebundenen Dienste (z.B. RAS) die Arbeit verweigern.

Also betrachten wir das erste  Problem mal als gelöst :-)

 

Problem Nummer 2: Adapter Reihenfolge

Nun kommt das tolle Verhalten, dass mir mittlerweile einige grauen Haare beschert hat.

Pinge ich den Servernamen z.B. Server 1, dann erhalte ich die als Antwort die Adresse einer der nicht in Betrieb befindlichen NIC's = 169.xxx.xxx.xxx

Pinge ich Servername.domainname z.B. server1.domain.local dann erhalte ich die als Antwort ebenfalls die Adresse einer der nicht in Betrieb befindlichen NIC's = 169.xxx.xxx.xxx

Deaktiviere ich beide NIC's also 4 und 5, so erhalte ich bei ping nun statt der 169..... die Adresse 192.168.10.5 obwohl ich eigentlich die 192.168.10.1 erhalten sollte den die Reihenfolge der Netzwerkkarten wurde folgendermaßen festgelegt:

1. 192.168.10.1

2. 192.168.10.5

3 Hyper-V Switch

4. not in use 1

5. not in use 2

 

Im DNS Server trägt sich die 192.168.10.5 zwar nicht unter dem Servernamen ein, jedoch ist sie unter den übergeordneten Einträgen zu finden.

Im Moment musste ich alle NIC's bis auf die primäre Verbindung deaktivieren da ich den Server anders nicht dzu bringen kann als primäre Verbindung die 192.168.10.1 zu verwenden was dazu führt dass einige Dienste auf dem Server nicht mehr einwandfrei funktionieren.

 

Das einzige was ich möchte ist, dass mein Server generell unter servername und unter servername.domain.local mit der primären Verbindung antwortet auch wenn mehrere NIC's aktiviert sind und ein eigene Adresse haben. Ach so, natürlich habe ich bei es bei den NIC's bereits mit der Einstellung: Adresse dieser Verbindung im DNS registrieren = Disabled versucht.

 

Hat jemand eine Idee wie ich zum Ziel komme?

Danke im Voraus und Gruß

Chris

 

 

 

  

 

 

  • Like 1
Link to comment

Hyper-V erstellt automatisch einen vEthernet(Hyper-V Adapter) sobald ich einen virtuellen Switch konfiguriere. Dieser ist dann an mein Netzwerk connected und bekommt vom DHCP eine IP.

Da ich mit den Hyper-V Machinen sowohl intern als auch extern kommunizieren möchte, benötige ich eine Netzwerkanbindung.

Kann ja eigentlich auch nicht der Sinn der Übung sein alle NIC's abzuschalten oder? Es muss doch möglich sein die Kiste sauber mit mehreren Adaptern zu betrieben.  



Nachtrag:
Habe den letzten Satz überlesen. So Funktioniert es schon mal den der zweite Adapter ist damit nicht für das Verwaltungssystem sichtbar.

Löst aber dennoch nicht das Problem beim Einsatz von mehreren NIC's im Hauptsystem. 

Mit ist natürlich damit trotzdem schon mal geholfen... vielen Dank.

Link to comment
  • 4 months later...

Hallo,
 
das Problem habe ich momentan auch. Der HP Proliant ML350G8 hat 4 Netzwerkkarten. Installiert ist Windows 2012 Server und Hyper-V.
Sobald ich den Server selbst anpingen möchte bekomme ich als Antwort die IP 169.xxx.xxx.xxx.
Mit dem Befehl "netsh interface ip show config" sehe Ich, dass 169.xxx.xxx.xxx einer nicht verbundenen LAN-Verbindung zugewiesen ist.
Pinge Ich den Server selbst an wird immer die Lanverbindung mit 169.xxx.xxx.xxx verwendet statt dem Netzwerkadapter, der in der Reihenfolge vorgegeben ist.
Ein Ping vom Client funktioniert ordnungsgemäß, nur nicht am Server selbst.
Nach viel Probieren habe ich festgestellt, dass die gemeinsame Nutzung in Hyper-V (siehe auch Beitrag von NobertFe) das Problem herbeiführt.
Für VPN-Zwecke mussten wir aber noch einen Netzwerkadapter von SonicFirewall installieren. Nach der Installation ist wieder das gleich Problem aufgetreten, obwohl die "Gemeinsame Verwendung" in Hyper-V deaktiviert war.
 
@christophorus:
Hast Du bereits eine Lösung gefunden? Aktuell habe Ich zwecks der Sonic VPN Verbindung alle anderen Netzwerkkarten deaktiviert und IPv4 und IPv6 aus den nicht benötigten LAN-Verbindungen deaktiviert.
Ich denke auch, dass es ein Bug sein muss oder vielleicht auch mit der Harware zusammenhängt. Hast Du auch einen HP-Server?
Link to comment

Nachtrag:

 

Das Problem ist noch gravierender als angenommen.

Ich habe die Sonic-VPN-Verbindung für einen Dienstleister eingerichtet. Die Sonicfirewall installiert hierfür einen zusätzlichen Netzwerkadapter.

Sobald die VPN-Verbindung hergestellt ist, verwendet der 2012-Server die neue (VPN-)Adresse als primäre IP-Adresse statt der fest vergebenen IP.

Unter Netzwerkverbindungen --> Erweiterte Einstellungen --> Adapter und Bindungen habe Ich die korrekte Reihenfolge bereits angepasst.

Schaut man sich die Übersicht der Netzwerkverbindungen an stellt man auch gleich fest, dass die VPN-Verbindung sich in das Domänennetzwerk einbindet.

Hinter der VPN-Verbindung steht im im Status der lokale Domänname.

Lässt sich noch die Reihenfolge noch irgendwo anders anpassen? Vielleicht Registry?

 

Die einzige Lösung zur Zeit ist in hyper-V mit der Einstellung "Gemeinsames Verwenden dieses Netzwerkadapters für das Verwaltungsbetriebsystem zulassen" zu spielen.

Spielen  deshalb, weil nach einem Neustart des Servers das Problem wieder auftritt, unabhäbgig wie die Einstellung in Hyper-V ist.

Edited by Tschingiskan
Link to comment

Hi Tschingiskan,

 

sehe ich das richtig, dass Du einen DC auf dem physikalischen Host betreibst, gleichzeitig RAS-Einwahlpunkt für VPN und Hyper-V-Host? Ich empfehle Dir, die Komponenten zu entzerren. Lass den Hyper-V-Host Hyper-V-Host sein. Den DC virtualisierst Du darauf in einer Instanz. RAS-Server in einer zweiten. Damit hast Du keinen multi-homed DC und der Stress sollte sich legen.

 

Have fun!
Daniel

Link to comment

sehe ich das richtig, dass Du einen DC auf dem physikalischen Host betreibst, gleichzeitig RAS-Einwahlpunkt für VPN und Hyper-V-Host? Ich empfehle Dir, die Komponenten zu entzerren. Lass den Hyper-V-Host Hyper-V-Host sein. Den DC virtualisierst Du darauf in einer Instanz. RAS-Server in einer zweiten. Damit hast Du keinen multi-homed DC und der Stress sollte sich legen.

 

Der physische Host ist ein DC (migriert von SBS 2003) + Hyper-V (SQL-Server). RAS-Server ist nicht installiert. Die Sonic-VPN-Verbindung ist nur ein Client, der bei Bedarf eine VPN-Verbindung zum Dienstleister herstellt.

Das seltsame Verhalten tritt auch auf wenn Ich bspw. eine zweite Netzwerkkarte ativiere. Am Server kann Ich keine zwei Netzwerkkarten betreiben, da bei Aktivierung der zweiten Netzwerkkarte die IP automatisch dem hostnamen zugeordnet wird.

Die hosts-Datei wird auch komplett ignoriert. Trotz entsprechendem Eintrag wird bei ping auf den Hostnamen immer die IP der zweiten Netzwerkkarte verwendet. :wacko:

 

Hier noch ein Bild von der Konfiguration. Ich vermute, dass die rot markiert Netzwerkkarte nichts in der Domäne zu suchen hat. Aber wie bekomm Ich die da raus?

 

17772805oc.jpg

Edited by Tschingiskan
Link to comment

Nachtrag: Das Problem konnte Ich umgehen, indem Ich die SonicVCPNdeinstalliert habe. Den anderen Netzwerkkarten habe Ich entweder eine feste IP vergeben oder deaktiviert (auch nicht angeschlossene Netzwerkkarten!). Im DNS-Manager --> Eigenschaften vom DNS-Server--> Schnittstellen habe Ich die Option "Nur folgende IP-Adressen" verwendet.

 

Ganz gelöst ist es nicht, weil der Server trotzdem nicht verbunde Netzwerkkarten (per DHCP) bevorzugt obwohl das überhaupt keinen Sinn macht.

Die Sonic-VPN-Verbindung bezieht auch ihre IP per DHCP und war immer die primäre Adresse sobald die Verbindung aktiv war.

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...