Jump to content

Exchange 2007 Zertifikat erneuern - altes noch immer eingebunden


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo erst einmal alle zusammen,

 

ich stehe momentan vor einem etwas seltsamen Problem bzgl. Zertifikats Erneuerung am Exchange 2007.

 

Und zwar habe ich an einem Exchange 2007 über die Powershell die abgelaufenen Zertifikate erneuert und im Anschluss im IIS ua. diese für HTTPS OWA hinterlegt.

Das Problem ist nur, dass immer noch das alte Zertifikat angezeigt wird (Outlook Start Warnung und OWA), obwohl im Zertifikatsspeicher keine alten mehr hinterlegt sind.

 

Die neuen Zertifikate sind auch für die richtigen Services aktiviert, hier die 3 erneuerten Zertifikate:

 

 

Thumbprint         : 95AD75**********10A4E

NotAfter           : 07.05.2018 14:04:14

Services           : SMTP

CertificateDomains : {Sites, ***-SV-0001. **********.local}

 

Thumbprint         : BAC01F**********564B73173

NotAfter           : 07.05.2018 14:03:43

Services           : IMAP, POP, IIS, SMTP

CertificateDomains : {remote. **********.net, **********.net, ***-SV-0001. **********

                     .local}

 

Thumbprint         : 79AECF**********00BCB

NotAfter           : 07.05.2018 14:03:11

Services           : IMAP, POP, SMTP

CertificateDomains : {remote. **********.net, **********.net, ***-SV-0001. **********

                     .local}

 

 

In der Zertifizierungsstelle sind die alten Zertifikate gesperrt und in den LOGs ist nichts ersichtlich.

 

Jemand zufällig eine Ahnung wo er sich das alte Zertifikat herholt und warum das neue nicht angezeigt wird?

 

Besten Dank schon einmal im Voraus,

 

Beste Grüße, mPhin.

 

 

 

PS: ist ein SBS2008 Server.

 

Link to comment

Ich hab's diese Woche schon mal in einem anderen Forum gesagt und vermute, dass hier das gleiche Problem ist:

 

Die Differenz kommt daher, weil Du manuell an den IIS-Einstellungen rumgespielt hast.

Die müssen (und dürfen) nicht angefasst werden, die Einstellungen dort macht Exchange.

Für eine normale Exchange-Installation muss man niemals den IIS anfassen, Exchange macht ALLES dort selbst. Und wenn man den IIS anfassen muss, dann sollte man sich dringend fragen, warum!

 

Hast Du die Zertifikate mit "Enable-ExchangeCertificate" aktiviert? Wenn nein, hol das noch mal nach.

Link to comment

Die müssen (und dürfen) nicht angefasst werden, die Einstellungen dort macht Exchange.

 

Dachte beim SBS muss man dies manuell ändern?

 

Hast Du die Zertifikate mit "Enable-ExchangeCertificate" aktiviert? Wenn nein, hol das noch mal nach.

 

Wurde bei der Erneuerung getan. 

 

Hier mal die Details des Zertifikats, welches eigentlich eingebunden ist.

 

AccessRules        : {System.Security.AccessControl.CryptoKeyAccessRule, System

                     .Security.AccessControl.CryptoKeyAccessRule, System.Securi

                     ty.AccessControl.CryptoKeyAccessRule, System.Security.Acce

                     ssControl.CryptoKeyAccessRule}

CertificateDomains : {remote.******.net,*******.net, ***-SV-0001. *******

                     .local}

HasPrivateKey      : True

IsSelfSigned       : True

Issuer             : CN=remote. *******.net

NotAfter           : 07.05.2018 14:03:43

NotBefore          : 07.05.2013 14:03:43

PublicKeySize      : 2048

RootCAType         : None

SerialNumber       : 52*********************0733

Services           : IMAP, POP, IIS, SMTP

Status             : Valid

Subject            : CN=remote.suedfisch.net

Thumbprint         : BA*********************3173

Link to comment

Hi,

 

das liegt evtl. daran, dass du das alte Zertifikat gelöscht hast ;)

Ist das ein selbstsigniertes Zertifikat? Dann erstelle einfach ein neues über den Assistenten in der SBS Console (Vertrauenswürdiges Zertifikat hinzufügen).

 

Gruß

Jan

 

Haja, hab über die PS das neue Zertifikat erstellt und dabei das alte überschreiben lassen.

Oder bin ich e wing auf dem Holzweg?

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...