Jump to content
Sign in to follow this  
bernardo

VPN über SSTP

Recommended Posts

Hallo liebne Community,

 

ich habe mir zuhause einen VPN-Server basierend auf einem W2K8 R2 Sp1 mit einer PKI installiert (Anleitung von Microsoft- Step by Step Guide).

 

Der Zugriff klappt von extern Wunderbar, soll heißen das ich von Freunden oder Bekannten aus über SSTP (dies definiere ich in der VPN-Verbindung) eine VPN-Verbindung herstellen kann (zuvor muss ich natürlich noch das Zertifikat herunterladen und installieren).

 

Wenn ich jetzt von der Arbeit aus versuche die Verbindung aufzubauen erhalte ich den Fehler:

fehler 0x80092013: die sperrfunktion konnte die sperrung nicht üperprüfen, da der sperrserver offline war.

 

Mein Kollege (IT-Leiter Technik) meinte dass das Problem wohl mit dem Proxy zu tun hat.

 

Wisst Ihr was es damit genau auf sich hat, bzw. ob das Problem woanders liegt?

 

Ich habe als Installationshilfe den Step by Step guide von MS benutzt:

 

SSTP Remote Access Step-by-Step Guide: Deployment

 

wie immer bedanke ich mich recht herzlich bei euch für eure Unterstützung:-)

 

Grüße

Bernardo

Share this post


Link to post
Share on other sites

Hi !

 

Funtionieren "normale" https seiten sowie telebanking zB ?

edit: Ist dein Verteilungspunkt für Zertifikatssperrlisten über das Internet erreichbar ?

 

Hab hier noch was gefunden. Ist der Proxy ein "authenticated web (http) proxy" ?

http://social.technet.microsoft.com/Forums/en-US/winserverNIS/thread/d0e7648e-5cfc-40d7-9030-e951d6f6e442/

 

 

 

lg

Edited by Hr_Rossi

Share this post


Link to post
Share on other sites

Hi,

 

also HTTPS wird nicht geblockt, komme ins online Banking oder auf Freemail Seiten in den HTTPS-Bereich.

 

Der Verteilungspunkt für Zertifikatsperlisten ist auch erreichbar, so denke ich zumindest. Ich kann über den Browser ganz normal über HTTP auf die Seite zugreifen (vpn.xyz.com/certsrv) und das Zertifizierungsstellenzertifikat herunterladen bzw. installieren.

 

 

Also der Proxy ist ohne Authetifizierung

Share this post


Link to post
Share on other sites

 

 

Also der Proxy ist ohne Authetifizierung

 

Hi !

Bist du dir da sicher ?

 

Probier mal ob du mit einem lokalen User also keinen Domain User ins Internet kommst !

 

lg

Share this post


Link to post
Share on other sites

ja komme ich, habe eine vm mit win7 erstellt. die maschine ist kein mitglied der domäne und mit dem lokalen admin account komme ich via proxy ins internet.

 

wobei: ich sollte evtl erwähnen das wir zwei proxys haben. einer ist ohne und einer ist mit authetifizierung. der mit authetifizierung wird mittels dhcp an die client verteilt. der ohne authetifizierung ist ein alter proxy der noch läuft aber nicht mehr benutzt wird. ich habe im internetexplorer den proxy eingetragen ohne authetifizierung. das die einstellung greift, kann ich daran merken auf welche internet seiten ich komme und auf welche nicht (die proxys haben unterschiedliche listen).

 

Ich war igrendiwie immer der meinung, dass der proxy den das system benutzt, der selbe ist den man im ie einträgt?

 

Ist das evtl falsch?

Share this post


Link to post
Share on other sites

Hier siehst du welcher proxy verwendet wird:

 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Connections\WinHttpSettings

 

 

lg

Share this post


Link to post
Share on other sites

JAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA:-)

 

Hat geklappt, also man muss den systemproxy mit der Netsh.exe anpassen und zwar wie folgt:

netsh winhttp set proxy "proxyname:port"

 

Jetzt ist die VPN Verbindung über SSTP aufgebaut:-)

 

Danke an Hr_Rossi

Share this post


Link to post
Share on other sites
JAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA:-)

 

Hat geklappt, also man muss den systemproxy mit der Netsh.exe anpassen und zwar wie folgt:

netsh winhttp set proxy "proxyname:port"

 

Jetzt ist die VPN Verbindung über SSTP aufgebaut:-)

 

Danke an Hr_Rossi

 

NP !

 

Danke fürs feedback !

 

lg

Share this post


Link to post
Share on other sites

@bernardo:

 

Bitte achte darauf konsequent Großbuchstaben zu verwenden. Deine Art zu schreiben ist schwer lesbar und je besser deine Beiträge lesbar sind umso besser können wir dir helfen.

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...