Jump to content
Sign in to follow this  
charly91

Office 2010 | Access 2003 extrem langsam

Recommended Posts

Hallo,

 

ich bin letzte Woche auf Office 2010 umgestiegen, habe allerdings nur die H&B Version. Dadurch bin ich gezwungen noch Access 2003 zu verwenden.

 

Nun zu meinem Problem:

 

Ich vermute, dass seitdem ich Office 2010 installiert habe, Access extrem langsam geworden ist. Das heißt normale Formulare die letzte Woche noch in 10 Minuten fertig waren, werden nun gar nicht mehr fertig (ein paar hunderttausend Datensätze!). Auf anderen PC´s (mit Windows XP 32Bit) funktioniert alles. Meine zweite Vermutung wäre, das es an meinem Windows 7 32 Bit liegt was allerdings nicht erklären würde wieso es letzte Woche noch funktionierte. :)

 

Hat jemand schon mal solch eine Erfahrung gemacht bzw. ist jemanden bekannt, das so ein Fehler durch ein Windows Update ausgelöst wird. ?

 

Gruß

Charly

Share this post


Link to post
Share on other sites

Also ein Formular das die Artikel abfragt die sich in der letzten Woche geändert haben, war letzte Woche noch in 5-10 Minuten fertig mit der Abfrage, JETZT hängt sich Access auf und gibt die Daten nicht mehr aus.

Wenn ein Kollege die mdb öffnet und das Formular ausfüllt...werden die Daten nach 10 Minuten ohne Probleme ausgegeben. Wo bei mir dann keine Rückmeldung kommt bzw. es einfach nichts passiert auch wenn ich 2 Stunden warte. Mich wundert es nur das ich die gleich Abfrage letzte Woche gemacht habe, und es ohne Probleme alles ging. Und der Fehler kann ja nur bei meinem PC / Office liegen, da es bei den Kollegen ja funktioniert.

 

Hoffe das war etwas verständlicher.

 

Edit: Achja Sunny der Link in deiner Signatur ist tot. :)

Share this post


Link to post
Share on other sites
Also ein Formular das die Artikel abfragt die sich in der letzten Woche geändert haben, war letzte Woche noch in 5-10 Minuten fertig mit der Abfrage, JETZT hängt sich Access auf und gibt die Daten nicht mehr aus.

 

Zeig doch mal den SQL String, der dahinter steht.

 

Wenn ein Kollege die mdb öffnet und das Formular ausfüllt...werden die Daten nach 10 Minuten ohne Probleme ausgegeben. Wo bei mir dann keine Rückmeldung kommt bzw. es einfach nichts passiert auch wenn ich 2 Stunden warte. Mich wundert es nur das ich die gleich Abfrage letzte Woche gemacht habe, und es ohne Probleme alles ging. Und der Fehler kann ja nur bei meinem PC / Office liegen, da es bei den Kollegen ja funktioniert.

 

Greift ihr beide auf die gleiche MDB zu? Es sollte jeder ein eigenes Frontend haben um auf die Daten zuzugreifen. Was für ein Backend liegt dahinter?

 

Hast du die Datenbank in A2010 schon neu erstellt und alle Objekte aus der alten importiert? Versuche auch ein /Decompile: donkarls Access-Seiten Vorher ein /Compact, dann ein /Decompile, dann erneut ein /Compact. Gehts jetzt besser?

 

Edit: Achja Sunny der Link in deiner Signatur ist tot. :)

 

Danke für den Hinweis, ist korrigiert. ;)

Share this post


Link to post
Share on other sites

Hier mal der SQl String.

 

/////////////////////////////////////////////////////////////////////////////////////////

Private Sub cmdCreateTmpData_Click()

Dim strStart As String

Dim strEnde As String

Dim datAktDatum

Dim strSQL As String

Dim msgAnswer

 

Application.SetOption "Confirm Record Changes", False

Application.SetOption "Confirm Action Queries", False

 

msgAnswer = MsgBox("Temporäre Daten erstellen?", vbQuestion + vbYesNo, "Pickdaten")

If msgAnswer = vbYes Then

strSQL = "DELETE tag FROM tmp_pick_rohzahlen WHERE typ<>'dummy';"

DoCmd.RunSQL strSQL, False

 

DoCmd.OpenQuery "pick_ffa_we_pal_insert"

DoCmd.OpenQuery "pick_ffa_um_pal_insert"

DoCmd.OpenQuery "pick_ffa_ko_pal1_insert"

DoCmd.OpenQuery "pick_ffa_ko_pal2_insert"

DoCmd.OpenQuery "pick_ffa_ko_geb_insert"

 

DoCmd.OpenQuery "pick_ffa_ko_999_pal_insert"

DoCmd.OpenQuery "pick_ffa_ko_999_geb_insert"

 

DoCmd.OpenQuery "pick_ffa_we_zeiten_insert"

DoCmd.OpenQuery "pick_ffa_um_zeiten_insert"

DoCmd.OpenQuery "pick_ffa_ko_zeiten1_insert"

DoCmd.OpenQuery "pick_ffa_ko_zeiten2_insert"

 

DoCmd.OpenQuery "pick_ssw_we_geb_insert"

DoCmd.OpenQuery "pick_ssw_we_pal_insert"

DoCmd.OpenQuery "pick_ssw_um_geb_insert"

DoCmd.OpenQuery "pick_ssw_um_pal_insert"

DoCmd.OpenQuery "pick_ssw_ko_pal1_insert"

DoCmd.OpenQuery "pick_ssw_ko_pal2_insert"

DoCmd.OpenQuery "pick_ssw_ko_geb_insert"

DoCmd.OpenQuery "pick_ssw_ko_fla_insert"

 

DoCmd.OpenQuery "pick_ssw_ko_999_pal_insert"

DoCmd.OpenQuery "pick_ssw_ko_999_geb_insert"

DoCmd.OpenQuery "pick_ssw_ko_999_fla_insert"

 

DoCmd.OpenQuery "pick_wer_we_geb_insert"

DoCmd.OpenQuery "pick_wer_um_geb_insert"

DoCmd.OpenQuery "pick_wer_ko_geb_insert"

 

DoCmd.OpenQuery "pick_wer_ko_999_geb_insert"

 

DoCmd.OpenQuery "pick_lg_insert"

 

DoCmd.OpenQuery "pick_we_lg_pal_insert"

 

DoCmd.OpenQuery "pick_zeiten_insert"

 

DoCmd.OpenQuery "pick_anzmit_insert"

 

MsgBox "Datenerstellung beendet!"

End If

Application.SetOption "Confirm Record Changes", True

Application.SetOption "Confirm Action Queries", True

End Sub

 

//////////////////////////////////////////////////////////////////////////////////////

 

Nee wir greifen nicht auf die gleiche Datenbank zu. Das muss auch nur einmal die Woche gemacht werden. Ist eine nicht so häufig benutzte mdb.

Es werden auch eigentlich nur die Daten aus einer Tabelle genommen und Temporär in eine andere Tabelle geschrieben. Deswegen verstehe ich irgenwtie nicht was mein Rechner aufeinmal für ein Problem damit hat. :suspect:

Share this post


Link to post
Share on other sites

So das ist mal wieder sehr komisch.

Das Phänomen der Phänomene ist eingetreten... es geht. Ich habe aber nichts gemacht. :) auch mit 2 anderen mdb´s die auch nicht funktionierten.

Auf jeden Fall danke für die Hilfe!

 

gruß

Charly

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...