Jump to content
Sign in to follow this  
PathFinder

Adaptec Controller 5405 Hot Swap

Recommended Posts

Hallo zusammen,

 

bitte nicht hauen wenn das nicht das richtige Forum ist, aber ihr seid nunmal die besten :P

 

Wir haben einen Server mit 2 Adaptec 5405 Controllern.

 

An jedem Controller hängt eine Backplane.

 

Die erste hält ein RAID 5 mit Hot Spare alles Zucker.

 

Die zweite hält ein RAID 1 mit Hotspare und einer weiteren Platte.

 

Diese Platte ist als JBOD konfiguriert.

 

Server 2008 R2 alles neuster Software/Treiberstand.

 

Die besagte JBOD Platte soll in Rotation gewechselt werden.

 

Gesichert wird mit Windows Server Backup.

 

Wir machen das normalerweise mit Intel Controllern das funktioniert immer sehr gut.

 

Der Adaptec will nicht so recht.

 

Die Platten wurde alle als JBOD eingerichtet und der Windows Serversicherung mit wbadmin hinzugefügt, schaut auch alles gut aus.

 

Allerdings hat das System (Controller/Windows) wohl das Problem die Platten beim wechseln richtig zu erkennen. Die Partitionsinformationen stimmen nicht.

 

Beispiel:

 

Es steckt Disk01 und es wurde gesichert. Steckt dann die nächste Platte, wird diese wieder als Disk01 erkannt. Sicherung funktioniert natürlich nicht.

 

Am Slot der Backplane liegt es nicht. Hab schon andere probiert.

 

Kennt das Problem vielleicht jemand?

 

Ich bin kurz davor den Controller zu tauschen und gegen einen anderen zu ersetzen, wäre aber unschön wenn das nur auf Grund von mangelndem Wissen passieren würde.

 

Hatte mit dem Contoller leider bisher keine Erfahrung und "bin gezwungen" ihn zu nutzen.

 

Kann man da was falsch machen? Packt der Controller es einfach nicht?

 

Ich habe mir beim wechseln Zeit gelassen

- Im Storage Manager verschwindet erstmal die eine Platte, warten, stecken, dann taucht die neue auf

- Windows Geräte Manager zeigt noch die erste Partion (F5 nutzt hier nix)

- mit webadmin get disks bekomme ich noch die alte ID (paarmal ausführen, immer das selbe)

- Das ein Neustart die richtige Platte/Partition zu tage fördert ist nicht tröstlich

 

mfg der Path

Edited by PathFinder

Share this post


Link to post

Danke das hat geholfen!

 

Man könnte nun einen geplanten Task laufen lassen der kurz vorher startet.

 

Eine Textdatei anlegen z.b. "rescan.txt" mit dem simplen Inhalt "rescan"

 

Dann ein Batchfile das mit "diskpart /s rescan.txt" die Sache anschaufelt.

 

Schön ist anders aber besser als ein neuer Controller.

 

 

Hier die Antwort von Adaptec dort habe ich auch mal nachgefragt.

 

----------------------------------------------------------------------

 

vielen Dank für Ihre Anfrage zum Adaptec 5405 SAS Raid Controller.

Wir wissen, daß einige Kunden diese Art von Backup in Verbindung mit einem Raid Controller anwenden, aber wir unterstützen selber diese Konfiguration nicht, da es immer Probleme verursachen kann.

Werden diese JBOD Platten neu formatiert, bevor Sie sie wieder in das Raid Array einstecken ?

Falls Sie es nicht tun, daß enthalten sie die gleichen Metadata Informationen, und der Raid Controller, bzw. das OS, können durcheinander geraten.

Edited by PathFinder

Share this post


Link to post

Das sind ja gute Leute beim Adaptec Support!

 

Ihr sollt daran teilhaben.

 

-----------------------------------------------------------------

 

vielen Dank für die Information.

Folgendes kann ich in der Tat in den Logs über diese JBOD Platte on ID3 finden:

 

December 14, 2010 9:24:11 AM CET?INF ?S1176162.d1176162.local?Drive removed: controller 2, channel 0, SCSI device ID 3

December 14, 2010 9:24:11 AM CET?ERR ?S1176162.d1176162.local?Disk failed: controller 2, channel 0, SCSI device ID 3

December 14, 2010 9:24:11 AM CET?INF 408:A02C0S03L--?S1176162.d1176162.local?Physical drive removed: controller 2, connector 0, device 3, S/N WD-WMAZA2462186.

December 14, 2010 9:24:39 AM CET?INF ?S1176162.d1176162.local?New device found: controller 2, channel 0, SCSI device ID 3, LUN 0

December 14, 2010 9:24:39 AM CET?INF ?S1176162.d1176162.local?Sense data: Illegal request (INVALID FIELD IN PARAMETER LIST). Controller 2, channel 0, SCSI device ID 3, LUN 0, cdb [15 10 00 00 10 00 4f c2 00 b0 00 00], data [70 00 05 00 00 00 00 00 00 00 00 00 26 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00]

 

Die Platte ward physikalisch entfernt, für den Controller wird sie dann als "ausgefallen" als Konsequenz markiert.

Dann wird die neue Platte mit der unterschiedliche S/N schon gefunden, aber anschließend taucht ein Command Fehler auf.

Da es sich hier um WD 2TB Platten handelt, setzen Sie bitte diese Platten mit einem Jumper auf jeden Fall auf 1.5Gb/s auf, ansonsten werden sie nicht sehr stabil auf dem Bus laufen. Vielleicht hängt das problem damit zusammen.

 

Bitte aktualisieren Sie die Firmware Version des Controllers auf die 17911.

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...