Jump to content
Sign in to follow this  
PowerShellAdmin

Intranet website wird als internet website erkannt (SP2010)

Recommended Posts

Hallo :),

hier ein Update: Das Problem ist:

Die SharePoint Website wird als Internet-Seite innerhalb der Company angezeigt.

Daher muss man sich beim Aufruf des SharePoints mit der URL Authentifzieren.

Das eintragen in die Zone "lokales Intranet" am Client hat dies behoben.

 

Das Problem ist damit aber nicht gelöst, Office meckert ebenfalls. Sobald man ein SharePoitnt-Dokument mit word & co öffnet muss man sich erneut anmelden.

 

Wie sieht hier eine möglichst einfache Lösung aus:

am besten mit GPO Verteilung.

 

vielen Dank

 

 

Alt:

ich stehe vor einem Problem mit dem SharePoint 2010.

Problem: Im Intranet öffnet sich der Anmeldedialog, nach Eingabe des Win-Benutzers geht es dann. Das sollte aber automatisch funktionieren.

 

SharePointServer-Name: PSRV20.bla.Domäne.biz (hier nimmt er automatisch den angemeldeten Benutzer)

Erreichbarkeit URL-Bindung: Sharepoint.domäne.biz (Hier kommt der Anmelde Dialog)

 

Sharepoint.domäne.biz ist als eigene Zone im DNS-Server eingerichtet und verweißt mit der Wildcart auf psrv20.bla.domäne.biz. DNS Eintrag ist soweit korrekt.

 

Ursache

Der Server DARF NICHT über PSRV20.bla.Domäne.biz sonder muss ausschließlich über SharePoint.domäne.biz erreichbar sein.

Melde ich mich über PSRV20.bla.Domäne.biz nimmt er die automatische Authentifzierung.

 

Konfiguration der Webanwendung: Forderungs-Authentifizierung SharePoint.domäne.biz:80, Win NTLM

 

Ich kann ja eine Login.aspx Seite im SharePoint selbst definieren. Also sollte man das Ganze ja über einen Java Skript oder noch über den IIS lösen können.

Habe eine Login_intern.aspx erstellt und um den Javaskript erweiter. Ergebnis: Er will immernoch die Anmeldedaten.

<script language=”javascript” type=”text/javascript”>

document.getElementById(‘ctl00_PlaceHolderMain_ClaimsLogonSelector’).value = ‘Windows’;

document.getElementById(‘ctl00_PlaceHolderMain_ClaimsLogonSelector’).onchange();

</script>

 

Ich hoffe das Problem ist verständlich.

 

Vielen Dank

 

PS: Das Ganze muss so sein, da wir im Intranet die Win-Anmeldung nutzen und im Internet per FBA oder Win Anmeldung zugreifen.

Die Extranetanwendung ist eine Erweiterung vom Intranet, daher muss die Intranetanwendung Forderungsbasiert sein.

 

Habe mich ein wenig an Digital-Livestyle Microsoft SharePoint - Living and Working as a Digital Native orientiert. Wobei wir hier noch einige Redirects haben, sodass man intern von https auf http und extern von http auf https des Links/Seite umgeleitet wird.

Edited by PowerShellAdmin

Share this post


Link to post

Davon ausgehend, dass Ihr mit dem IE auf den SharePoint zugreift:

 

Ist die interne Zugriffsadresse des SharePoint im Browser in die Intranet-Zone eingetragen?

Share this post


Link to post

Hallo nochmal:

 

Habe nun auch innerhalb der Domäne getestet. Also Scharepoint.bla.domäne.biz. Er erfordert weiterhin die Anmeldung.

 

An alten SharePoints ist mir ebenfalls folgendes aufgefallen:

 

http://Servername => SharePoint öffnet ohne Login

http://Servername.bla.domäne.biz => Login Fenster öffnet sich

 

Sprich das Problem ist: WindowsAuthentifizierung bei FQN, geht das nicht ?

 

Sobald ich den Browser im IE8 der Intranet-Zone hinzufüge geht der Aufruf. Dokumente & Co wollen weiterhin eine Authentifzierung. :(

Edited by PowerShellAdmin

Share this post


Link to post

Huhu Zahni :) vielen Dank, wie immer, für deinen treffenden Post.

 

Einen Proxyserver verwenden wir nicht, daher hatte ich das Ganze zuerst per GPO gesetzt, funktioniert aber es ist leider nicht sinnvoll. Hier kann der Benutzer später keine Site mehr in einer Zone manuell eintragen.

 

Zur Info (falls man es doch so möchte):

Benutzerkonfiguration/Administrative Vorlagen/Windows-Komponenten/Internet

Explorer/Internetsystemsteuerung/Sicherheitsseite/Liste der Site zu Zonenzuweisungen

Dort anschließend die URL eingetragen, gespeichert.

 

 

Nun möchte ich, dass der Benutzer weiterhin die Sites auch selbst verwalten darf. Daher werde ich das per Logon verteilen.

Hier würde gerne beim Neustart die Site setzen per Regdatei.

Nach deinem Link sollte folgender Regpfad ja IEx32 und IEx64 betreffen, soweit die erweiterte Internetsicherheit ausgeschaltet ist.

 

Software\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\Domains (For 32-bit versions of Internet Explorer or 64-bit versions of Internet Explorer on 64-bit versions of Windows XP or Windows Server 2003, if Enhanced Security Configuration is turned off.)

 

Windows Registry Editor Version 5.00

 

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\Domains\domäne.biz]

 

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\Domains\domäne.biz\subdomäne]

"http"=dword:00000001

 

Edited by PowerShellAdmin

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...