Jump to content
Sign in to follow this  
JuppDietz

Konsole friert beim copy ein

Recommended Posts

Moin.

 

Seit gestern habe ich ein eigenartiges Problem:

 

Ich kopiere von meinem Win7_x64-Client aus Daten via Kommandozeile Daten von einem Server zu einem anderen. Dabei reagiert die Konsole nicht mehr, es werden keine Daten kopiert und ich kann noch nicht einmal die Konsole schließen (werden per "x", noch per taskkill oder Taskmanager oder direktem Zugriff via Powershell übers WMI-Objekt). Die Konsole bekomme ich nur durch das harte Ausschalten des Rechners weg. Selbst ein Reboot bleibt an dem Prozess hängen.

Ich habe Anfang der Woche einige Patches installiert und habe den Eindruck, dass die Probleme erst seitdem auftreten.

 

Der Fehler tritt beim xcopy in der cmd und auch beim copy-item in der Powershell gleichermaßen auf. So lange und so viel ich mit der Kommandozeile arbeite, diesen habe Effekt habe ich leider noch nie gesehen und bin ehrlich gesagt ein bisschen überfragt. Hat jemand eine Idee?

 

Danke!!

Share this post


Link to post

Danke für den Tipp. Den robocopy habe ich vergessen zu erwähnen - da läuft das Kopieren nämlich problemlos durch.

Das Problem ist, dass ich ein sehr umfangreiches Powershell-Script geschrieben habe und den copy-item mit verschiedenen anderen Kommandos in einer Pipe habe. Nun habe ich den copy-item separiert und laufe in das gleiche meldungsfreie Einfrieren. Den xcopy habe ich als Gegenvergleich dann mal ausprobiert.

 

Was mich stutzig macht, ist, dass ich selbst die Kommandozeile bzw. dessen Prozess nicht mehr beenden kann. Das xcopy taucht gar als eigener Prozess zweimal im Taskmanager auf. Den einen Prozess kann ich mit einer "Zugriff verweigert"-Meldung nicht beenden und der andere bleibt einfach im Taskmanager stehen...

 

Danke!!

Share this post


Link to post

Hi Jupp.

 

Hast Du schon mal versucht Deinen copy-Prozessen mit dem ProcessExplorer/Monitor zuzugucken? Vielleicht kriegst Du mit den tools ja noch was dazu raus.

 

ciao und 'nen angenehmen Tag

M.

Share this post


Link to post

Daran habe ich noch gar nicht gedacht. Peinlich...

 

Ich habe mir die Prozesse damit mal genauer angesehen. Abgesehen davon, dass sich die Prozesse nicht bewegen und Speicher belegen, lies sich nicht viel ablesen. Mit dem ProcessExplorer konnte ich zumindest die Shell weghauen, was mit dem Taskmanager auch schon nicht ging. Die copy-Prozesse stehen jedoch weiterhin drin...

 

Dir auch einen schönen Tag und Danke!!!!

Share this post


Link to post

Hi Jupp.

 

Hast Du mal 'nen Doppelklick auf Deine copy-Prozesse gemacht? In dem dann aufgehenden Fenster kriegst Du doch noch 'ne ganze Ecke mehr über den Prozeß raus, vielleicht ja auch was das Dir noch ein bißchen weiter hilft.

 

ciao, ... und viel Erfolg

M.

Share this post


Link to post

Hallo,

 

ja, habe ich. Ich sehe, dass er im State Wait:WrResource ist und nichts tut. Die Quelle und das Ziel, auf das der Prozess greift, sind beide verfügbar. Er hat nur einen Thread mit der Start-Adresse 0x0. Will ich auf den Thread, bekomme ich die Meldung "Error Accessing Thread". Auch das entsprechende Modul ist nicht vorhanden. Der Performance Graph zeigt, dass den Prozess statisch im RAM liegt und keinerlei CPU-Aktivität verursacht...

Share this post


Link to post

Leider nichts hilfreiches. Ich habe mir den Client, auf dem die Scripts laufen, einmal angesehen. Es liegt wohl an einer bestimmten Datei. Wenn ich sie manuell per TotalCommander kopiere, friert mir auch dieser ein. Kopiere ich die Datei auf einem älteren XP-Client, geht es problemlos. Warum der Win7_x64-Client nun das Problem verursacht, habe ich noch nicht feststellen können :-((

Share this post


Link to post

Moin.

 

Man mag es kaum glauben, aber es war mal wieder der tolle Symantec Virenscanner. Der procmon hat mir zwar nicht wirklich weiterhelfen können, ich kam jedoch über einen hängenden Citrix-Prozess, der sich auffallend ähnlich daneben benahm drauf. So einfach und doch so wirkungsvoll...

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...