Jump to content
Sign in to follow this  
Webbrauser

SCCM2007R2 - Clientaktualisierung

Recommended Posts

Hallo boardgemeinde,

 

ein kleines Problemchen hat sich bei unserer SCCM Installation eingeschlichen.

 

Kurzer Anriss:

zwei Standorte mit jeweils zwei DPs, Pakete sind verteilt, kommunikation mit dem installierten Agent funktioniert ohne Probleme.

Nun ist der Client eine zeitlang nicht an gewesen und wird nun wieder genutzt. Ich setze also einen otto-normal ping auf die Maschine und stelle fest .. falsche IP. Hm, kurz im DNS nachgeschaut - ok ist auch falsch hinterlegt. Also den Namen aus dem DNS gelöscht - ipconfig /flushdns und schon funktioniert der Ping wunderbar.

 

Jetzt habe ich allerdings BEVOR ich diese Pingproblematik herausgefunden habe schon ein Advertisement an eine Collection mit nur EINEM System losgeschickt ( und zwar dem mit dem fehlerhaften DNS-Eintrag) .. zusammengestellt wird die Collection als "System Ressource" mit der Suche nach "NetBios Namen" (jaja ich weiss :-) ) .

 

In der Collection wird der Client hinzugefügt und das Advertisement angezeigt - Wenn ich mir nun die Eigenschaften für die Collection anzeigen lasse sind die Informationen vom Agent allerdings stark veraltet.

 

.. Ich habe nachgelesen, dass die Informationen zum Subnet und zur IP vom hiesigen DHCP-Server gezogen werden mit anschließendem Ping auf die Maschine um dann die benötigten aktuellen Informationen abzurufen.

Als Netzwerkermittlung ist Topologie, Client und Clientbetriebssystem angekreuzt - ich verwende kein SNMP!

 

Wo liegt da der Fehler im Design? Muss ich nun wirklich 25 Stunen warten bis eine neue Frequenzermittlung durch ist und der Agent sich aktualisiert hat?

 

Meldet sich der Server beim Client oder der Client beim Server?

 

 

Klar könnte ich als workaround nun nach der Mac-Adresse suchen lassen und alles wär tutti.. aber das ist ja nicht Zielführend.

 

Also kurz zusammengefasst:

Wie funktioniert die Kommunikation zwischen Client (bzw. Agent) und Server?

Warum ist der SCCM Server so sensibel was die fehlerhafte DNS-Einträge angeht - obwohl er doch die Daten vom DHCP abfragt.

 

 

Vielleicht kann mir ja jemand helfen.. die Logs sind übrigens sauber..

 

Viele Grüße

Share this post


Link to post

Übrigens:

 

Die "Actions" wurden alle einmal angeworfen, in den Logs vom Client steht ausserdem, dass die IP geupdated wurde und alle Policys neu vom Server geladen wurden.

 

Dennoch (auch nach mehrmaligem aktualisieren :-) ) erscheinen die ALTEN Settings unter "General" :-) .. das Advertisement ist darüberhinaus auch noch nicht beim Client angekommen und wird in keinem Log erwähnt :-(

Share this post


Link to post

Fehler die ich im execmgr gefunden habe:

 

<![LOG[Failed to instantiate UI Server {C2F23AE4-82D8-456F-A4AF-A2655D8CA726} with error 80004005]LOG]!><time="15:53:34.536+-120" date="07-06-2010" component="execmgr" context="" type="3" thread="1032" file="uieventgenerator.cpp:164">

<![LOG[Cached CCM (user, session) is: (,-1).]LOG]!><time="15:53:34.536+-120" date="07-06-2010" component="execmgr" context="" type="1" thread="1032" file="usertoken.cpp:1138">

<![LOG[::GetSMSConsoleSessionId - No SMS console session found.]LOG]!><time="15:53:34.536+-120" date="07-06-2010" component="execmgr" context="" type="1" thread="1032" file="usertoken.cpp:135">

<![LOG[Failed to instantiate UI Server 2 {E8425D59-451B-4978-A2AB-641470EB7C02} with error 80004005]LOG]!><time="15:53:34.536+-120" date="07-06-2010" component="execmgr" context="" type="3" thread="1032" file="uieventgenerator.cpp:222">

<![LOG[Cached CCM (user, session) is: (,-1).]LOG]!><time="15:53:34.536+-120" date="07-06-2010" component="execmgr" context="" type="1" thread="1032" file="usertoken.cpp:1138">

<![LOG[::GetSMSConsoleSessionId - No SMS console session found.]LOG]!><time="15:53:34.536+-120" date="07-06-2010" component="execmgr" context="" type="1" thread="1032" file="usertoken.cpp:135">

<![LOG[Failed to instantiate Updates UI Server {2D023958-73D0-4542-8AD6-9A507364F70E} with error 80004005]LOG]!><time="15:53:34.536+-120" date="07-06-2010" component="execmgr" context="" type="3" thread="1032" file="uieventgenerator.cpp:279">

<![LOG[Cached CCM (user, session) is: (,-1).]LOG]!><time="15:53:34.536+-120" date="07-06-2010" component="execmgr" context="" type="1" thread="1032" file="usertoken.cpp:1138">

<![LOG[::GetSMSConsoleSessionId - No SMS console session found.]LOG]!><time="15:53:34.536+-120" date="07-06-2010" component="execmgr" context="" type="1" thread="1032" file="usertoken.cpp:135">

<![LOG[Failed to instantiate VApp UI Server {00AAB372-0D6D-4976-B5F5-9BC7605E30BB} with error 0x80004005]LOG]!><time="15:53:34.536+-120" date="07-06-2010" component="execmgr" context="" type="3" thread="1032" file="uieventgenerator.cpp:338">

 

Gestern aufgetreten

 

---

 

Edit:

 

Habe den Client einmal remote neuinstalliert. Jetzt ist das Log sauber - das Advertisement trotzdem noch nicht angekommen und die Daten noch immer nicht geupdated.

Kann ich das irgendwie manuell anstoßen?

Edited by Webbrauser

Share this post


Link to post

Fehler gefunden:

 

Ich habe zwei Rechner mit demselben Namen die ich für die Collection auswählen kann. Die GUID ist unterschiedlich; Die MAC dieselbe. Ich habe in geistiger Umnachtung die ältere Ressource genommen (Murphys Law) und mich gewundert warum nix passiert. Habe diese nun gelöscht und der aktuellen zugewiesen. Alles OK.

Abgefahren....

 

Wie kann sowas passieren? Eigentlich sollte der "nichtmehr aktive" Client doch dann wenigstens ausgegraut sein?

Share this post


Link to post

abgefahren ja :)

 

Problem beim SCCM ist, dass sein automatischer Aufräumjob auf 3 Monate oder 6 Monate eingestellt ist, deshalb können auch sehr alte Objekte/Computer angezeigt werden :)

 

-> ein ähnliches Problem wie du hatte ich auch schon

Share this post


Link to post
Wie kann sowas passieren? Eigentlich sollte der "nichtmehr aktive" Client doch dann wenigstens ausgegraut sein?

 

Das ist das Problem mit den Direct Membership rules (ich schätze, diese wurde verwendet). Eigentlich wird im Hintergrund die ResourceID verwendet, nicht der Name => Du hast evtl einen Rechner mit "obsolete yes, active no" erwischt (anstatt genau andersrum). Das würde nicht passieren, wenn Du eine dynamische Query mit (sinngemäß) "... Name = 'PCNAME' " verwendet hättest (da wären dann eben 2 Rechner Mitglied der Collection gewesen).

Der Client kontaktiert übrigens immer den Server => auch wenn die IP in ConfigMgr nicht aktuell war und selbst wenn DNS hier nicht stimmte, hätte er trotzdem die Policies erhalten müssen.

Share this post


Link to post
Das ist das Problem mit den Direct Membership rules (ich schätze, diese wurde verwendet). Eigentlich wird im Hintergrund die ResourceID verwendet, nicht der Name => Du hast evtl einen Rechner mit "obsolete yes, active no" erwischt (anstatt genau andersrum). Das würde nicht passieren, wenn Du eine dynamische Query mit (sinngemäß) "... Name = 'PCNAME' " verwendet hättest (da wären dann eben 2 Rechner Mitglied der Collection gewesen).

 

Hey, Danke für deine Rückmeldung :-)

 

Ist es nicht genau das was SCCM macht, sobald ich in der direct Membership rule (got me!) als Systemressource den NetBiosnamen angebe? Ich war bisher in der Annahme, dass genau ein solcher Query die DB durchläuft. Mir wurden (!) auch zwei Stück zur Auswahl angezeigt. Aus Neugier habe ich dann im zweiten Anlauf (nachdem ich festgestellt habe, dass der den ich vorerst genommen hatte veraltet war) beide ausgewählt. Beide waren nicht obsolete und beide active. Ich kenne das bisher tatsächlich nur so, dass, z.B. durch Neuinstallationen o.ä. dann wenigstens ein Client ausgegraut (obsolete=yes) ist... .

 

Okay, dann ist also ein Fehler durch das fehlerhafte DNS-Replikat (was ja ohnehin gefixt werden muss) auszuschließen. Sehr gut.

Die Info, dass der Client den Server kontaktiert ist übrigens im allgemeinen mal sehr gut.

 

Mal was anderes:

 

Ich würde gerne auf 70-401 Zertifikatsjagd gehen - muss ich mich auf Multiple Choice oder auf Lab einstellen? Habe leider im Netz nichts dazu gefunden und bisher nur eine (popels-)Prüfung hinter mir...

Eventuell hat ja einer von euch beiden die Muße mir da n kurzen Anriss zu geben :-)

Share this post


Link to post

Direct membership bietet Dir eine Auswahl an, ja. ABER: die Mitgliedschaft in einer Collection wird durch die ResID bestimmt => bei einer Neuinstallation bekommt der Client eine neue => er ist nicht mehr Mitglied der Collection. Deshalb lieber query based nehmen.

Ich hab die Prüfung damals in der Beta-Version gemacht und kann mich schon gar nicht mehr an die Inhalte erinnern.

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...