Jump to content
Sign in to follow this  
Dopamin

DNS Auflösungsverwirrung

Recommended Posts

Hallo Community,

 

ich habe hier einen DC 2k8 mit DNS (AD Int.) und einen einen 2k3 Server mit DNS (sek. Zone). Beide Server haben eine 192er und eine 172er NIC.

Alle Clients beziehen ihre Infos primär vom 2k3 Server über die 172er Adresse und sekundär über die 192er des 2k8 Servers. Soweit so gut. Folgendes Problem:

 

Wir haben einen Server mit zwei Host (A) Einträgen in den Netzen 172.17.17.220 & 192.168.7.220. Wenn ich von einem Client aus dem 172er Netz einen ping auf das System absetze, will er immer die 192er Adresse auflösen wohin er aber keine Verbindung hat. Mache ich ein flushdns, nimmt er die 172er, dann wieder flushdns, geht er wieder auf die 192er, usw.

 

Normal sollte der DNS Server primär die Adresse an den Client weitergeben, die seinem Netz am ehesten entspricht?! Also die 172er!

 

Ich habe schon Round Robin dafür verantwortlich gemacht, aber das war es nicht.

 

Ich hoffe jemand hat eine Idee, wie ich den DNS Eintrag priorisieren kann, dass immer der 172er genommen wird?!

 

 

Gruß

Olli

Edited by 0l2i
Überarbeitet da eine Aussage inkorrekt war

Share this post


Link to post

Kann mir die Situation noch nich 100% vorstellen.

Kannst du mal beispielhaft ne IP-Konfiguration eines Clients posten? Einfach damit man mal sieht was als DNS-Server eingetragen ist etc.

 

Gruß

Share this post


Link to post

Ist auf dem angefragten DNS-Server die Netzwerkmaskenanforderung aktiv ? Teste das mal mit NSLOOKUP, mehrmals nacheinander ...

Share this post


Link to post

Na sicher:

 

 

Ethernet-Adapter LAN-Verbindung:

 

Verbindungsspezifisches DNS-Suffix: firma.de

Beschreibung. . . . . . . . . . . :

Physikalische Adresse . . . . . . :

DHCP aktiviert. . . . . . . . . . : Ja

Autokonfiguration aktiviert . . . : Ja

Verbindungslokale IPv6-Adresse . :

IPv4-Adresse . . . . . . . . . . : 172.17.19.1(Bevorzugt)

Subnetzmaske . . . . . . . . . . : 255.255.252.0

Lease erhalten. . . . . . . . . . : Mittwoch, 2. Juni 2010 13:03:00

Lease läuft ab. . . . . . . . . . : Donnerstag, 10. Juni 2010 13:03:00

Standardgateway . . . . . . . . . : 172.17.17.253

DHCP-Server . . . . . . . . . . . : 172.17.17.254

DHCPv6-IAID . . . . . . . . . . . :

DHCPv6-Client-DUID. . . . . . . . :

 

DNS-Server . . . . . . . . . . . : 172.17.17.254

192.168.0.249

172.17.17.253

Primärer WINS-Server. . . . . . . : 192.168.0.249

NetBIOS über TCP/IP . . . . . . . : Aktiviert

 

 

Die 172.17.17.254 ist der 2k3 Server, die 192.168.0.249 der DC und die 172.17.17.253 der Router ins Internet.

 

Sind immer noch am Testen. Nach jedem flushdns wechselt sich wieder die Adresse von 172er nach 192er und zurück. Ist zum aus dem Bus gucken :confused:

 

Gruß

Olli

Share this post


Link to post
Ist auf dem angefragten DNS-Server die Netzwerkmaskenanforderung aktiv ? Teste das mal mit NSLOOKUP, mehrmals nacheinander ...

 

japp, auf beiden Servern aktiv.

 

Gruß

Share this post


Link to post

Auch wenn es nichts mit Deinem Problem zu tun hat ... der Router hat in der DNS-Konfiguration nichts zu suchen ...

Probiere mal folgendes:

IPCONFIG /FLUSHDNS auf dem Client

NSLOOKUP <FQDN des Servers> 172.17.17.254

NSLOOKUP <FQDN des Servers> 172.17.17.254

 

NSLOOKUP <FQDN des Servers> 192.168.0.249

NSLOOKUP <FQDN des Servers> 192.168.0.249

 

Zwischen den NSLOOKUP Aufrufen brauchst Du kein IPCONFIG /FLUSHDNS machen, da NSLOOKUP den Cache nicht benutzt. Wenn Du ganz sicher gehen willst, dass Dir der Cache keinen Streich spielt, beende auf dem Client den Dienst "DNS-Client" ...

Share this post


Link to post

NSLOOKUP <FQDN des Servers> 172.17.17.254

NSLOOKUP <FQDN des Servers> 172.17.17.254

 

NSLOOKUP <FQDN des Servers> 192.168.0.249

NSLOOKUP <FQDN des Servers> 192.168.0.249

 

Router entfernt. Den hatten wir ursprünglich mal reingesetzt um Probleme zu vermeiden :rolleyes:.

Mit NSLOOKUP bekomme ich folgenden Ablauf, egal auf welche Adresse:

 

 

PS C:\> nslookup FQDN 172.17.17.254

Server: FQDN

Address: 172.17.17.254

 

Name: FQDN

Addresses: 172.17.17.220

192.168.7.220

 

PS C:\> nslookup FQDN 172.17.17.254

Server: FQDN

Address: 172.17.17.254

 

Name: FQDN

Addresses: 192.168.7.220

172.17.17.220

 

PS C:\> nslookup FQDN 172.17.17.254

Server: FQDN

Address: 172.17.17.254

 

Name: FQDN

Addresses: 192.168.7.220

172.17.17.220

 

PS C:\> nslookup FQDN 172.17.17.254

Server: FQDN

Address: 172.17.17.254

 

Name: FQDN

Addresses: 172.17.17.220

192.168.7.220

 

PS C:\> nslookup FQDN 172.17.17.254

Server: FQDN

Address: 172.17.17.254

 

Name: FQDN

Addresses: 172.17.17.220

192.168.7.220

 

PS C:\> nslookup FQDN 172.17.17.254

Server: FQDN

Address: 172.17.17.254

 

Name: FQDN

Addresses: 172.17.17.220

192.168.7.220

 

 

Ich habe auch schon die NIC Reihenfolge geändert. Am DC haben wir aus anderen Problemstellungen die zweite NIC mit dem 172er Netz wieder entfernt.

Jedenfalls wechselt die Antwort ohne erkennbares Muster.

 

Gruß

Olli

Share this post


Link to post
Auch wenn Du als DNS-Server die 192.168.0.249 fragst ?

NSLOOKUP <FQDN des Servers> 192.168.0.249

 

Jopp, same problem :(

Share this post


Link to post
Moin,

 

man korrigiere mich, wenn ich völlig danebenliege, aber: Sollte es nicht reichen, auf dem DNS-Server das Round Robin abzuschalten?

 

Description of the netmask ordering feature and the round robin feature in Windows Server 2003 DNS

 

Gruß, Nils

 

Korrigieren möchte ich dich nicht ;), aber das haben wir schon versucht, hat nichts gebracht. Würdest Du denn dieses Verhalten nur auf Round Robin zurückführen oder gibts es noch andere Dienste, die dieses "tauschen" der Host (A) Abfrage veranlasst?

 

Gruß

Olli

Share this post


Link to post

Nein, das reicht nicht ... :) Ich habe hier das gleiche Verhalten (gerade getestet). Wir haben hier ein 10er Netz mit ´ner 16er Maske und hier wurden auch nicht nach anfragendem Subnetz geordnet, und das unabhängig von Round Robin. Also mit ...

Dnscmd /Config /LocalNetPriorityNetMask 0x0000FFFF

oder

Dnscmd /Config /LocalNetPriorityNetMask 0x00FFFFFF

die Priorität eingestellt und passt ...

Share this post


Link to post
Nein, das reicht nicht ... Ich habe hier das gleiche Verhalten (gerade getestet). Wir haben hier ein 10er Netz mit ´ner 16er Maske und hier wurden auch nicht nach anfragendem Subnetz geordnet, und das unabhängig von Round Robin. Also mit ...

Dnscmd /Config /LocalNetPriorityNetMask 0x0000FFFF

oder

Dnscmd /Config /LocalNetPriorityNetMask 0x00FFFFFF

die Priorität eingestellt und passt ...

 

So nach langem hin und her...

Ich habe deinen Vorschlag mal versucht zu nutzen. Auf dem DC ging das via DNSCMD gut, auf dem 2k3 nicht, da der kein DNSCMD kennt. Im Technet habe ich dann noch diesen Artikel gefunden:

 

LocalNetPriority

 

Über Registry etc. konnte ich dei gleichen Einstellungen wie auf dem DC auch vornehmen, hat aber alles nichts gebracht. Wenn Round Robin ausgeschaltet ist, dann wechseln die Einträge mit NSLOOKUP nicht mehr. Soweit so gut. Aber NSLOOKUP zeigt immer den 192er Eintrag als erstes. Egal was ich dort per DNSCMD einstelle. Zwischenzeitlich ging ein einfach PING mal und dann wieder nicht. Sehr merkwürdig.

 

Wir haben jetzt für das 192.168.7er Netz einen eigenen DNS installiert, da dieses Netz eh nur für Backup etc. genutzt wird und nicht zwingend im normalen DNS stehen muss. Das ist zwar nicht wirklich der Grund des Problems, aber eine Lösung mit der man leben kann.

 

Der 2k3 wird bald gegen einen 2k8 DC getauscht und bekommt eine AD Int. Zone. Dann werde ich die 192.168.7er Einträge nochmal Testweise einfügen um zu gucken ob es sich in diesem Fall anders verhält.

 

Ich danke euch für eure hilfe und wünsche einen sonnigen Feierabend :cool:

 

Gruß

Olli

Share this post


Link to post

Sind auf dem 2003er die Support Tools installiert ? Funktioniert die Maskenanforderung denn mit dem 2008er DNS-Server ? Der von Dir gesetzte Regkey ist NICHT das, was der DNSCMD-Befehl einstellt !

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...