Jump to content
Sign in to follow this  
timmi

DNS Problem Event ID 40960/1

Recommended Posts

Hallo zusammen!

 

Ich habe mal wieder ein kleines DNS-Problem und ich hoffe, dass ihr mir weiterhelfen könnt. Ich behaupte aber mal, dass mein Problem nicht ganz so exotisch ist:

 

Beim Starten meines Servers (Win 2K3 Server EE, PDC, DNS, Subnetz 192.168.22.x, Domäne tlhome.local) habe ich die folgenden beiden Meldungen (Warnungen) in meinem Ereignisprotokoll (System):

 

Quelle: LSASRV

Kategorie: SPNEGO (Vermittlung)

ID: 40961

Text: Das Sicherheitssystem konnte keine sichere Verbindung mit dem Server ldap/srv01.tlhome.local herstellen. Es war kein Authentifizierungsprotokoll verfügbar.

 

Quelle: LSASRV

Kategorie: SPNEGO (Vermittlung)

ID: 40960

Text: Das Sicherheitssystem hat einen Authentifizierungsfehler für den Server ldap/srv01.tlhome.local festgestellt. Der Fehlercode des Authentifizierungsprotokolls Kerberos war "Es stehen momentan keine Anmeldeserver zur Verfügung, um die Anmeldeanforderung zu verarbeiten. (0xc000005e)".

 

 

Diese beiden Warnungen möchte ich gerne eliminieren. Meine DNS-Konfiguration findet ihr im Anhang. Zwar funktioniert mein Netz hier im Prinzip tadellos, aber es kann ja nicht richtig sein, dass diese Warnungen erscheinen. Ich habe zu den beiden Events zwar schon Informationen gefunden, aber konnte diese nicht in die erforderlichen Arbeitsschritte umsetzen.

 

Daher wäre ich sehr dankbar, wenn mir jemand StepByStep erklären könnte, was ich nun tun sollte, um das Ereignisprotokoll zukünftig clean zu haben.

 

Vielen Dank schon jetzt für Eure Hilfe. Wenn noch Informationen fehlen, werde ich diese schnellstmöglich nachposten!

 

Timmi

post-9352-13567388971107_thumb.gif

Share this post


Link to post

Hat denn wirklich niemand eine Idee zu meinem Problem? Ich denke, dass es doch so exotisch nicht sein kann. Wenn noch Informationen fehlen, einfach nachfragen!

 

Danke schonmal an Alle!

Share this post


Link to post

http://www.eventid.net gibt zu deinem Problem folgendes aus:

 

Last update 10/27/2003):

This can occur if the File Replication Service (Ntfrs.exe) tries to authenticate before the directory service has started. See Q824217 to troubleshoot this problem.

 

From a newsgroup post: "In my case, this error occurred because the credentials specified in my DHCP server on “DC1” for dynamic DNS registration were misspelled".

 

Darren Monahan (Last update 10/26/2003):

If this warning appears by itself on an hourly basis, check that the credentials assigned to the DHCP server to register DNS dynamic updates are valid. Spelling errors or incorrect passwords and/or domain names can be to blame. To do this in Windows Server 2003, open the DHCP snap-in, open the properties for your DHCP server, select the "Advanced" tab, and click the "Credentials" button. Verify the username, password, and domain listed here are valid.

 

Anonymous (Last update 10/26/2003):

We had the same problem on one of the workstations that had a long logon timeout. This has worked for us:

1. logon as an admin.

2. remove from domain.

3. add to domain.

4. restart.

 

Adrian Grigorof (Last update 8/12/2003):

From a newsgroup post: "If there is there a matching 40960 event then it is more likely a forward lookup zone issue in DNS. If not, it probably is that Windows is looking for a reverse lookup zone."

 

As per Q823712, this may occur when you restart the server that was promoted to a domain controller.

 

DweezMon (Last update 8/12/2003):

If the server name is prisoner.iana.org, blackhole-1.iana.org or blackhole-2.iana.org, this is just telling you that Windows could not perform a reverse lookup on the IP address configured as a DNS server. These names are used to respond with "server does not exist" when you use a private IP range, for example 192.168.1.0. This can be quickly cleared up by adding a Reverse Lookup zone, and adding a record for your DNS Server.

 

Adrian Florin Moisei (Last update 5/23/2003):

From a newsgroup post: "If the system is Win XP and if the errors were not occuring under a different profile the folowing steps can solve the problem:

1. Log on as a different user

2. Back up the profile in mention.

3. Delete the profile.

4. Create a new profile by logging on.

5. Restore the files from the backed up profile."

 

Gunnar Carlson (Last update 5/18/2003):

I get this error on all DC's that I upgrade to Windows 2003 Server. I upgraded one DC from W2k3 beta3 to the released version, and the events immediately started to show up. After I created the reverse lookup zones for the network they stopped.

 

Anonymous (Last update 5/10/2003):

This happened when machines were trying to register PTR records, and we didn't have reverse lookup zones. The solution was to add them for all our subnets.

 

DJ (Last update 5/2/2003):

I'm on a small home test network with Win2k domain behind a Linksys 4 port DSL router. The router handles DNS. A power failure sacked my domain controllers. After some restores and GP resets, my DCs were up and talking. But my workstation could not access AD Users and computers. The problem was the order of DNS in the Lynksys. After putting my local DNS server first in the list on the Linksys, I was able to get to AD.

 

Greg Martin

Had this on a WinXP workstation which could no longer access domain resources. The fix was changing the DNS settings to point to a Win2k DNS which was tied into Active Directory. Apparently the workstation could no longer locate SVR records for the kerberos authentication server. These records were not in our UNIX DNS but were in the Win2k DNS. Related directly to Event 40960 - LsaSrv.

Links Q823712 , Q824217

 

Hoffe, du kannst damit was anfangen, eventid.net hat mir jedenfalls auch immer weitergeholfen.

 

Greetings

weimer

Share this post


Link to post

Hallo Weimer, danke für die Antwort, bei EventID-net hatte ich schon nachgesehen. Anfangs hatte ich nämlich drei Fehler im Protokoll, und zwar die beiden wie oebn beschrieben und ausserdem noch eine Warnung, die mit dieser Beschreibung übereinstimmt:

 

DweezMon (Last update 8/12/2003):

If the server name is prisoner.iana.org, blackhole-1.iana.org or blackhole-2.iana.org, this is just telling you that Windows could not perform a reverse lookup on the IP address configured as a DNS server. These names are used to respond with "server does not exist" when you use a private IP range, for example 192.168.1.0. This can be quickly cleared up by adding a Reverse Lookup zone, and adding a record for your DNS Server

 

Also habe ich (wie man sieht) eine entsprechende Reverse-Lookup-Zone erstellt. Daraufhin war dieser eine Fehler (also eine von insgesamt 3 Warnungen) aus dem Protokoll verschwunden. Die anderen beiden nicht.

 

Aus meiner Sicht handelt es sich bei den verbleibenden 2 Warnungen um diesen Fall (nach EventID.net):

 

This can occur if the File Replication Service (Ntfrs.exe) tries to authenticate before the directory service has started. See Q824217 to troubleshoot this problem.

 

Im genannten MS-Artikel steht dann:

To work around this issue, ignore these two warning events if the directory service starts successfully. If the events continue to appear after Windows has successfully restarted, you may have to troubleshoot the directory service.

 

Und nun bin ich mit meinem Latein am Ende, die Warnungen werden bei jedem Neustart des Servers ins Protokoll eingetragen und ich weiss leider nicht, wie ich mein "Directory Service" entsprechend "troubleshooten" soll. Denn ansonsten funktioniert so ziemlich alles, Group Policies, UserLogon/Logoff etc. alles ohne Probleme oder Protokolleinträge.

 

Any Ideas? ;-)

Share this post


Link to post

Hi,

 

hatte das gleiche Problem mit den gleichen Fehlermeldungen,.

DNS richtig eingerichtet, incl. reverse lookup zone, Dateireplikationsdienst deaktiviert (weil nicht benötigt), ebenso DHCP.

Blieb nur noch die Reihenfolge in der die Dienste starten.

Habe Netlogon und Windowszeitgeber von DNS abhängig gemacht und hatte die Lösung; Keine Fehler mehr.

REGEDT32 ausführen zu

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon

 

gehen, auf DependOnService doppelklicken und in die nächste freie Zeile DNS eintragen.

Vorher Registry sichern!!

Analoger Eintrag bei W32TM (erstellen, da DependOnService nicht vorhanden) und Ruhe ist!

Share this post


Link to post
Hi,

 

hatte das gleiche Problem mit den gleichen Fehlermeldungen,.

DNS richtig eingerichtet, incl. reverse lookup zone, Dateireplikationsdienst deaktiviert (weil nicht benötigt), ebenso DHCP.

Blieb nur noch die Reihenfolge in der die Dienste starten.

Habe Netlogon und Windowszeitgeber von DNS abhängig gemacht und hatte die Lösung; Keine Fehler mehr.

REGEDT32 ausführen zu

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon

 

gehen, auf DependOnService doppelklicken und in die nächste freie Zeile DNS eintragen.

Vorher Registry sichern!!

Analoger Eintrag bei W32TM (erstellen, da DependOnService nicht vorhanden) und Ruhe ist!

 

 

öhm das verstehe ich nicht so ganz. Habe das selbe Problem. Kann es einer nochmal genauer beschreiben was ich da machne soll?

 

greetz

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...