Jump to content
Sign in to follow this  
TIR

DC macht mit Router was er will

Recommended Posts

Hallo

 

Ich weiss das dieses Thema schon viele male hier im Forum abgesprochen wurde, jedoch war leider keine Lösung für mich da.

Mein Prop

 

W2K DC + Netzwerk, feste IP, W2K Clients, Allnet Router.

 

Hatte das Problem das wenn die Clients eine IP abfrage gestartet haben, das sich der Router immer eingewählt hat. Problem lag an der DNS, und habe es mit viel Ausprobieren gelöst bekommen, doch jetzt wählen sich nicht mehr die clients ins Internet ein, sondern jetzt wählt sich der Server alle 3-5Minuten von selbst ein.

DNS scheint ok zu sein, Namensauflösung Vor-Backward funzt und ipconfig/all gibt alle richtigen Werte zurück.

In der DNS ist aber ein Eintrag "Zwischengespeicherte Einträge" zu finden, und in dessen Unterverzeichnis ein ".", unter dem alle möglichen Ländercodes eingetragen sind.

Wird dieses benötigt, oder kann das dass Problem sein ?

 

Danke für Eure Hilfe

 

Ralf

Share this post


Link to post

Wählen sich die Clients oder dein Router ins Internet ein? Oder gar der Server??

 

Wenn Du Deinem DNS-Server die Zone "." einträgst, nimmt Dein DNS-Server an, dass er der Ober-Macker-Checker-DNS-Server aller DNS-Server ist und lässt somit alle anderen in Ruhe. Kommt nun eine Abfrage, die er nicht auflösen kann, dann versucht er gar nicht erst einen anderen DNS-Server danach zu fragen, denn er ist ja der festen Überzeugung:

 

"*ey* Wenn ich das nicht weiss, wer denn dann? Schliesslich bin ich ja der Ober-Macker-Checker-DNS-Server" :D

 

Jetzt hast Du zwei Möglichkeiten:

 

1. Du trägst Deinem DNS-Server ALLE DNS-Namen und IP-Adressen ein, die es auf der Welt gibt :D -oder:

 

2.

Wenn Du ihm die Zone "." wegnimmst, fühlt er sich auf einmal schrecklich alleine und hätte gerne jemanden, den er fragen könnte, wenn er was nicht weiss.

Diesen "jemand" musst Du ihm dann unter "Weiterleitung" eintragen :p

Share this post


Link to post

Stimmt zwar, aber...

 

...ich glaube nicht, dass das sein Problem ist. Sein Problem - wenn ich das richtig verstehe - ist, dass der Server alle 3-5 Minuten rauswählt. Nicht, dass er nicht rauswählt...

 

Also an der Weiterleitung wird's nicht liegen, zumal ich davon ausgehe, dass der Router die DNS für das Netz auflöst.

 

Es scheint, als würde wohl der Server selbst irgendetwas broadcasten. Ist zufällt irgendein Update Agent aktiv? Oder ist es vielleicht so, dass der Server auch gleichzeitig eMail-Server ist, und diese einfach austauschen will?

 

Fragen über Fragen :D

 

- Pie

Share this post


Link to post

soso.... gehen wir mal davon aus das du keine weitere Software installiert hast auf deinem Server dann kann es dafür 2 Ursachen geben.

 

1. Der Server schickt NetBios Broadcast ins Netz. Diese kannst du mit Acces Lists blocken (Zielports 137 bis 139; und von Port 137 auf Port 53)

 

2. Wenn der Router die Möglichkeit besitz trag bitte deinen Active Directory Domänennamen im DNS Ein und zwar als Ignore oder negativ. z.B so:

 

*.domain.de.

 

Alles andere musst du mal mit einem Netzwerkmonitor überwachen oder den Router debuggen wenn der sowas erlaubt. Bei Cisco, Bintec und Co geht sowas.

 

Stimpy

Share this post


Link to post

Danke für die Antworten, und ich hatte die Weiterleitung eingerichtet, als ich die Probleme mit den Clients hatte.

Heisst also jetzt das ich den "." löchen sollte oder?

 

Auf dem Server ist keine externe Software aktiv die nach einem Update alle 3 - 5 Minuten verlangt.

Als Mail ist David auf dem Server installiert, und er macht die Mailabfragen alle 30 Minuten, also no.

 

Das mit dem Port 137 - 139 blocken kein Thema, aber die leite ich den Port 137 auf 53 um, denn nach der Aussage meines Etherreal Programmes macht nur der Server, also IP...10.10 die

Einwahl ins Internet auf dem Port 53, und dann werden immer die tollen Systemseiten von Microsoft angewählt, kann man dieses abstellen?

Danke

Share this post


Link to post

Hallo, versuchs mal damit

 

Automatische Updates -> ausstellen in der Systemsteuerung

Windows Zeitdienst -> ausstellen (deaktivieren) unter den Diensten

 

Das sind die meisten Ursachen, warum ein Server sich immer wieder einwählt

Share this post


Link to post
Danke für die Antworten, und ich hatte die Weiterleitung eingerichtet, als ich die Probleme mit den Clients hatte.

Heisst also jetzt das ich den "." löchen sollte oder?

:confused: Wenn dein DNS die Root-Zone "." hostet, kannst du keine Weiterleitung konfigurieren. Das geht logischerweise erst, wenn die Root-Zone auf dem DNS gelöscht wurde.

 

Meine Empfehlung: um herauszufinden, wer oder was genau, deine Routerverbindung immer hochzieht, empfehle ich, den Netzwerkmonitor auf der Schnittstelle, auf der es zum Router geht, mitlaufen zu lassen, und dann gezielt die Pakete zu beleuchten, die an den Router gehen. DANN kann man verlässliche Aussagen machen und nach Lösungen für das Problem suchen. Alles andere ist im "Nebel Herumgestochere".

 

grizzly999

Share this post


Link to post

Hi

 

Jep, habe das autom. Update als auch den Zeitdienst deaktiviert, jedoch ist das prop das selbe.

Mit dem Netzwerkmonitor kann ich machen, aber erhalte ich mit Etherreal alle benötigten Info´s, oder benötige ich ein anderes Programm?

 

Ralf

Share this post


Link to post

Ich meinte nicht das du den Port 137 auf 53 umleiten sollst sondern du solltest die Anfragen die von port 137 kommen und auf 53 gestellt werden sperren. Andernfalls nutz dein etherreal um den Traffic für eine Zeitlang zu speichern und wenn der Router die Verbindung aufbaut dann auswerten.

 

Stimpy

Share this post


Link to post

Hallo

 

Sorry for the late reply, aber ich musste erst einmal wieder an den Server kommen.

 

Also Ethereal hat mir jede Menge aufgezeichnet, hoffe es hilft Euch ein wenig weiter.

Hier ein Auszug aus 949 Sek. Aufzeichung die mir sehr wichtig erscheinen:

 

 

 

Client----Destination Broadcast ----Protokoll ARP ----Who has IP ... aber keine Antwort

Client ---IP..255 (nicht definiert)----- Protokoll NBNS--- Name Query

Client ....IP..255 - „ - Browser Host Announcement Name des Client

Alle Client fragt nach der IP vom Router aber bekommen keine Antwort

Client fragt nach IP von Netzdrucker, IP ist fest aber keine Antwort

Client fragt nach IP von Printer Server, Protokoll ARP, keine Antwort

Server fragt nach Router aber keine Antwort Protokoll ARP

Client an IP.255 (nicht vorhanden) über Protokoll NETLOGON Info: SAM LOGIN request from Client Port 138

Server fragt nach IP 224.0.1.24 Port 42 Protokoll UDP nach dem Nameserver

 

Server an IP...255 Protokoll BROWSER Port 42 Domian/Workgroup Announcement Servername/Domain Controller/NT Workstation Domain Enum

 

Immer wieder die Abfrage nach den Printserver IP´s von allen Client´s aus.

 

Sagt das o.g. einem Irgentwas ?

 

Danke für Eure Hilfe

Share this post


Link to post

Ähm, sorry aber kann mir da keiner helfen, denn die Telefonkosten steigen und steigen, und habe keinen Plan was es sein könnte.

 

Danke

Share this post


Link to post

Ich würde die Sache anders herum angehen: Was soll über den Router raus ins Internet (HTTP, FTP, DNS,....)? Diese Protokolle auf dieser Netzwerkkarte im Routing und RAS im Ausgabefilter zulassen, alle anderen blocken.

Dann sollte Ruhe sein.

 

 

grizzly999

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...