Jump to content
Sign in to follow this  
Shinji_2001

WIN2k Druckserver noch eine wichtige Frage

Recommended Posts

So bei mir läuft jetzt fast alles ganz gut aber naja paar kleine probs ist ja egal!

 

Also mein 2kserver soll als druckserver laufen! Wenn sich jetzt z.B. ein xp rechner an meinen server anmeldet,

kann ich das dann auf meinem server irgendwie einstellen das der Client(PC) dem am Server hängenden Drucker automatisch als Neuen Drucker bei sich einrichtet ohne das der Client(also die Person die davor sitzt) erst auf Netzwerkdrucker und suchen und usw. gehn muss und das selber machen muss!??? :confused: :suspect:

 

hoffe habt es verstanden was ich will :p

Share this post


Link to post

recht haste!! Hab da garnet dran gedacht! Ist hier zufällig jemand ein Spezialist in scripte schreibe und kann mir denn Befehl für drucker einbinden sagen bzw. hat wer nen link wo ich ein bißchen was über scripte nachlesen kann?

Share this post


Link to post

ich habe das mal so gemacht

 

set objWSHNetwork = CreateObject("WScript.Network")

objWSHNetwork.AddWindowsPrinterConnection "printer"

objWSHNetwork.SetDefaultPrinter "printer"

' remove
objWSHNetwork.RemovePrinterConnection "printer"

 

eventuell hilft es ja

 

regards

Share this post


Link to post

Hi,

habe gerade einen anderen Thread zu diesem Thema gepostet......

Schau dir doch mal das Zero Administration Kit an. Und da das Tool "contoprt". Gerade wenn du kreuz und Quer Drucker zuweisen mußt, ist das ne echte Hilfe um nicht Meterlange Scripte zu schreiben bzw. nach Fehlern durchsuchen.

 

 

 

Viele Grüße

ricwa

Share this post


Link to post

finde das thread irgendwie net kannst mal link posten!? :rolleyes:

 

gleich noch ne Frage! Wenn ich mich mit meine client am server anmelde nimmt der irgendwie mein script net!

 

Script habe ich in winnt sysvol usw. gespeichert als cmd!

 

in AD habe ich meinem client bei profil und loginscript den pfad reingeschrieben

\\dstest(servername)\netlogon

oder auch mal

c:\winnt\sysvol\sysvol\test.druck.de\scripts\login.cmd

 

irgendwas habe ich doch noch vergessen zu machen!

 

Ach beim script sieht so aus

 

@echo off

 

con2prt /cd \\Servername\Druckername (also habe den freigabe name KyoceraF genommen)

 

die exe liegt auch im script verz mit drin!

Share this post


Link to post

Aaah,

du benutzt das teil ja schon.......

Deine Beispiele sehen soweit auch brauchbar aus?

Hast du die Parameter zu con2prt gesehen?

Rufst du aus deinem Logon Skript die Druckerzuweisung auf?

 

Hab im anderen Thread das gleiche geschrieben.....

 

 

Viele Grüße

ricwa

 

P.S.

Scheint irgendwie an deinem Logon Skript zu liegen.......

Share this post


Link to post

Anbei noch mal die vorgehensweise......

 

net use O: \\server\fileshare > %systemdrive%\temp\logon.log

con2prt /f /cd \\server\printshare >> %systemdrive%\temp\logon.log

 

So, oder so ähnlich sollte das bei dir auch aussehen........

 

 

/f

löscht bestehende Verbindungen zu Druckern

Share this post


Link to post

und hat wer noch ne idee warum bei meinem client das logon script net startet? Liegt das direkt am script oder habe ich da in der ad oder woanders vergessen ne einstellung zu setzen oder ne freigabe zu machen?

Share this post


Link to post

Ich schätze mal, die CMD liegt im falschen Ordner ... der komplette Pfad wäre recht hilfreich.

Ich gehe mal davon aus, dass du das Script mal mit nem Doppelklick gestartet und getestet hast.

Share this post


Link to post

script liegt auf server in

 

C:\winnt\sysvol\sysvol\test.druck.de\scripts\login.cmd

 

und in der ad habe ich bei dem nutzer in scriptpfad oder wie die 2 zeile heist(also die unter profilpfad)

 

C:\winnt\sysvol\sysvol\test.druck.de\scripts\login.cmd

 

genau das eingetragen!

Share this post


Link to post

Hi,

hast das mit den direkten Pfaden einen besonderen Grund?

Warum benutzt du nicht die dafür vorgesehenen Variablen........

 

 

Oder soll "uns" das nur die Lage der Skripte verdeutlichen?

 

 

Gruß

ricwa

Share this post


Link to post

das hat keinen besonderen Grund!

 

Habe das wirklich so rein geschrieben!

 

Das erste, damit wollte ich nur sagen wo ich mein script auf dem server abgelegt habe!

 

und das zweite damit will ich dem client sagen woher er das script nehmen soll!

Share this post


Link to post

das ist falsch...

unter anmelde scribt schreibste einfach

 

login.bat

 

dann nennste dein script auch login.bat und es wird funktionieren...

 

br

raiko

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...