Jump to content
Sign in to follow this  
osna_frank

Hyper-V und NAT (virtueller Web-Server nicht erreichbar)

Recommended Posts

Hallo,

 

ich habe mir eine virtuelle Testumgebung geschaffen mit 2 Domänencontrollern (einer AD Domäne), einem Exchange Server und 2 WinXP Maschinen.

Der Hostrechner ist ein Win 2008 Server und darauf läuft nur die Hyper-V Rolle.

Die Netzwerkkarte des Hostrechners ist zu einem virtuellen Switch geworden. Es gibt zudem zwei weitere neue Netzwerkverbindungen: ein virtuelles externes Netzwerk (mit realer IP-Adresse 131.xxx) und es gibt ein virtuelles internes Netzwerk (IP: 192.168.0.1). Die Virtuellen Rechner haben alle eine IP-Adresse des virtuellen internen Netzwerkes bekommen. Soweit schein alles OK zu sein. Ich kann vom Host-Server aus die einzelnen virtuellen Rechner (192.168.0.x) ansprechen. Die virtuellen Rechner haben Verbindung mit dem Internet - alles OK.

Der virtuelle Exchange-Server sitzt auf einem Win2003 R2. Dieser besitzt einen Web-Server (IIS) für Outlook Web Access.

 

Nun möchte ich von einem Rechner aus dem realen Netz (also 131.xxx) auf Outlook Web Access (also auf den Web-Server) zugreifen. Der Host-Server soll also die HTTPS-Anfragen weiterleiten an den virtuellen Exchange-Server (192.168.0.x). Und das klappt nicht. Was kann oder muss ich tun? Das müsste irgendwie per NAT laufen oder liege ich da falsch? Wie konfiguriere ich das?

 

Viele Grüße

Frank

Share this post


Link to post
Share on other sites

Hallo und Willkommen hier.

 

Mit Hyper-V spiele ich zwar nicht rum, doch sind NAT-Netzwerke prinzipiell (wie im Internet) nicht von aussen zu erreichen.

 

Es sei denn, über Reverse-Nat oder Port-Forwarding. Du müsset dann also die Ports vom Exchange auf die interne NAT-IP forwarden. Ich wüsste aber nicht, wozu der Hyper-V das unterstützen sollte. Also: deaktiviere den NAT-Kram und gib den VM reale Adressen aus Deinem 131*er Netz über einen virt. Switch, oder so.

 

-Zahni

Share this post


Link to post
Share on other sites

Hallo Zahni,

 

danke für den Willkommensgruß!

 

Wir haben ein Produktiv-Active Directory im realen Netz. Und diese AD-Umgebung auf dem Hyper-V Hostrechner soll nur zum Testen und "Spielen" dienen und nur für bestimmte Rechner des realen Netzes an bestimmten Ports erreichbar sein.

Dafür wollte ich eine Virtualisierungslösung mit einem privaten Netz (also mit 192.168.xx-Adressen).

Das funktioniert auch alles ganz gut. Was mir eben noch fehlt ist das IP-Forwarding. Wenn jemand im realen Netz im Browser eingibt "https://<IP Hostrechner>/owa", dann soll das an den virtuellen Exchange-Server weitergeleitet werden. Prinzipiell ist sowas kein Problem. Nur mit Hyper-V bekomme ich es nicht hin.

NAT läuft übrigens noch gar nicht. Ich lese zwar überall, dass Hyper-V NAT unterstützt aber nicht wie das konfiguriert wird.

 

Für weitere Hilfe wäre ich sehr dankbar.

 

VG

Frank

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...