Jump to content
Sign in to follow this  
tzepf

Softwareverteilung über GPO von MSI Paket - Rechte nicht ausreichend?

Recommended Posts

Hallo zusammen,

 

ich hab mit WINInstallLE ein .msi Paket von TightVNC auf einer nackten Maschine erstellt. Die Installation auf einem normalen Rechner funktioniert auch, das richtige Passwort wird gesetzt usw.

 

Ich habe das MSI Paket im SBS03 unter Computerkonfiguration hinzugefügt. Dort ist auch Firefox als MSI Paket, was funktioniert.

 

Bei der automatischen Installation hapert es jetzt aber. In der Ereignisanzeige auf dem Client steht: Fehler 1303. Die Rechte von Installer reichen nicht aus, um auf diesen Ordner zuzugreifen: C:\Programme\TightVNC. Die Installation kann nicht fortgesetzt werden...

 

Was soll das? Ist nicht gerade die Installation über Gruppenrichtlinien dazu da, dieses Problem zu umgehen?

 

Was mach ich falsch?

 

Gruß

Tobias

Share this post


Link to post

ich hab mit WINInstallLE ein .msi Paket von TightVNC auf einer nackten Maschine erstellt. Die Installation auf einem normalen Rechner funktioniert auch, das richtige Passwort wird gesetzt usw.

 

Die Installation hast Du im Userkontext ausgeführt?

 

Ich habe das MSI Paket im SBS03 unter Computerkonfiguration hinzugefügt. Dort ist auch Firefox als MSI Paket, was funktioniert.

 

Bei der automatischen Installation hapert es jetzt aber. In der Ereignisanzeige auf dem Client steht: Fehler 1303. Die Rechte von Installer reichen nicht aus, um auf diesen Ordner zuzugreifen: C:\Programme\TightVNC. Die Installation kann nicht fortgesetzt werden...

 

Bist Du sicher, daß die Meldung zur Installationszeit passt? Nicht das beim anschließend angemeldeten Benutzer weiter konfiguriert werden soll, und das jetzt fehlschlägt, weil der User keine Rechte hat.

 

Alternativ kannst Du mal diese Einstellung aktivieren: Computerkonfig > Admin-Vorlagen > Windows Komponenten > Windows Installer > Immer mit erhöhten Rechten installieren > Aktivieren. Ich glaub zwar nicht, daß es hilft, aber versuchen kannst Du es ja.

 

Was soll das? Ist nicht gerade die Installation über Gruppenrichtlinien dazu da, dieses Problem zu umgehen?

 

Wenn die SW es zulässt, im Computerkontext installiert zu werden, dann hast Du Recht.

 

Was mach ich falsch?

 

Andersrum gefragt: Weshalb benötigst Du die SW? Du kennst Remote-Unterstützung? Remoteunterstützung - Remoteassistence anbieten und konfigurieren

Share this post


Link to post

Die Installation wurde unter VMWare durchgeführt, von einem Image. WinInstallLE kann man aber auf Benutzerebene nicht ausführen, hab halt den Standard Admin Account genommen den man nach ner XP installation so hat ;)

 

liegt hier der hund begraben?

 

die meldung passt, denn wenn ich direkt aufs msi klicke kommt der gleiche fehler...

 

remoteunterstützung kenn ich, tightvnc is mir aber lieber, da ich da sofort ohne nachfrage intervenieren kann :)

Share this post


Link to post

Also als Fazit: Die Installation scheint im Computerkontext nicht zu funktionieren, daher die Fehlermeldung, welche aus dem Userkontext kommt. Also solltest du dir entweder ne andere Möglichkeit überlegen, die Software zu verteilen, oder ein "besseres" MSI erzeugen (lassen).

Share this post


Link to post
Die Installation wurde unter VMWare durchgeführt, von einem Image. WinInstallLE kann man aber auf Benutzerebene nicht ausführen, hab halt den Standard Admin Account genommen den man nach ner XP installation so hat ;)

 

So ganz versteh ich das noch nicht, was Du mir damit sagen willst. Kennst Du diese Anleitung? Eigenbau und Erstellung eines MSI Paketes Bist Du genauso vorgegangen?

 

die meldung passt, denn wenn ich direkt aufs msi klicke kommt der gleiche fehler...

 

Irgendwas passt wohl noch nicht.

 

remoteunterstützung kenn ich, tightvnc is mir aber lieber, da ich da sofort ohne nachfrage intervenieren kann :)

 

Autsch, das kann sehr gefährlich sein, das ist dir schon klar, oder?

Share this post


Link to post

ich hab die anleitung eigentlich so befolgt, allerdings seh ich gerade dass ich am schluss nicht auf compress geklickt hatte (war in meinem tutorial net drin). werde das noch mal probieren.

 

als administrator kann ich das ding installieren... so ein käse das alles

 

werde wohl doch auf die remoteuntersützung zurückgreifen müssen, auch wenns mir nicht gefällt

Share this post


Link to post
ich hab die anleitung eigentlich so befolgt, allerdings seh ich gerade dass ich am schluss nicht auf compress geklickt hatte (war in meinem tutorial net drin). werde das noch mal probieren.

 

Erhoff dir allerdings nicht zu viel davon.

 

als administrator kann ich das ding installieren... so ein käse das alles

 

Admin ist nicht User bzw. Lokales System.

 

werde wohl doch auf die remoteuntersützung zurückgreifen müssen, auch wenns mir nicht gefällt

 

Ist schnell via GPO eingerichtet und auch rechtlich im grünen Bereich.

Share this post


Link to post

Admin ist nicht User bzw. Lokales System.

 

wo kämen wir denn da auch hin :)

 

trotzdem danke für deine hilfestellung!

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...