Jump to content
Sign in to follow this  
osirus01

Bekomme keine ISDN einwahl zustande

Recommended Posts

Hallo, habe hier zwei CISCO 801 ISDN Router. Soll die beiden für eine Anbindung nach Österreich fertig machen. Da ich das ganze erst mal testen wollte, habe ich die Router folgender massen konfiguriert.

Sollte doch eigentlich richtig sein, oder ? Bekomme keine Verbindung hin.

 

R O U T E R 1

 

Building configuration...

 

Current configuration:

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Router1

!

enable secret password

!

username Router1 password password

username Router2 password password

!

!

!

!

ip subnet-zero

!

isdn switch-type basic-net3

!

--More--

00:12:23: %PQUICC-1-LOSTCARR: Unit 0, lost carrier. Transceive! ?

process-max-time 200

!

interface Ethernet0

description LAN Oesterreich

ip address 192.168.20.254 255.255.255.0

no ip directed-broadcast

!

interface BRI0

no ip address

no ip directed-broadcast

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

!

interface Dialer1

ip address 10.10.10.6 255.255.255.252

no ip directed-broadcast

encapsulation ppp

dialer remote-name Router1

dialer string 00026349602841

dialer pool 1

dialer-group 1

ppp authentication chap

ppp multilink

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.10.5

ip route 10.224.192.0 255.255.240.0 10.10.10.5

!

dialer-list 1 protocol ip permit

!

line con 0

transport input none

stopbits 1

line vty 0 4

password password

login

!

end

 

Router1#

 

 

 

 

 

R O U T E R 2

 

 

Building configuration...

 

Current configuration:

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Router2

!

enable secret password

!

username Router1 password password

username Router2 password password

!

!

!

!

ip subnet-zero

!

isdn switch-type basic-net3

!

!

process-max-time 200

!

interface Ethernet0

description BuM LAN

ip address 10.224.192.59 255.255.240.0

no ip directed-broadcast

!

interface BRI0

no ip address

no ip directed-broadcast

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp callback accept

ppp authentication ms-chap

!

interface Dialer1

ip address 10.10.10.5 255.255.255.252

no ip directed-broadcast

encapsulation ppp

dialer remote-name Router1

dialer pool 1

dialer-group 1

ppp callback accept

ppp authentication ms-chap

ppp multilink

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.10.6

ip route 192.168.20.0 255.255.255.0 10.10.10.6

!

dialer-list 1 protocol ip permit

!

line con 0

transport input none

stopbits 1

line vty 0 4

exec-timeout 30 0

password password

login

!

end

 

Router2#

 

 

 

Hier der ISDN q931 Debug

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.224.XXX.XXX, timeout is 2 seconds:

 

00:06:85899345920: ISDN BR0: TX -> SETUP pd = 8 callref = 0x03

00:06:85905379356: Bearer Capability i = 0x8890

00:06:85899386880: Channel ID i = 0x83

00:06:85899386880: Called Party Number i = 0x80, '0002XXXXXXXXXXX'

00:06:20: ISDN BR0: RX <- SETUP_ACK pd = 8 callref = 0x83

00:06:20: Channel ID i = 0x89..

00:06:23: %PQUICC-1-LOSTCARR: Unit 0, lost carrier. Transceiver problem?

00:06:24: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0x83

00:06:24: Channel ID i = 0x89..

00:06:28: ISDN BR0: RX <- DISCONNECT pd = 8 callref = 0x83

00:06:28: Cause i = 0x8192 - No user responding

00:06:120259125248: ISDN BR0: TX -> RELEASE pd = 8 callref = 0x03

00:06:120265117724: Cause i = 0x809208 - No user responding

00:06:28: ISDN BR0: RX <- RELEASE_COMP pd = 8 callref = 0x83

00:06:120259125248: ISDN BR0: TX -> SETUP pd = 8 callref = 0x04

00:06:120265117724: Bearer Capability i = 0x8890

00:06:120259125248: Channel ID i = 0x83

00:06:120259.

Success rate is 0 percent (0/5)

Router1#125248: Called Party Number i = 0x80, '0002XXXXXXXXX'

00:06:28: ISDN BR0: RX <- SETUP_ACK pd = 8 callref = 0x84

00:06:28: Channel ID i = 0x89

00:06:32: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0x84

00:06:32: Channel ID i = 0x89

00:06:32: ISDN BR0: RX <- DISCONNECT pd = 8 callref = 0x84

00:06:32: Cause i = 0x809F - Normal, unspecified or Special intercept, c

all blocked group restriction

00:06:137438994432: ISDN BR0: TX -> RELEASE pd = 8 callref = 0x04

00:06:137444986908: Cause i = 0x809F08 - Normal, unspecified or Special

intercept, call blocked group restriction

 

 

 

Schonmal Danke für Eure hilfe! :D

Share this post


Link to post

Router1:

 

dialer remote-name Router1

dialer string 00026349602841

 

Router2:

hostname Router2

 

Ich kenne zwar die Ciscos nicht, aber bei allen ISDN-Routern, die ich bisher verbaut habe, musste man bei "Remote-Name" (also Gegenstellenname) den Namen des anderen Routers eintragen, teilweise auch mit Telefonnummer (bzw. MSN), so dass die Router halt wissen, wer da anruft. Wenn die Namen nicht gestimmt haben (wie bei Deinem Beispiel), hats nicht gefunzt.

:wink2:

Share this post


Link to post

Ups sorry, habe da wohl einen Fehler im Beitrag gehabt. :D

In der original Konfig habe ich bei dialer remote-name den anzurifenden Router eingetragen.

Also halt dialer remote-name Router2

Share this post


Link to post

Habe den Router jetzt umkonfiguriert und die Dialer-Profiles weggelassen. Arbeitet jetzt nur noch mit dem Bri0 Interface.

Dort habe ich dann auch mit dem befehl "dialer map ip XXX.XXX.XXX.XXX name Hostname Rufnummer"

Die Hosts auf den Router bekannt gemacht. Bekomme aber immer noch die Fehlermeldung :cry::cry:

 

 

Sending 5, 100-byte ICMP Echos to 10.224.XXX.XXX, timeout is 2 seconds:

 

00:05:133143986176: ISDN BR0: TX -> SETUP pd = 8 callref = 0x01

00:05:133150019612: Bearer Capability i = 0x8890

00:05:133144027136: Channel ID i = 0x83

00:05:133144027136: Called Party Number i = 0x80, '000XXXXXXXXX'

00:05:31: ISDN BR0: RX <- SETUP_ACK pd = 8 callref = 0x81

00:05:31: Channel ID i = 0x89.

00:05:34: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0x81

00:05:34: Channel ID i = 0x89..

00:05:38: ISDN BR0: RX <- DISCONNECT pd = 8 callref = 0x81

00:05:38: Cause i = 0x8192 - No user responding

00:05:163208798208: ISDN BR0: TX -> RELEASE pd = 8 callref = 0x01

00:05:163214790684: Cause i = 0x809208 - No user responding

00:05:38: ISDN BR0: RX <- RELEASE_COMP pd = 8 callref = 0x81

00:05:167503765504: ISDN BR0: TX -> SETUP pd = 8 callref = 0x02

00:05:167509757980: Bearer Capability i = 0x8890

00:05:167503765504: Channel ID i = 0x83

00:05:167503.

Success rate is 0 percent (0/5)

oesterreich#765504: Called Party Number i = 0x80, '000XXXXXXXX'

00:05:39: ISDN BR0: RX <- SETUP_ACK pd = 8 callref = 0x82

00:05:39: Channel ID i = 0x89

00:05:42: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0x82

00:05:42: Channel ID i = 0x89

00:05:42: ISDN BR0: RX <- DISCONNECT pd = 8 callref = 0x82

00:05:42: Cause i = 0x809F - Normal, unspecified or Special intercept, c

all blocked group restriction

00:05:180388667392: ISDN BR0: TX -> RELEASE pd = 8 callref = 0x02

00:05:180394659868: Cause i = 0x809F08 - Normal, unspecified or Special

intercept, call blocked group restriction

00:05:42: ISDN BR0: RX <- RELEASE_COMP pd = 8 callref = 0x82

Share this post


Link to post

Mal ne ganz dumme Frage (nicht böse sein): Sind die Router so eingestellt, dass sie einen eingehenden Anruf auf ihrer Nummer auch annehmen?

Und gleich noch eine dumme Frage hinterher: Beide Router sind direkt an einen S0-Bus (also entweder am NTBA oder an einer Anlage mit S0) angeschlossen?

 

*schonmalindeckunggeh*

Share this post


Link to post

Hi, nein bin Dir nicht böse. :D

 

wir haben eine Avaya Telefonanlage. Die macht dieses Ammi-ISDN :)

 

Für die Euro-ISDN Verbindungen haben wir so ISDN-Board darin.

Dann wird für jeden Port eine Rufnummer hinterlegt. D.h. der Router hängt an Prot XY und somit auch nur auf der Nummer 123456 erreichbar. Die Nummer werden den Ports zugeordnet.

Share this post


Link to post

Habe die Router jetzt beide nochmal umkonfiguriert. Habe mal die Dialer Profiles weggelassen. Sieht jetzt so aus

 

Router1

 

Current configuration:

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router1

!

enable secret password

!

username Router2 password 0 password

username Router1 password 0 password

!

!

!

!

ip subnet-zero

!

isdn switch-type basic-net3

!

!

process-max-time 200

!

interface Ethernet0

 

ip address 10.224.192.59 255.255.240.0

no ip directed-broadcast

!

interface BRI0

ip address 10.10.10.5 255.255.255.252

no ip directed-broadcast

encapsulation ppp

dialer map ip 10.10.10.6 name Router2 002xxxxxxxx

dialer-group 1

isdn switch-type basic-net3

ppp authentication chap

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.10.6

ip route 192.168.20.0 255.255.255.0 10.10.10.6

!

dialer-list 1 protocol ip permit

!

line con 0

transport input none

stopbits 1

line vty 0 4

password password

login

!

end

 

Router1#

 

 

 

 

Router2

 

 

 

Building configuration...

 

Current configuration:

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router2

!

enable secret password

 

username Router1 password password

username Router2 password password

!

!

!

!

ip subnet-zero

!

isdn switch-type basic-net3

!

!

process-max-time 200

!

interface Ethernet0

ip address 192.168.20.254 255.255.255.0

no ip directed-broadcast

!

interface BRI0

ip address 10.10.10.6 255.255.255.252

no ip directed-broadcast

encapsulation ppp

dialer map ip 10.10.10.5 name Router1 0002xxxxxxxx

dialer-group 1

isdn switch-type basic-net3

ppp authentication chap

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.10.5

ip route 10.224.192.0 255.255.240.0 10.10.10.5

!

dialer-list 1 protocol ip permit

!

line con 0

transport input none

stopbits 1

line vty 0 4

exec-timeout 30 0

password password

login

!

end

 

Router2#

 

 

 

 

so sollten die Dinger doch zumindest mal mit einander reden, oder? Kann biite mal jemand schauen ob die Konfig richtig ist ? :confused:

Share this post


Link to post

mach mal noch die authentification ppp chap raus. dann müssen die miteinder reden. und du mußt auf jeden fall ein connect bekommen, ohne das die router unterbrechen. wenn du noch einen disconnect bekommst. liegt das an deiner tk-anlage meineserachtens. weil die config ist so wie sie jetzt ist total o.k. wenn nicht schcike nochmal den debug isdn q931 aber dann bitte von beiden routern der der wählt und der der empfängt.

Share this post


Link to post

Hi, habe jetzt mal die CHAP Geschichte rausgenommen. Ist leider das selbe Ergebnis. Der wählt den zwar an und verbindet sich auch kurz mit dem, aber legt dann wieder auf. Kann auch kein Interface auf der Gegenseite anpingen. Irgendwas mache ich doch falsch?

 

 

 

oesterreich#ping 10.224.192.5929888796: Bearer Capab

 

Type escape sequence to abort.secess RETURN to get started!

Sending 5, 100-byte ICMP Echos to 10.224.192.59, timeout is 2 seconds:net0, changed state to up

00:10:150323896320: Called

 

00:22:137438994432: ISDN BR0: TX -> SETUP pd = 8 callref = 0x05Received 0 broadcasts, 0 runts, 0 giants,

00:10:35: ISDN BR0: RX

00:22:137444986908: Bearer Capability i = 0x8890ut errors, 0 CRC, 0 frame, 0 overrun, 0

00:10:35:

00:22:137438994432: Channel ID i = 0x83

00:10:35: Progress Ind i = 0

00:22:32: Channel ID i = 0x89 Calling Party Number i = 0x0

00:22:32: Progress Ind i = 0x8188 - In-band info or appropriate now avai:10:35: Called Party Number i = 0xC1, '22'

MTU 1500 b

lableBW 64

00:22:33: ISDN BR0: RX <- SETUP pd = 8 callref = 0x01d a DATA call from 026124380 on B2 a5, txload 1/255, rx

00:22:33: . Bearer Capability i = 0x8890

own

t 64 Kb/ssulation

00:10:15032389

00:22:33: Channel ID i = 0x8A8 callref = 0x81

00:22:33: Channel ID i = 0x89...

00:22:39: %ISDN-6-CONNECT: Interface BRI0:2 is now connected to 026124380 .

Success rate is 0 percent (0/5)

oesterreich#ping 10.224.192.59

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.224.192.59, timeout is 2 seconds:

...

00:22:57: %ISDN-6-DISCONNECT: Interface BRI0:2 disconnected from 026124380 , ca

ll lasted 24 seconds

00:22:244813176832: ISDN BR0: TX -> DISCONNECT pd = 8 callref = 0x81

00:22:244819169308: Cause i = 0x8090 - Normal call clearing

00:22:57: ISDN BR0: RX <- RELEASE pd = 8 callref = 0x01

00:22:57: Cause i = 0x0280E6 -

00:22:244813176832: ISDN BR0: TX -> RELEASE_COMP pd = 8 callref = 0x81

00:22:249108103167: %LINK-3-UPDOWN: Interface BRI0:2, changed state to down

00:22:57: ISDN BR0: RX <- RELEASE pd = 8 callref = 0x01

00:22:57: Cause i = 0x0280E6 - ..

Success rate is 0 percent (0/5)

oesterreich#

00:23:8589975552: ISDN BR0: TX -> DISCONNECT pd = 8 callref = 0x05

00:23:8595968028: Cause i = 0x8090 - Normal call clearing

00:23:02: ISDN BR0: RX <- RELEASE pd = 8 callref = 0x85

00:23:8589975552: ISDN BR0: TX -> RELEASE_COMP pd = 8 callref = 0x05

Share this post


Link to post

das ist doch komisch. Du bist aber in deutschland an einer TK-Anlage oder an einem direktem S0-Bus. Wenn dann schau dir doch bitte mal folgenden Link an. Habe dort eine konfig gepostet. Versuche doch mal mit dem Bri Interface ins Internet zu kommen. Wenn das Funktioniert, machst du die 2 Konfig drauf und dann gehts weiter.

http://www.mcseboard.de/showthread.php?s=&threadid=11100&highlight=cisco+isdn

wenn du einen Internet Provider benötigst der eine normale Rufnummer zur Verfügung stellt wg Rufnummernsperre im der TK-Anlage dann suche mal bei http://www.onlinekosten.de die müssen da irgendwo die nummern zu stehen haben. sage mal bescheid über das ergebniss

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...