Jump to content
Sign in to follow this  
pablovschby

ausm DNS raus....trotzdem kann ich den Host pingen...

Recommended Posts

Hallo

 

Win2k-serverumgebung...

 

Der Datenserver übernimmt DNS, wobei der DHCP-Server noch zusätzlich der second DNS ist....nun habe ich folgenden Effekt:

 

Eine Arbeitsstation von uns heisst "WP_5" (netbios-name).....diese bekam heute morgen von unserem dhcp die ip "192.168.3.43".....diese lässt sich pingen und alles ist gut, soweit....nun das problem:

  • eine station, die seit gut etwa 3 Monaten nicht mehr im Netzwerk ist .,..... hiess damals noch "testpc2".......tja....und bekam irgendwann wahrscheinlich auch mal diese ip....
    nun....heute habe ich ganz schön gestaunt...von meinem lokalen pc aus konnte ich ein ping ausführen auf den pc "testpc2"....tja.... und der ping wurde ausgeführt auf die ip "192.168.3.43".........also irgendwie meint mein lokaler pc irgendwie, .... dass der testpc2 die ip .....43 hat...

dies wäre grundlegend nicht mal so komisch....wenn man entsprechenden eintrag aufm dns finden würde.....aber hier:

  • ....-primary dns---> keinen eintrag vorhanden für die ip ...43 ausser jener für "WP_5"....
    ...-das gleiche aufm second dns....kein eintrag mit "testpc2"
    -->all das in der reverse und lookup zone....

- alle dateien in dem ordner /winnt/system32/drivers/etc auf den lokalen arbeitsplätzen und servern abgecheckt-->keine einträge drinnen....

  • wenn ich ein nslookup auf den namen "testpc2" ausführe......meint der dns, .... er finde keinen eintrag...

.....kann mir vielleicht (bitte, bitte) jemand von euch erklären, wieso zum geier ich trotzdem auf mehreren clients und allen servern den host "testpc2" als "....43" pingen kann?????

 

wie gesagt... der nslookup sagt: no entry...

 

"ipconfig /flushdns" auf allen servern und arbeitsplätzen mehrmal ausgeführt....

gruss&bin um jeden tipp froh...

pablo

 

p.s.: kurz und verständlich:

 

ping testpc2

--> ping wird ausgeführt auf 192.168.3.43

 

nslookup

testpc2

--->"non-existent domain"

hab ich noch nie gesehen.....kommt mir sehr spanisch vor....

Share this post


Link to post

Hallo pablovschby,

wenn ihr noch wins im einsatz habt, schau in den wins server ob dort

noch ein eintrag auf den testpc2 vorhanden ist.

 

thorgood

Share this post


Link to post
wenn ihr noch wins im einsatz habt, schau in den wins server ob dort
alles abgecheckt....kein WINS irgendeinem Server am laufen.......

 

wir haben NT4-Workstations, noch etwa 2 bis 3.... im Netzwerk.,... könnten die ein Problem machen mit WINS???

 

ich geh mal zu diesen Stationen und werde da, falls aktiv, den WINS dienst mal deaktivieren...

gruss&danke

pablo

Share this post


Link to post

ok....habs aufm Domain Controller gesehen:

 

er ist im mixed-mode....also müsste da WINS irgendwie noch laufen...aber wie komme ich auf die "WINS-Liste"..., "WINS-Einträge"....warum sind die anders als beim AD-DNS...?

gruss&danke

pablo

Share this post


Link to post

Unter Verwaltung/WINS den Server suchen.

Unter diesem rechte Maustaste auf Aktive Registrierungen

nach Namensuchen... * eingeben und Enter.

Irgenwo steht dort der alte Client mit IP Adresse.

 

thorgood

Share this post


Link to post

alle lmhosts.... in /system32/drivers/etc sind leer...

 

....ein "eigentlich dürfte das nicht einen solchen effekt haben" wäre wenigstens eine hilfe.....bitte bitte

gruss&danke

pablo

Share this post


Link to post
Original geschrieben von thorgood

Unter Verwaltung/WINS den Server suchen.

Unter diesem rechte Maustaste auf Aktive Registrierungen

nach Namensuchen... * eingeben und Enter.

Irgenwo steht dort der alte Client mit IP Adresse.

 

thorgood

es tut mir leid..... ich habe auf allen servern nachgeschau....nirgens unter "administrative tools" oder "control panel" irgendwas mit "wins", vergiss es...

 

....ich mach dir gern en printscreen, wennde willst...

 

nur unter tcp/ip- gibts da paar sachen, die bei beiden servern zu wins aktiviert sind, aber keine liste...---....

 

der nt4-pc bekommt nach wie vor namen-zu-ip-auflösung....also wo könnte/sollte ich noch nachschauen?

 

irgendwo muss das doch sein...

 

aufm i-net heissts: wins-liste in lmhosts.sam.....und die sind alle leer

 

 

hilfe, hilfe

pablo

Share this post


Link to post

Also um das Problem nochmal einzukreisen.

Du hast nur Windows 2000 Server im Einsatz oder noch NT4 Server?

Auf allen Servern gibt es keinen Dienst namens

"WINS (Windows Internet Name Service)".

Der Rechner testpc2 ist seit 3 Monaten nicht mehr aktiv im Netz gewesen.

Dann ist das für mich unerklärlich. Sorry...

 

thorgood

 

PS: lmhosts.sam ist nur eine Beispieldaten die aktive genutzte heist nur lmhosts.

Share this post


Link to post
Original geschrieben von thorgood Also um das Problem nochmal einzukreisen.

Du hast nur Windows 2000 Server im Einsatz oder noch NT4 Server?

...nur Win2k-Server
Auf allen Servern gibt es keinen Dienst namens

"WINS (Windows Internet Name Service)".

wie schon gesagt, kann ich dies unter "computer management/services" NICHT finden.... ein WINS-dienst finde ich nirgens .... auf keinem DC (auch DNS) und DHCP-Server
Der Rechner testpc2 ist seit 3 Monaten nicht mehr aktiv im Netz gewesen.

Dann ist das für mich unerklärlich. Sorry...

....ok, danke....dacht ich's mir doch.... typisch microsoft, .... da gibts so viele unerklärliche, unlogische sachen...
PS: lmhosts.sam ist nur eine Beispieldaten die aktive genutzte heist nur lmhosts.
und die ist auch leer....

gruss

pablo

Share this post


Link to post
Original geschrieben von klausk

Hast Du auf den DNS-Servern auch in der Cache-Zone nachgeschaut?

sorry....aber wo finde ich das???

ich sehe da nur eine "forward" und eine "reverse" lookup zone....

gruss

pablo

Share this post


Link to post

Im DNS MMC-Snap in gibts bei Ainsicht einen Punkt Erweiterte Ansicht, dort kann man die zwischengespeicherten Lookupzonen sichtbar machen. Aber das ist wohl kaum das Problem, sonst würde ja NSLOOKUP auflösen. Probier mal

Ping {Host.Domainsufix}, also den FQN anpingen, dort wird die Auflösung immer über DNS gemacht, das dürfte nicht funktionieren, damit scheidet DNS als verursacher aus.

 

MfG

 

Apotheker

Share this post


Link to post

Nee mit unerklärlich meine ich folgendes.

Wenn du an einer Arbeitsstation ein Ping auf testpc2 machst

und kein DNS Server diesen Namen kennt bleibt als einzige Möglichkeit der lokale NetBios Cache als Antwortgeber.

Dieser "lernt" aber seinen Inhalt entweder über einen WINS Server oder wenn ein aktiver PC

namens testpc2 ihm seine IP via broadcast mitteilt.

Check mal an dem PC wo ein Ping auf testpc2 antwortet den Namenscache mit nbtstat -c

 

thorgood

Share this post


Link to post
Original geschrieben von Apotheker

Im DNS MMC-Snap in gibts bei Ainsicht einen Punkt Erweiterte Ansicht, dort kann man die zwischengespeicherten Lookupzonen sichtbar machen. Aber das ist wohl kaum das Problem, sonst würde ja NSLOOKUP auflösen. Probier mal

Ping {Host.Domainsufix}, also den FQN anpingen, dort wird die Auflösung immer über DNS gemacht, das dürfte nicht funktionieren, damit scheidet DNS als verursacher aus.

 

MfG

 

Apotheker

danke...aber selbstverständlich dieser effekt:
  • alle cached lookups sind adressen im WAN

es sind da keine anderen hosts sichtbar...

gruss&danke

pablo

Share this post


Link to post

C:\>nbtstat -c

Local Area Connection:
Node IpAddress: [192.168.3.32] Scope Id: []

   No names in cache

C:\>ipconfig /flushdns

Windows 2000 IP Configuration

Successfully flushed the DNS Resolver Cache.

C:\>ping testpc2

Pinging testpc2 [192.168.3.43] with 32 bytes of data:

Reply from 192.168.3.43: bytes=32 time<10ms TTL=128
Reply from 192.168.3.43: bytes=32 time<10ms TTL=128
Reply from 192.168.3.43: bytes=32 time<10ms TTL=128
Reply from 192.168.3.43: bytes=32 time<10ms TTL=128

Ping statistics for 192.168.3.43:
   Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
   Minimum = 0ms, Maximum =  0ms, Average =  0ms

C:\>

tja-......wie wir hier alle sehen:

  • 1. kein WINS-server...

2. nichts im cache......

 

GOTTES HAND....????

gruss&danke

pablo

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...