Jump to content
Sign in to follow this  
kai_local

DNS mit Win98/2000 geht (nicht)

Recommended Posts

Hallo ihr Gurus :wink2: ,

 

Also, was mein Problem ist:

Eine Eingabe im Browser, z. B. "vaio", soll auf einen lokalen Rechner verweisen, ohne dass sich der Router ins Internet einwählt.

 

Der IIS läuft auf einem Win2000Prof-Notebook, und wenn ich am Win2000-Client "vaio" eingebe, erhalte ich die von mir auf dem IIS definierte Startseite.

Auf Client A (2000Prof) ist als DNS nur der Router eingetragen mit der IP 192.168.0.1. Ebenso auf dem Client B (W98SE). Wenn ich im Browser von A "vaio" eingebe, erscheint schnell die Seite des Servers, ohne dass sich der Router ins Internet einwählt. Wenn ich dasselbe beim Client B probiere, wählt sich der Router zunächst ins Internet ein, und nach ca. 30 bis 45 Sekunden kommt dann auch die richtige Seite. Es scheint so, als ob zunächst der DNS-Server des Providers angeklingelt wird, um dann festzustellen: Vaio? Internet? Is nich, schau nochmal bei dir.

Wenn ich unter W98 in die hosts-Datei vaio 192.168.0.3 eintrage, geht es (natürlich?) auch. Allerdings ist es - gelinde gesagt - doof, bei allen Clients dieses eintragen zu müssen.

Bei dem W98-Client ist DNS aktiviert, der Router ist als erste Adresse eingetragen, sonst nix (naja, ein Rechnername noch :D )

 

Der Router ist übrigens ein Elsa ISDN Microlink 4 U, dessen DNS-Tabelle interessanterweise ausschliesslich über telnet zugängig ist.

 

Gibt es unter W98 ein DNS-Problem, oder worin könnten meine Probleme liegen?

 

Greetz to the fantastic mods!

 

Kai

 

PS: Linguatec übersetzte einen Auszug aus dem DNS-Whitepaper von MS so:

"Ein Meisterserver ist die Quelle der Zoneninformation." (Das musste eigentlich schon immer mal gesagt werden, finde ich :p )

Share this post


Link to post

Der Router argiert nur als Forwarder für DNS-Anfragen. Das heißt er leidet die Anfragen an die DNS-Server deines Provider weiter.

 

Um das Problem zu lösen müsstest du einen DNS-Server für dein lokales LAN konfigurieren oder die Einträge in die Hosts-Datei machen.

Eine kostenlose Lösung als DNS-Server stellt BIND da.

http://www.isc.org/products/BIND/

Share this post


Link to post

Hmmm, klingt alles soweit logisch. Aber warum (oder womit) findet der W2K-Client dann die Seite? :confused: Oder sprechen sich die W2K-Client untereinander noch anderweitig ab?

 

MfG

 

Kai

Share this post


Link to post

Hab was ausprobiert: Es funktioniert auch, wenn der Apache läuft, allerdings funktioniert es immer nur, wenn auf den Rechnernamen (in diesem Falle "vaio") abgefragt wird, jedoch nicht über ander VirtualHosts.

Der o. g. Client A ist ja ein anderer W2K-Rechner als der Webserver. Das ist ja das, was micht im wesentlichen irritiert, weil es ja dadurch so aussieht, als ob es am W98-Client liegt.

Ich glaube, ich mag keine Computer ;)

 

MfG

Kai

Share this post


Link to post

Auch auf die Gefahr hin, dass ich mir selbst geholfen habe :rolleyes: :

Infos hier: http://www.mcseboard.de/showthread.php?threadid=13580

 

Dabei geht es zwar ursprünglich nicht um die Namensauflösung, aber interessant waren die Infos auf jeden Fall. Jetzt muss ich nur noch mal überlegen, wie ich das machen tu, mit dem Router und so. Hmmmm...

 

MfG

 

Kai

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...