Jump to content
Sign in to follow this  
coto

Catalyst VLAN Frage

Recommended Posts

Hallo,

 

ich bin gerade dabei mich näher mit dem Thema VLAN zu beschäftigen. Daher habe ich eine kleine Testumgebung mittels CCNA Network Visualizer aufgebaut. An einem Catalyst 3560 habe ich ingesamt 4 VLANs definiert. Auf dem VLAN 1 wurde die Management IP des Switches konfiguriert. Die verschiedenen PCs ( unterschiedliche Netzbereiche ) wurden in jeweils ein VLAN eingegliedert. Jedem VLAN wurde auf dem Switch auch eine IP Adresse gegebenen. Die PCs können sich untereinander nicht erreichen ( weil momentan kein Routing definiert ist ). Allerdings müsste ich doch die jeweilige IP Adresse des VLAN anpingen können, oder.

 

Beispiel: VLAN 2 192.168.1.100 255.255.255.0

PC IP 192.168.1.1 255.255.255.0

 

Ein Ping von PC auf die IP 192.168.1.100 und umgekehrt ist nicht möglich.

 

Hier mal die Ausgabe von sh run des Switches.

 

core Con0 is now available

 

 

 

Press RETURN to get started!

 

 

 

core>show run

^

% Invalid input detected at '^' marker.

core>en

core>enable

core#sh run

 

Building configuration...

 

Current configuration : 868 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname core

!

!

!

!

no aaa new-model

system mtu routing 1500

no ip subnet-zero

!

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface FastEthernet0/1

switchport access vlan 4

!

interface FastEthernet0/2

switchport access vlan 3

!

interface FastEthernet0/3

switchport access vlan 2

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface GigabitEthernet0/1

!

interface Vlan1

ip address 192.168.2.1 255.255.255.0

no ip route-cache

!

interface Vlan2

ip address 192.168.1.100 255.255.255.0

no ip route-cache

!

interface Vlan3

ip address 172.17.3.100 255.255.255.0

no ip route-cache

!

interface Vlan4

ip address 10.150.3.100 255.255.255.0

no ip route-cache

!

ip http server

!

control-plane

!

!

line con 0

line vty 0 4

login

line vty 5 15

login

!

end

 

Hat jemand eine Idee woran dies liegen könnte?

 

Hat jemand Erfahrung mit diesem Router Simulator? Ich schaffe es auch nicht die VLANs zu routen. Auch hier wäre ich über eurer Hilfe sehr dankbar.

 

Gruß

Share this post


Link to post
Share on other sites

Wie ist der Status der Ports, der VLANs, PCs am richtigen Port? MAC Adresse im ARP-Cache vorhanden? Normalerweise sollte das mit physialischer Hardware schon klappen

Share this post


Link to post
Share on other sites

Ports sind alle enabled

 

VLANs sind aktiv

 

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0/4, Fa0/5, Fa0/6, Fa0/7

Gi0/1

2 PC active Fa0/3

3 Drucker active Fa0/2

4 Server active Fa0/1

1002 fddi-default active

1003 token-ring-default active

1004 fddinet-default active

1005 trnet-default active

 

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1 enet 100001 1500 - - - - - 0 0

2 enet 100002 1500 - - - - - 0 0

3 enet 100003 1500 - - - - - 0 0

4 enet 100004 1500 - - - - - 0 0

1002 fddi 101002 1500 - - - - - 0 0

1003 tr 101003 1500 - - - - - 0 0

1004 fdnet 101004 1500 - - - ieee - 0 0

 

Die MAC Adressen wurden gelernt

show arp

 

core#show arp

Protocol Address Age (min) Hardware Addr Type Interface

Internet 10.150.3.1 56 00b0.9580.8d48 ARPA Vlan4

Internet 192.168.1.1 - 00b0.94e1.fa08 ARPA Vlan1

Internet 172.17.3.1 27 00b0.9580.8bd8 ARPA Vlan3

Share this post


Link to post
Share on other sites

Fals du zugang durch deine Firma/Fortbildungsabteilung zu CIsco IOS Images hast wurde ich dir GNS3 | Home sehr ans herz legen. Nur dort gibts auch "kleinere" Probleme mit den Vlans :/

 

edit:

 

von wo aus Pingst du Uberhaupt die Vlan Interfaces?

 

Setz noch einen Router hinzug

 

setz den "Uplinkport" zum Router auf switchport mode trunk

 

switchport trunk encapsulaiton dot1q

switchport mode trunk

 

und auf dem router dann einfach

 

enable

conf t

interface fastethernet 0/0 (das entsprechende interface) und ACHTUNG, hinter der letzten interface nummer komt ein Punkt ( . ) welche die concatinierung zu einem Subinterface erlaubt

 

interface fastethernet 0/0.2

(config-if)hier dann das vlan eintragen mit passender ip adresse jene ist dann der default gateway fur die clients.

Share this post


Link to post
Share on other sites

Die VLANs pinge ich von den virtuellen PCs. Ein ping vom Switch auf den PC ist auch nicht möglich.Den Befehl "show vlan database" gibt es in dieser Version von Network Visualizer leider nicht.

Share this post


Link to post
Share on other sites
Wahrscheinlich musst du die VLANs noch in der VLAN Data base anlgegen.

 

Gruß Dirk

 

Also wenn ich mir die COnfig nochmal angucke dann muss ich deine Aussage bestatigen

Share this post


Link to post
Share on other sites

Der Fehler hört sich genau danach an, als wenn die VLAN´s nicht in der Database wären. Daher war ja meine Idee "Show vlan database" - nur wie der befehl dann heisst, wenn es den in Network Visualizer nicht gibt - muss ich passen, da ich die Soft nicht kenne.

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...