Jump to content
Sign in to follow this  
MrC00l

Basisordner

Recommended Posts

Hallo zusammen,

 

hoffe mir kann jemand bei diesem Phänomen helfen:

 

Ich habe in auf meinem MS Server 2000 einem Benutzer einen Basisordner zugewiesen, also ich verbinde h: mit \\server\home$\%username% . Dies klappt in der Regel auch ganz gut, nur ab und zu kriegt der Benutzer als Laufwerk h: nur \\server\home$ verbunden.

 

Ich hoffe mir kann jemand den richitgen Gedankenanstoß geben wo ich dieses verkehrte mappen korrigieren kann.

 

Grüße

MrC00l

Share this post


Link to post
Share on other sites

Es kann beim Mappen von Laufwerken nur auf Freigaben verbunden werden.

 

Der Ordner %username% ist höchstwahrscheinlich selber nicht freigegeben und liegt unterhalb einer Freigabe.

 

Versuch mal, den Ordner "home" nicht freizugeben und anstelle dessen den Userordner.

Als Basisordner dann \\<servername>\%username% eingeben.

Dann sollte es klappen.

Share this post


Link to post
Share on other sites

Das leuchtet mir ein. Aber ist dann die Funktion des Basisordner nicht unsinnig? Dann müsste ich ja für jeden Benutzer eine eigene Freigabe erstellen! Kurioserweise funktioniert es ja auch fasst immer.

 

Ich frage mich ob das gleiche Problem dann auch unbewusst bei meinen Profilen und Ordnerumleitungen auftritt? Ab und zu habe ich in der Freigabe, wo ich die Benutzerprofile speichere, einen leeren Ordner "Dokumente und Einstellungen".

 

???

Share this post


Link to post
Share on other sites

Die Freigabe wird vom System automatisch eingerichtet.

 

Wenn aber der Ordner selber (und die vom System erstellte Freigabe) unterhalb einer schon existierenden Freigabe liegt, kann es zu dem von Dir geschilderten Phänomen kommen.

 

Teste es spaßeshalber mal mit einem Dummy-Useraccount...

Share this post


Link to post
Share on other sites

Aber was gebe ich dann Ziel für den Basisordner ein? Das Ziel kann doch nur eine Freigabe sein, oder ?

 

Quasi: \\server\basisordner\benutzer1

 

und die Freigabe ist in dem Fall "basisordner", der Ordner benutzer1 wird dann automatisch erstellt.

Share this post


Link to post
Share on other sites

Als Ziel: \\<servername>\%username%

 

Mit Klick auf [OK] oder [Übernehmen] wird die Variable in den Usernamen aufgelöst, automatisch der Ordner angelegt, die NTFS-Rechte gesetzt und der Ordner mit den entsprechenden Rechten freigegeben.

 

Wenn der übergeordnete Ordner für die Admins über NTFS-Rechte im Vollzugriff ist, werden die Rechte der Admins weitervererbt.

Share this post


Link to post
Share on other sites

Moment mal, ich glaube, ich habe da einen Denkfehler...

 

Eigentlich macht Ihr das schon richtig. Wir machen das nämlich genauso.

 

Da müssen wir mal anderweitig forschen...

 

Sorry für die Verwirrung, aber irgendwie war ich gerade im falschen Kino...

Share this post


Link to post
Share on other sites

Habe hier nur XP Clients. Der Fehler tritt sporadisch auf und lässt sich nicht reprodizieren. Habe zuerst gedacht es würde an zu langen Freigabenamen liegen. Also habe ich die Freigabe "Eigene_Dateien$" in "ED$" geändert. Ohne $ das gleiche Problem.

Mittlerweile behelfe ich mir über die NTFS Berechtigungen so das die Benutzer nicht die Verzeichnisstruktur von der Freigabe "ED$" zu gesicht bekommen. Aber keine wirklich tolle Lösung wenn die Leute auf H: klicken und den Hinweiss bekommen "Sie haben keine Berechtigung"

 

Bin weiter für jeden Gedankenanstoss sehr dankbar.

Share this post


Link to post
Share on other sites

Hallo MrC00l

 

Ich habe genau dasselbe Problem bei unserer Win2000 ADS! Auch bei uns tritt dieses Phänomen nur sporadisch auf, und zwar nur auf den XP-Clients, die Citrix-Farm (auf Win2k3 Servern) ist davon nicht betroffen! Nach einem aus- und wieder einloggen ist meisst alles paletti. (ausser, wenn man es dem Chef demonstrieren will - dann klappt's natürlich gerade nicht :eek: )

Hast du in der Zwischenzeit schon was raus gefunden? Wäre dir für einen Feedback sehr dankbar.

Share this post


Link to post
Share on other sites

Hi,

  • "MS Server 2000" - Stand-alone (Peer-To-Peer) oder Domäne?
  • Wenn Domäne: Liegen die Basisordner auf einem DC oder einem Memberserver?
  • Wenn mehrere DC: Tritt das Problem möglicherweise immer nur dann auf, wenn mein einen bestimmten Anmeldeserver (%LOGONSERVER%) erwischt?

 

Es ist dringend zu empfehlen auch dem SYSTEM mindestens Leseberechtigungen auf den Stammordner der Benutzer-Basisordner zu geben, wenn nicht erforderlich.

 

Theo

Share this post


Link to post
Share on other sites

Hallo Theo

 

Es sind zwei DC's in der Domäne und die Basisordner liegen auf dem SAN. Obs nur beim einen DC passiert, muss ich noch beobachten.

Aber mir ist noch was aufgefallen. Wenn man einen ShortCut anklickt, der auf eine Datei im UserHome verweisst, mapt das System kurzerhand ein neues Laufwerk Z:, welches den korrekten Pfad aufweist. Komisch ist nur, dass dieses Laufwerk Z:\ das Lable "HOME" erhält - das wird nämlich normalerweise durch das Loginscript so definiert. Aber zu diesem Zeitpunkt ist das Loginscript schon längst durch.

 

Besten Dank und schönen 1. August morgen...

 

Rony

Share this post


Link to post
Share on other sites
Wenn mehrere DC: Tritt das Problem möglicherweise immer nur dann auf, wenn mein einen bestimmten Anmeldeserver (%LOGONSERVER%) erwischt?

 

Den Vermutung mit mehreren DC kann ich ausschliessen, der Fehler verfolgt mich schon länger und damals hatten wir nur einen.

 

Weiter :confused:

Share this post


Link to post
Share on other sites

Zu der These mit den mehreren DC's kann ich sagen, dass ich das Phänomen bei zwei Usern geloggt habe. Dabei habe ich festestellt, dass es zwar nicht bei jedem Login auf einem (korrupten) DC passiert, jedoch handelt es sich im Fehlerfall immer um denselben DC.

Ich muss diesen Test aber noch auf weitere User ausweiten, um eine genauere Aussage machen zu können.

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...