Jump to content
Sign in to follow this  
autowolf

RPC Ping

Recommended Posts

Hi,

habe zum ersten mal einen Exchange 2003 SP2 mit Windows 2003 SP2 AD am laufen. Sonst ist es immer ein schöner SBS 2003 :)

 

Will jetzt RPCoverHTTPS, mit dem SBS war es nie ein Probelm.

Habe mich nach Anleitung und nach Anleitung 2 durch gekämpft.

SSL Zertifikat habe ich am Client auch schon installiert. Aber eine Anmeldung bekomme ich nicht "Es besteht keine Verbindung zum Exchanger Server bla bla.."

Wenn ich mit rpcping.exe -t ncacn_http -s testex -o RpcProxy=testex -p "Administrator,test,test" -H 1 -u 10 -a connect -F 3 -E -R none einen Test auf dem Server mache kommt Ping Faild

Es liegt wohl am RPC. In dem IIS habe ich den Ordner wie gewohnt, aber wo kann ich sehen ob der wirklich läuft.

Kann mir einer helfen, bin halt vom SBS 2003 sehr verwöhnt.

Share this post


Link to post

Hallo,

 

mit den Informationen die Du anbietest ist es unmöglich ein Troubleshooting zu machen,

da braucht es mehr als "geht nicht".

 

ASR

Share this post


Link to post

Ok,

 

ich habe eine Test Umgebung mit diesen Daten. Die Umgebung habe ich gebaut, da ich bei einem Kunden auch das Problem habe. Ich kenne mich halt nur beim SBS gut aus und da übernimmt ja ein Assistent die Konfiguration.

 

Den ping habe ich auf dem Exchange Server ausgeführt und es kam Ping Faild.

 

Habe in der Software den RPCoverHTTPs installiert

Dann den IIS konfiguriert.

In der Registry ist die Werte angeglichen:

 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\RpcProxy

testex:6001-6002;testex.test.local:6001-6002;testex.test.local:6001-6002;testex:6004;testex.test.local:6004;testex.test.local:6004

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Parameters

ncacn_http:6004

 

Ein SSL Zertifikat habe ich im IIS erstellt und über http://test/consrv die Lizenzdatei erzeugt. Diese dann wieder in den IIS eingespielt.

 

nun habe ich die Ports am Router freigegeben SSL 443

Jetzt über das Inet versucht ein Outlook 2003 dran zu hängen und ich bekomme die Meldung, das der Exchange Server nicht da ist.

Share this post


Link to post

Nur ein Schuss ins Blaue:

Ich habe in deinen Beschreibungen noch nicht gelesen, dass du unter den Eigenschaften des Exchange Servers "RPC-HTTP-Backend Server" aktiviert hast

 

kann mich noch dunkel erinnern, dass man die Berechtigungen für das virtuelle rpc Verzeichnis im IIS anpassen muss

Share this post


Link to post
testex:6001-6002;testex.test.local:6001-6002;testex.test.local:6001-6002;testex:6004;testex.test.local:6004;testex.test.local:6004

 

Hier steht der FQDN jeweils 2x drin für Ports 6001/2 bzw Port 6004.

 

Ist das ein Vertipper oder steht das so in der Registry?

 

Der Eintrag muss eigentlich lauten:

testex:6001-6002;testex.test.local:6001-6002;testex:6004;testex.test.local:6004

 

Christoph

Share this post


Link to post

@firefox80

Habe den Exchange auch schon umgestellt und den RPC konfiguriert. Trotzdem Danke

 

@Christop35

Hab es geändert, aber leider ohne Erfolg :-(

 

Noch am Rande: OWA geht 1a

 

und

 

Kann ich den RPC neu installieren ?

Wenn ich unter Software ihn wieder weg nehmen, ist er den noch im IIS Sichtbar

Share this post


Link to post

Funktioniert es im gleichen Netz mit dem internen Exchange Namen?

Welche Outlook Version?

Bekommst Du bei OWA eine Zertifikatswarnung?

Was sagt outlook.exe /rpcdiag?

Wie sind die Security Settings im RPC Dir?

 

ASR

Share this post


Link to post

@ASR

Ja wenn ich als Servername nur den Namen (testex) mache geh es.

Wenn ich aber mit Dom (testex.test.local) geht es nicht.

Beidemale habe ich keine Proxy-Einstellungen hinterlegt.

 

Outlook Version 2003 und 2007 beide kein Erfolg

 

Ja, weil das Zertifikat nicht öffentlich ist, da ich es ja selbst erstellt habe.

 

/rpcdiag sagt das die Verbindung getrennt ist. Wenn ich zu einem anderen Server (SBS 2003) dann geht es und die Verbindung wird aufgebaut.

 

Diese beiden Arten habe ich schon getestet:

 

demo1.JPG

demo2.JPG

demo3.JPG

Share this post


Link to post

Hi

 

Hatte glaub ich auch immer aehnliches problem.

 

du veruchst von extern ueber https://dynamischeip zuzugreifen

 

dynamischeip entspricht den namen des certs.

 

Ich musste beim client wo ich testete eine host eintrag machen

 

testex.test.local dyndnsname

 

dann gings

 

er baut ueber https://dynip einen tunnel auf dann sucht der client den server testex.test.local wenn dieser nicht aufgeloest wird findet er ihn nicht.

 

hiesse der server server.domaene.de

dieser haette einen mx eintrag mail.domaene.de

dann haettest du diese prob nicht

 

tschuesss

Share this post


Link to post

Hallo

 

Ne ich hatte in der host datei unter c:\windows\system32\drivers\etc diesen eintrag gemacht

 

testex.test.local name.no-ip.org

im client servername testex.test.local

 

nun weis er testex.test.local entspricht name.no-ip.org

 

Vieleicht hilfts :)

tschuess

Share this post


Link to post
@ASR

Ja wenn ich als Servername nur den Namen (testex) mache geh es.

Wenn ich aber mit Dom (testex.test.local) geht es nicht.

Beidemale habe ich keine Proxy-Einstellungen hinterlegt.

 

Outlook Version 2003 und 2007 beide kein Erfolg

 

Ja, weil das Zertifikat nicht öffentlich ist, da ich es ja selbst erstellt habe.

Es darf keine Zertifikatswarung kommen da Outlook die Meldung ja nicht wegklicken kann. Du muss also das Zertifikat importieren bzw. zu den Vertrauenswürdigen Stammzertifizierungstellen hinzufügen. Auch der Name des Zertifikats muss unbeding mit der in Outlook eingetragenen URL matchen, also z.b. mail.firma.de.

 

ASR

Share this post


Link to post

@Packesel

 

Die Einträgen haben nichts gebracht.

Sowohl im Lan als auch über WAN

 

@ ASR

Habe das Zertifikat schon installiert --> jetzt mal in die Vertauenswürdigen einsortiert.

und das Zertifikat läuft auch auf name.no-ip.org

Jetzt kommt keine Warnmeldung mehr im OWA

 

Aber leider keine Änderung des Problems

Share this post


Link to post

Outlook habe ich jetzt einmal verbunden innhalb des LANs

 

Wenn ich jetzt wieder über den RPC gehen will, dann verbindet sich Outlook 1 sec und dann kommt wieder getrennt.

 

Ich bin langsam echt ratlos.... :confused:

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...