Jump to content
Sign in to follow this  
Gadget

WSUS bringt auf Clients 100% Auslastung / svchost eventid 26

Recommended Posts

Nachdem bei uns an mehreren Clients im Lan nun dieser Fehler reproduzierbar aufgetreten ist u. auch hier an Board einige Fälle ohne konkrete Lösungsvorschläge gepostet wurden möchte ich dies ändern u. eine Lösung aufzeigen.

 

Fehler:

Ereignistyp:	Informationen
Ereignisquelle:	Application Popup
Ereigniskategorie:	Keine
Ereigniskennung:	26
Datum:		16.04.2007
Zeit:		08:39:37
Benutzer:		Nicht zutreffend
Computer:	PC29
Beschreibung:
Anwendungspopup: svchost.exe - Fehler in Anwendung: Die Anweisung in "0x745f2780" verweist auf Speicher in "0x00000000". Der Vorgang
"read" konnte nicht auf dem Speicher durchgeführt werden.

Klicken Sie auf "OK", um das Programm zu beenden.
Klicken Sie auf "Abbrechen", um das Programm zu debuggen.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.

 

Mein Lösungsweg:

1. Da ich zuerst nicht wusste welche Applikation diesen Fehler verursachte, hab ich mal den Windows Debugger angeschmissen. Hat zwar WSUS schon im verdacht war mir aber nicht 100% sicher. (Wer einen Blick in das Ergebnis vom Windows Debugger wagen will, hab´s als Txt angehängt.)

 

2. Nachdem ich in den Microsoft KB´s gesucht hab bin ich auf folgenden Hotfix gestossen:

You receive an access violation when you try to install an update from Windows Update after you apply hotfix package 916089

 

Mein erster Versuch der Hotfix Installation viel gleich mal schief... deswegen hab ich zuerst

 

3. Den Dienst "wuauserv" (automatische updates) beendet dann lies sich der Patch problemlos installieren.

 

Reboot u. tada...der Fehler war leider immer noch da...

 

4. Also nächster schritt..."wuauserv" wieder beenden, "%windir%\softwaredistribution" in "%windir%\softwaredistribution_old" umbennen u. folgendes Skript durchlaufen lassen:

 

(Das Skript hab ich von PatchAholic...The WSUS Blog!

 

@echo off
Echo Save the batch file "AU_Clean_SID.cmd". This batch file will do the following:
Echo 1.    Stops the wuauserv service
Echo 2.    Deletes the AccountDomainSid registry key (if it exists)
Echo 3.    Deletes the PingID registry key (if it exists)
Echo 4.    Deletes the SusClientId registry key (if it exists)
Echo 5.    Restarts the wuauserv service
Echo 6.    Resets the Authorization Cookie
Echo 7.    More information on http://msmvps.com/Athif
Pause
@echo on
net stop wuauserv
REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v AccountDomainSid /f
REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v PingID /f
REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v SusClientId /f
net start wuauserv
wuauclt /resetauthorization /detectnow
Pause

 

Nach ausführen dieses Skriptes lief die Sache endlich wieder u. ein kontrollierender Reboot brachte zu Tage, das auch keine Access Violation mehr produziert wurde....:rolleyes:

 

LG Gadget

crashdump_pc29_16-04-07.txt

Share this post


Link to post

@Kohn

 

Danke schön für die Beschreibung.............

 

Ich hatte bist jetzt in noch keine Installation dieses Problem und das

war bist jetzt schon sehr sehr viele.

Ich versuche ein mal am Abend dein Log vom Windows Debugger anzusehen

und zu schauen ob ich "was" finden kann ?

Share this post


Link to post

Hi Kohn,

 

ich suche schon seit Tagen nach einer Lösung dieses Problems.

 

Habe alles ausprobiert, ohne Erfolg.

 

Werde jetzt mal dein Script laufen lassen, mal sehen obs auf dauer hilft.

 

Hast du vielleicht ne Ahnung was die Ursache des Fehlers ist?

 

Würde mich sehr stark interessieren. Da in meiner Fa. einige Leute der Meinung sind ich würde den mit meiner WSUS konfig. produzieren.

 

Ich konfiguriere den Wsus über lokale GPedit. da keine Domäne in unserer Fa.

 

also vielen dank.

 

mfg

 

Michael

Share this post


Link to post
Hast du vielleicht ne Ahnung was die Ursache des Fehlers ist?

 

Welcher Fehler genau, der "Application Hang" EventID 26 o. die generelle Systemauslastung durch die wuauclt.exe (svchost)?

 

LG Gadget

Share this post


Link to post

Ist ein unerfreulicher Bug in der msi.dll.

 

Welche MSI.dll-Versionen davon genau betroffen sind, kann ich dir nicht sagen hatte da auch noch keine Zeit dazu nachzuforschen...

 

Ich kann nur hoffen, dass sowas in Wsus v3 nicht mehr vorkommt.

 

LG Gadget

Share this post


Link to post

Hi,

 

ich hatte genau mit dem gleichen Problem zu kämpfen. Meine Lösung war ähnlich, hat aber auch funktioniert:

 

net stop wuauserv

net stop bits

del /q /s %windir%\SoftwareDistribution

 

Ich habe echt schon überlegt, den Wsus 3 Beta produktiv loszulassen....

Share this post


Link to post

@Trommeltier

 

 

Inzwischen gibt es statt der Beta ein RC. Produktiv würde ich

ihn trotzdem noch nicht einsetzen.

 

@Kohn

 

Tritt das Problem bei dir bei jeder Installation auf ?

Share this post


Link to post

Nein nicht an allen Maschinen aber bisher an ca. 10 Clients in der Domäne, ich rede jetzt einfach mal von beiden Problemen gemeinsam also

 

(CPU Belastung u. Eventid 26, da die gleiche Dll betroffen ist u. es sich für mich dahher als ein Problem darstellt.)

 

Ich stehe aber nicht alleine mit meinem Problem dar ...gibts viele Diskussionen in den Newsgroups dazu u. Blog-Beiträge...

 

Wenn man sich nur die Anzahl der Comments dazu anschaut weis man wieviele diese Probleme haben:

Tech Blender: Windows Update Broke My Machine (svchost.exe -- application error), and How to Fix It

 

Große Resonanz u. eine gute Beschreibung dazu auf dem Wsus Team Blog gabs leider nicht.

WSUS Product Team Blog

 

Es gab zwar einen Beitrag vom Team im Januar:

WSUS Product Team Blog : Update on WUA Srvhost.exe, high CPU consumption and memory consumption issue

 

Wo sie versprochen hatten den Patch über WU/AU anzubieten, aber mir ist nichts bekannt, dass in dieser Richtung irgendwas passiert wäre. Wo bleibt das Statement dazu?

 

These updates will be available via MU/WU after a complete general-distribution-update package test cycle is completed. More information on the future availability of these critical updates on the WU/MU sites will posted next week.

 

Auf die neuen Informationen warten wir immer noch...

 

LG Gadget

Share this post


Link to post
Hi,

 

ich hatte genau mit dem gleichen Problem zu kämpfen. Meine Lösung war ähnlich, hat aber auch funktioniert:

 

net stop wuauserv

net stop bits

del /q /s %windir%\SoftwareDistribution

 

Ich habe echt schon überlegt, den Wsus 3 Beta produktiv loszulassen....

 

 

Hi,

 

das hab ich auch gemacht. Hat aber nur geholfen bis zum nächsten Update. Als ich die nächsten Updates über WSUS freigegeben hatte war das Problem wieder da.

 

mfg

 

michael

Share this post


Link to post

@Kohn

 

 

Das Problem aus Blog kannte ich auch und habe die Beiträge und

die Antworten auch gelesen.Und war erschrocken wie oft das dann doch auftritt.

Nur hatte ich bis jetzt kein Fall wo das Problem auftrat.

Auch würde ich es gerne nachstellen ?

Nur wie das Problem produzieren ?

Kann man "genau das und das machen" und dann tritt das Problem auf ?

Share this post


Link to post

Nur wie das Problem produzieren ?

 

das weiß ich auch nicht aber ich weiß, wir haben genau das selbe Problem und es nervt sehr, da wir viele PowerUser haben, die sehr viel Rechenkapazität benötigen. U Ich vermute mal, es tritt auch in anderen Firmen (bei Dir?) auch oft auf, nur fällt es dem Admin nicht auf, da:

 

- die 100%Auslastung nicht permanent ist

- die 100% Auslastung sicher auch dann auftritt, wenn der User mal grade nichts macht

- viele User eine hohe Leidenstoleranz haben, bis sie das Problem dem Admin melden

 

Das Problem konnte ich verstärkt bisher nur bei XP Masschinen beobachten, bei 2K Clients hatte ich das Problem so weit ich gesehen habe bisher nicht. Kann das jemand bestätigen?

 

Du könntest mal die Auslastung Deiner Clients überwachen und Dir jede 100% Ausslastung mailen lassen oder ins Protokoll schreiben. Das möchte ich auch machen, sobald ich etwas Zeit finde, evtl. kriege ich dann abeer den riesen Schreck, wenn ich so feststelle, wie viele Clients tatsächlich davon "infiziert" sind.

 

Hat mal jemand beobachtet, daß das Problem mit dem neuen WSUS weg geht?

 

Viele Grüße

Thomas

Share this post


Link to post

@smartino

 

Danke für dein Beitrag............

 

Ich habe mir hier ein richtiges Wsus Testlab aufgebaut und kann sehr viel nachstellen.

 

Wie gesagt kann ich es bei mir nicht bestätigen. Das es passiert ist klar und was passiert ist auch klar. Nur das warum und warum es mal passiert mal nicht ?

Das ist noch nicht so klar.

Ich versuche grade zu testen ob es mit der Anzahl der Clients zu tun hat ?

 

Wieviele Clients hängen an deinem Wsus ?

 

 

@kohn

 

Wieviele Clients hängen bei dir am Wsus ? Oder hast du

eine Master - Slave Wsus Struktur ?

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...