Jump to content

Default Gateway klappt nicht


Guest marco-bormann
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Guest marco-bormann

HAllo habe ein Netz mit 4 Subinterfacen von 192.168.0.0 bis 4.0 so und habe einen Cisco Router 2620 der das Verwaltet. So der router hängt am Switch und an diesem Switch alle PCs und ein Router und ein Server. Die Switche haben die Ip 192.168.0.2 und 0.3 der cisco Router die 0.4 und der Telekom Router die 0.5 und der server die 0.6! So vom Cisco aus und von den Switchen aus kann ich die 0.5 und 0.6 erreichen aber von keinem Subinterface außer dem 192.168.0.0er Netz! Also nur das 0.0er Netz kann ins inet die anderen nicht weil sie keine Vebrindung zu 0.5 und 0.6 haben!

 

Wisst ihr weiteR?

 

Muss ich das irgendwie routern? Habe bei den Subinterfacen 0.6 als Gateway!

 

Please help

Link to comment

Ähm, irgendwie steige ich durch deine "Problem-Stellung" nicht durch. Du hast einen Cisco2620 - OK, du hast 4 Subinterfaces angelegt, auch ok. Wie hast du den deine SubInterf. konfiguriert??

Wie ist dein Switch konfiguriert und was für ein Switch ist es überhaupt?? Spricht der .1q oder irgendein anderes Trunking Protokoll (.1q oder ISL)??

 

Am besten du postest mal die Konfig des Routers.

 

Viele Grüße

Carsten

Link to comment
Guest marco-bormann

Hi ja .1q habe ich und dann Trunk zwischen Switch und Router aufgebaut! Also das sind 3 Com switche da heißt das Port Tagging! So die Verbindung steht ja auch nur dass die Netzt 1.0 2.0 3.0 und 4.0 nicht auf die 0.5 und 0.6 zugreifen können. Auf 0.1-0.4 geht aber! Das ist der Router und die Switche und 0.5 ist der Telekom Router und 0.6 der Server

 

 

Warum geht das nicht?

 

Habe die Subinterfaces einfach eingerichtet und encap.......ipadresse vergeben maske und so!

 

Woran liegts?

Link to comment

Jedes SubInterface muss eine eigene IP-Adresse haben!! Und diese IP-Adresse des Subif muss das StandardGateway des Rechners sein!!! Jetzt kommt es noch drauf an, was willst du aus dem x.x.1.0 Netz erreichen - willst du ins Internet über den Cisco und dem Telekom-Router?? Dann musst du noch eine Standard Route auf dem Cisco anlegen:

ip route 0.0.0.0 0.0.0.0 192.168.0.6

 

Dann sollte es auch mit dem Nachbarn klappen!!

Link to comment
Guest marco-bormann

also dann für jedes Netz? S

 

So in meinem Falle?

 

192.168.1.0 255.255.255.0 192.168.0.6

192.168.2.0 255.255.255.240 192.168.0.6

192.168.3.0 255.255.255.192 192.168.0.6

192.168.4.0 255.255.255.240 192.168.0.6

 

? Dann müsste der Router überall erreichbar sein?

Link to comment

Hallo,

du bruachst für direkt angeschlossene Geräte keine Standard Routen konfigurieren, denn dein Router kennt doch die direkt angeschlossenen Netze (guckst du in die Routing Tabelle --> sh ip route)

 

Ich hab das auch nochmal ausprobiert. Ich hab die Subif angelegt und schon konnte ich von Netz a in Netz b pingen und von b nach c und von c nach a - also kurz das Routing funktioniert in alle Richtungen...

 

Die Beispiel-Konfig ist allerdings auf einem Cisco1721 mit ner 12.4-7er IP-Plus erstellt. Ich kenne deinen 2620 nicht - sprich ich weiß nicht, welche IOS du drauf hast. Vielleicht nochmal

Router(config)#ip routing

probieren!!

 

Wenn es dann immernoch nicht klappt, poste bitte mal deine Konfig und deine IOS Version!

 

Hier meine Bsp-Konfig:

!
interface FastEthernet0
no ip address
speed auto
!
interface FastEthernet0.1
encapsulation dot1Q 1 native
ip address 192.168.6.250 255.255.255.0
no snmp trap link-status
!
interface FastEthernet0.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
no snmp trap link-status
!
interface FastEthernet0.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
no snmp trap link-status
!
interface FastEthernet0.30
encapsulation dot1Q 30
ip address 192.168.30.1 255.255.255.0
no snmp trap link-status
!
interface Serial0
no ip address
shutdown
no fair-queue
!
interface Serial1
no ip address
shutdown
!

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...