Jump to content

Browsen Explorer Netzwerkumgebung Domain


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo zusammen;

 

Ich habe nach meinem "Servercrash"

(zur Info: http://www.mcseboard.de/showthread.php?s=&threadid=9970 )

 

nun SP4 drauf und die Server laufen wieder vernünftig *megahappy* und sprechen wieder miteinander ;-))

 

Ich hab jetzt nur noch das Problemchen, dass ich im "Explorer - Netzwerkumgebung - ges.Netzwerk - Domain" nur die Rechner aus dem lokalen Segment sehe.

Vor meinem "Servercrash" hat man alle Rechnern aus allen Segmenten gesehen.

 

Weiss jemand, wie ich ohne Wins wieder alle Rechner sichtbar mache?

 

Ach ja, pingen kann ich mit dem NetBiosNamen und den FQDNs in alle subnetze.

 

Vielen Dank!

 

Gruss

 

aChim-Z

Link to comment

Ohne WINS würde mir als erstes einfallen, den/die Router für Broadcasts aufmachen, was ich aber nicht empfehle.

Der zweite Weg, aber auch den empfehle ich nicht, einen Eintrag auf den Masterbroswern in den Subnetzen, in denen der PDC NICHT steht, in der LMHOSTS vornehmen:

 

199.199.199.1 "pdcname \0x1b" #PRE

Wichtig: Die Anzahl der Zeichen vor dem BackSlash muss 15 betragen. Ist der PDC-Name kürzer als 15 Zeichen, muss der Rest mit Leerzeichen aufgefüllt werden.

 

Mehr dazu hier: 199.199.199.1 http://support.microsoft.com/default.aspx?scid=kb;EN-US;150800

 

Da man i.d.R. njicht weiss, wer nachher Masterbrowser ist, sollte man diesen Eintrag entweder auf allen Servern, oder besser noch auf allen Rechnern eintragen.

 

Ich empfehle aber eher den Einsatz von WINS.

 

grizzly999

Link to comment

Hallo,

 

mal eine "dumme" Frage am Rand: warum fahrt ihr alle so auf WINS ab? Täusche ich mich oder ist es nicht deutlich effektiver, einen DNS-Server aufzusetzen?!?

 

Selbst MS hatte ja spätestens ab W2K Server die Zeichen der Zeit erkannt und bietet WINS nur noch an, wenn jemand aus irgendwelchen (mir unerfindlichen) Gründen das benötigt.

 

Grüße

Olaf

Link to comment

Hallo Olaf !

 

Wir fahren immer noch einen "Gemischtwarenladen mit Netbios" und brauchen deshalb Wins-Server.

Deshalb mal meine Frage an Dich, rein interessenhalber:

Der Masterbrowser (wenn ein MS-Betriebssystem drauf läuft ) fragt definitiv immer den Wins-Server, wen der alles kennt, wenn ein Wins-Server angegeben wird.

Fährt man einen Gemischtwarenladen mit Netbios ohne einen Wins-Server, ermittelt der Masterbowser über Broadcast, wer da ist - geroutete Segmente sind ihm dann unbekannt, da Broadcast normalerweise nicht geroutet werden.

 

Jetzt meine Frage: Fragt der Masterbrowser, wenn kein Netbios installiert ist, einen der DNS-Server, wen es alles gibt - oder nicht ?

Wär echt super, wenn Du da eine definitive Antwort hättest.

Diese Masterbrowser-Funktion von MS hat mich schon etliche Nerven gekostet - zu viele LAN über miese WAN-Leitungen, ein LAN fehlt da meistens. :rolleyes:

Link to comment
Selbst MS hatte ja spätestens ab W2K Server die Zeichen der Zeit erkannt und bietet WINS nur noch an, wenn jemand aus irgendwelchen (mir unerfindlichen) Gründen das benötigt

 

Hi Olaf, ich "erfinde" dir einen Grund: Schon mal versucht, mit einem NT4.0 (W9x/Me)-Client in einem gerouteten Netz, ohne DC im Subnetz, dich anzumelden. Oder selbst wenn ein BDC in einer NT 4.0 Domäne im Subnetz ist, das Kennwort zu ändern (geht nur auf dem PDC wie du weisst). Wie findet einer der o.g. Clients den PDC?

 

Den anderen Grund hat zuschauer schon geschrieben. Es nun mal so, dass viele noch mit der Netzwerkumgebung arbeiten. Und das ist nunmal NetBIOS-Geschichte.

 

Du hast in soweit Recht mit der quasi Abschaffung des WINS bei Windows 2000, solange man in gerouteten Netze keine Legacy-Clients einsetzt, und/oder die Netzwerkumgebung nicht benötigt. Für Legacy-Clients in W2k-Netzen empfiehlt MS ausdrücklich den Einsatz von WINS.

 

Gruß

 

grizzly999

Link to comment

OK grizzly und zuschauer, ihr habt mich überzeugt dass meine Frage (deshalb war sie auch als "b***d" gekennzeichnet :p ) ein Schnellschuss war.

 

Drei Sachen vorweg (zu meiner Verteidigung ;) ):

1.) Die Frage wurde als W2K gekennzeichnet (läßt nicht auf W9x/NT-Clients schließen),

2.) ich habe das Routing zwischen den Segmenten übersehen :cry:,

3.) WINS habe ich bisher versucht zu umgehen, da ich nie mit solchen Problemen konfrontiert wurde (dürfte eine echte Wissenslücke sein :( ),

 

Nun gut, dumm gelaufen, wer lesen kann ist klar im Vorteil.

Ich habe mich nun, ohne genauer auf die ursprüngliche Frage einzugehen kurz gegoogelt und kann ein paar Hinweise anbieten. Die sind euch wahrscheinlich schon lange bekannt, könnten aber zu neuen Denkansätzen verhelfen. Bitte nicht hauen, wenn das für euch schon alles kalter Kaffee ist :rolleyes: .

 

Grundlagen zu NetBIOS-Namensauflösung und allem, was dazu gehört

http://www.digital-labs.de/kb/faq/faq-nt4/networking/wins/WINS.htm

 

Ablaufdiagramm der NetBIOS-Namensauflösung (dürfte zuschauers Frage beantworten)

http://www.digital-labs.de/kb/faq/faq-nt4/networking/wins/nbt-alg.gif

 

(Dies könnte vielleicht sogar die Ursprungsfrage beantworten!!)

WINS-Proxy-Agent konfigurieren (unterer Abschnitt)

http://www.ghostadmin.org/tcpip/wins.htm

 

Auch wenn ich mich wohl ein bisschen wie ein Elefant im Porzellanladen verhalten habe *schäm*, hoffe ich, ich konnte euch ein klein wenig weiter helfen. :D

 

Grüße

Olaf

Link to comment

Hallo Leute;

 

danke für eure Ideen!

 

Also nochmal mein Problem:

 

1.) das ursprungssystem:

- 4 Niederlassungen mit eigenem IPRange mit IPSec verbunden

- 4 Subnetzte 192.168.155.x, 192.168.157.x, 192.168.158.x, 192.168.159.x

- W2K sp2 mit AD, je ein GC pro Niederlassung, nur DNS, kein Wins!

- eine NetBios / DNS Domain: Kunde / Kunde.intra

 

Explorer - Netzwerkumgebung - Domain(Kunde):

- Alle Server sichtbar mit zugriff!!

- alle Wks sichtbar

 

:p :) :D Hurra, es funtzt! !

---------------------------------------------------------------------------------

 

2.) was passierte:

- kontinuierliches Updaten auf W2K.SP3

- zuletzt im "Ursprungsnetz" 192.168.155.x

 

3.) nach einiger Zeit:

Explorer - Netzwerkumgebung - Domain(Kunde):

- Alle Server sichtbar OHNE zugriff!!

- alle Wks sichtbar OHNE zugriff!!

 

 

:( :confused: :eek: Was ist denn jetzt los ???

 

-----------------------------------------------------------------------------------

 

4.) nach und nach "verschwinden" die Rechner aus der Domain

 

5.) jetzt hab ich 4 Netze, nichts wird mehr repliziert !!

 

:cry::cry:

 

Wiederzusammenbau nach dem Update auf SP4 gelungen. Die Server "sprechen" wieder miteinander :)

 

------------------------------------------------------------------------------------

 

Jetzt fehlt mir nur noch, dass die Rechner auch wieder alle in der Domain sichtbar sind.

 

Muss ich da was replizieren, oder in e inem Teilnetz was löschen??

 

grus

 

achim

Link to comment
Original geschrieben von edv-olaf

Ablaufdiagramm der NetBIOS-Namensauflösung (dürfte zuschauers Frage beantworten)

http://www.digital-labs.de/kb/faq/faq-nt4/networking/wins/nbt-alg.gif

Nein leider nicht. :(

Das ist das Schema, wie ein w2k/xp einen bestimmten Host sucht und funktioniert so auch. Bei Win9x/ME/NT4 - Clients muß dann nur der DNS-Query-Abschnitt weg. Dann stimmt es auch für die.

 

Netzwerkbrowsing funktioniert bei MS eben nicht so, daß jeder jeden sucht, sondern alle melden sich beim Masterbrowser (in achim´s Fall dem MB des Segmentes) und fragen den Masterbrowser auch bei "net view" bzw. "Netzwerkumgebung".

 

Da achim auch immer nur das eigene Segment sieht, scheint der MB bei fehlendem Wins-Server nicht die DNS-Server abzufragen, sondern gibt nur das weiter, was er selber kennt.

 

@achim: Wie grizzly schon sagte, setz in jedem Segment einen Wins-Server auf, mach den bei den Clients bekannt, damit die sich bei ihm melden und lass die 4 Wins-Server sich replizieren.

 

Wieso das bei Dir schon mal ohne Wins funktioniert hat, kann ich auch nicht sagen - siehe meine Frage zum MasterBrowser + DNS-Server weiter oben.

Link to comment

warum das schonmal funzte kann ich mir so vorstellen das du auf deinem dns servern oder server die ip´s angegeben hatt wo der server fragen soll falls er etwas selber nicht auflösen kann was man unter dns/server/eigenschaften/schnittstellen oder über den stammverzeichnis datensatz. was ich auch wieder probieren würde.

bin selber kein freund von wins aber wenn das nicht funzt wins installieren ist doch eh nur ne sache von ein paar minuten.

 

greetz

bombjack

Link to comment

Hallo Zusammen;

 

Eure Antworten haben meine Gedanken etwas "schweifen lassen"!

 

Ich bin dadurch ein riesen Stück weiter gekommen.

------------------------------------------------------------------

Ich habe also wieder einen Server im "alten" Netz zum PDCEmulator gemacht, und siehe da, die Browslist war wieder da.

 

das ADSIEdit-Tool ist da sehr hilfreich.

(Ich konnte damit auch die nicht-mehr-vorhandenen Rechner sauber entfernen, was mit ntdsutil nicht geklappt habt)

 

Ich denke, ich hab noch ein kleines Berechtigungsproblem. Ich sehe zwar die Rechernwieder, aber kann noch nicht drauf zugreifen.

 

GRuss & Dank!

 

achim

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...