Zum Inhalt wechseln


Foto

SUS Client zieht Updates nicht


  • Bitte melde dich an um zu Antworten
68 Antworten in diesem Thema

#1 Sunnyboy89

Sunnyboy89

    Member

  • 190 Beiträge

 

Geschrieben 16. März 2005 - 15:10

Hallo liebe Community,

habe folgendes Problem, dass sich die Clients nicht die Updates ziehen. Ich weiß nicht weiter..

1. Ich hab die GPO überprüft, dort ist alles korrekt konfiguriert.
2. Habe extra auch noch einmal in der registry nachgeschaut, ob die Einstellungen in Ordnung sind und sie sind so wie gewünscht... Updates automatisch runterladen und installieren (4)
3. Hab auch die Anmeldeprozedur geändert, weil ich gelesen habe, dass Windows XP zu schnell für die GPO ist, also das erst das Netzwerk geladen wird und dann das Anmeldefenster
4. Hab im Logfile nachgeschaut, dort bringt er folgende Fehlermeldung: WUCheckForUpdatesAtShutdown failed, hr=8024002B
Kann jemand etwas damit anfangen?

SUS läuft auf einem Windows 2000 System, alles funktioniert außer das..

Vielen Dank schon mal!

#2 JustinXiang

JustinXiang

    Member

  • 239 Beiträge

 

Geschrieben 16. März 2005 - 23:08

Hast du eine Firewall auf den Clients installiert! Möglicher weiße liegt es daran! Schau dir die einstellungen an welche ports freigeschalten werden müssen! Möglicher weiße liegt es auch einem Service Pack für den Win2000 Server
Wer anderen eine Bratwurst brät, hat ein Bratwurstbratgerät!:)

#3 Sunnyboy89

Sunnyboy89

    Member

  • 190 Beiträge

 

Geschrieben 17. März 2005 - 07:28

Nein, daran liegt es nicht.
Kann mir keiner weiter helfen?

#4 overlord

overlord

    Board Veteran

  • 2.125 Beiträge

 

Geschrieben 17. März 2005 - 07:51

hi,
steht was auffälliges im eventlog (client/server) oder im IIS-log?
versuch doch mal:

REGSVR32 C:\WINDOWS\system32\wuapi.dll
REGSVR32 C:\WINDOWS\system32\wuauclt.dll
REGSVR32 C:\WINDOWS\system32\wuaueng.dll
REGSVR32 C:\WINDOWS\system32\wucltui.dll
REGSVR32 C:\WINDOWS\system32\wups.dll


(xp brauch sp2 und win2000 brauch sp4)

#5 Sunnyboy89

Sunnyboy89

    Member

  • 190 Beiträge

 

Geschrieben 17. März 2005 - 08:04

Hallo!

Von den .dlls die du aufgeführt hast, ist diese:
REGSVR32 C:\WINDOWS\system32\wuauclt.dll
nicht auf dem client aufzufinden, hat das ne bedeutung?

#6 Sunnyboy89

Sunnyboy89

    Member

  • 190 Beiträge

 

Geschrieben 17. März 2005 - 08:47

Hab noch was anderes heraus gefunden.
Jetzt zieht er die updates und und installiert sie auch. aber im log file steht das:
Successfully downloaded file from http://au.download.w...64f3d0cb8e3.exe to C:\WINDOWS\SoftwareDistribution\Download\S-1-5-18\06f0efea0a0240a4f6ae48a5041ea77a\d7287c830c79239dd65ad73ba301264f3d0cb8e3.

Das heißt, er zieht nicht von meinen SUS oder?
muss ich dann bei UseWUSServer die 0 oder die 1 setzen damit er von meinem SUS zieht?
Hab jetzt die 0 und da hat er von dieser seite oben gezogen.
wenn ich ne 1 setze dann zieht er irgentwie keine updates...

#7 overlord

overlord

    Board Veteran

  • 2.125 Beiträge

 

Geschrieben 17. März 2005 - 08:58

Hallo!

Von den .dlls die du aufgeführt hast, ist diese:
REGSVR32 C:\WINDOWS\system32\wuauclt.dll
nicht auf dem client aufzufinden, hat das ne bedeutung?

weiß net, aber hab grad gesehen, dass die auf meinem xp-client auch net da ist.
machen eigentlich nur xp´s probleme oder auch w2k´s?

#8 danryker

danryker

    Senior Member

  • 392 Beiträge

 

Geschrieben 17. März 2005 - 09:00

Hai,

auf jeden Fall sollte bei UseWUSServer eine 1 stehen....
Gruß
danryker
_______________________________________________

#9 Sunnyboy89

Sunnyboy89

    Member

  • 190 Beiträge

 

Geschrieben 17. März 2005 - 09:01

kannst du vielleicht auch bezug auf meine zweite frage nehmen, ob der usewusserver auf 1 oder auf null stehen muss.

oder weißt du warum er die updates von ner internetseite installiert?
aber es ist die ip adresse des sus angeben!

#10 Sunnyboy89

Sunnyboy89

    Member

  • 190 Beiträge

 

Geschrieben 17. März 2005 - 09:03

Ich seh gerade der befehl : USEWUSSERVER steht auf 1 wieso hat er trotzdem die updates aus dem netz gezogen?

#11 Sunnyboy89

Sunnyboy89

    Member

  • 190 Beiträge

 

Geschrieben 17. März 2005 - 10:20

ich werd noch verrückt....

ma zieht er die updates ma net...
jetzt macht er es wieder net unter windows 2000. liegts vielleicht daran, dass ich es nun per registy eintrag versucht habe und dieser reg.key von xp stammte und ich es auf win2k system importieren wollte?

#12 overlord

overlord

    Board Veteran

  • 2.125 Beiträge

 

Geschrieben 17. März 2005 - 10:50

also nochmal langsam für mich ;-),
1) du weist die clients per grouppolicy an, sich mit deinem lokalen SUS zu verbinden (ADS umgebung)
oder 2) du änderst dir REG der clients per hand (workgroup umgebung) ???

im esten fall muss an den clients eigentlich gar nix gemacht werden (dienst muss halt laufen usw.).
wenn du WINDOWS UPDATE übers startmenü aufrufst, verbindet sich deine kiste soweit ich weiß immer mit MS.

#13 danryker

danryker

    Senior Member

  • 392 Beiträge

 

Geschrieben 17. März 2005 - 10:58

Schau mal in die Registry, steht dort unter

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate

Dein Server drin ( WUServer und WUStatusserver) = http:// DeinServer (IP)
Gruß
danryker
_______________________________________________

#14 Sunnyboy89

Sunnyboy89

    Member

  • 190 Beiträge

 

Geschrieben 17. März 2005 - 11:02

ja der WUS is drin..

über gpo scheints ja zu funktionieren, außer dass es mich verwundert hat, dass er ne http://adresse von microsoft.com angegeben hatte.

habs dann über die regeintrag versucht, aber da zieht er keine update obwohl 22 verfügbar sin und da würd mich auch interessieren wenn ich es über reg eintrag mach, ob ich da auch die wuau einfügen muss?

#15 danryker

danryker

    Senior Member

  • 392 Beiträge

 

Geschrieben 17. März 2005 - 11:58

Also, irgendwie bin ich jetzt nach dem lesen ganz durcheinander...

Du hast einen W2K-Server mit SUS
Du hast W2K- und XP-Clients
über GPO macht er die Update über einen Reg-eintrag nicht...

versuchen wir mal folgendes. Mach mal eine Textdatei mit Suffix *.reg mit diesem Inhalt. Deinen Server mußt Du natürlich noch eintragen.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate]
"WUServer"="http://Dein Server"
"WUStatusServer"="http://Dein Server"

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]
"NoAutoUpdate"=dword:00000000
"AUOptions"=dword:00000004
"ScheduledInstallDay"=dword:00000000
"ScheduledInstallTime"=dword:0000000b
"UseWUServer"=dword:00000001
"RescheduleWaitTime"=dword:0000000a
"NoAutoRebootWithLoggedOnUsers"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update]
"AUOptions"=dword:00000004

Das ganze dann als administrator starten...

So, dann gibts noch von heise ein Tool, das setze bitte danach ein...diese bringt das Update innerhalb von 10 min zum laufen...(Du brauchst noch die reg.exe von der W2K-CD)

http://www.heise.de/...shtml&words=SUS

danach sprechen wir uns wieder....
Gruß
danryker
_______________________________________________