Zum Inhalt wechseln


Foto

Langsame Internetverbindung bei einem Dienst - Troubleshooting?


  • Bitte melde dich an um zu Antworten
3 Antworten in diesem Thema

#1 jostrn

jostrn

    Member

  • 232 Beiträge

 

Geschrieben 06. Juni 2016 - 16:16

Grüß' euch!

 

Seit einiger Zeit klagen die Benutzer an einem Standort über eine lange Wartezeiten in einer Fachanwendung. Diese Anwendung ist eine JNLP-Java-Anwendung, die (über HTTPS?) Daten von einem Server des Softwareanbieters lädt, darstellt und vom Anwender bearbeiten lässt.

 

Wir haben turnusmäßig die PCs gewechselt (Core i7, 8 GB RAM, SSD) und auf Windows 10 migriert. Der Firewall-Admin sagt, dass die Firewall (Palo Alto PA-200) die meiste Zeit Däumchen dreht, in der Spitze habe sie 30% Last. Er sagt auch, dass die primäre Internetleitung (MNet LWL 300/60) genug freie Bandbreite habe. Ich habe zwar einen Admin-Zugang auf der Firewall, kenne mich mit Palo Altos aber nicht aus und verlasse mich auf die Infos des Experten.

 

Während die Fachanwendung Daten lädt kann ich von dem betroffenen PC aus den Server des Anbieters mit 10-13ms pingen, zu Googles DNS-Servern sind es konstante 8-9ms.

 

Die Anwender berichten, dass sie von anderen Standorten aus drastisch kürzere Ladezeiten haben, heute bspw aus einem grindigen Hotel-WLAN!

 

In meiner Verzweiflung habe ich einzelne Anwender statt über die PA-200 über eine FritzBox auf die 300/60er Leitung geschickt - die Ladezeiten waren unverändert. Um die Leitung auszuschließen habe ich dieselben Anwender dann über eine Fallback VDSL-Leitung (25/5) der DTAG geschickt - die Ladezeiten waren ganz minimal schlechter, mit Meßtoleranz unverändert. Die Switche, über die die Anwender zum Router kommen habe ich ebenfalls überpatcht.

 

Unterm Strich habe ich meines Erachtens alles verändert: Clients, Switche, Router und Leitung zum ISP - trotzdem stimmt die Geschwindigkeit nicht.

 

Der Software-Anbieter hat intern die Last gemessen und kann bei sich auch nichts erkennen.

 

Habt ihr zielführende Ideen, wie ich meine Anwender glücklich machen kann? Budget zum Tauschen von Equipment ist da, nur weiß ich nicht, was ich tauschen sollte.

 

Vielen Dank und viele Grüße

Josef



#2 Nobbyaushb

Nobbyaushb

    Board Veteran

  • 2.637 Beiträge

 

Geschrieben 06. Juni 2016 - 20:08

-Ironic on - den Softwareanbieter - Ironic off

 

Ich hatte hier ein ähnliches Spiel, allerdings mit lokalen DB´s auf eigenen SQL-Servern

 

Es hieß immer, unsere Umgebung sei zu langsam (das Storage (Datacore-SAN mit SSD für Auto-Tiering drunter) kann locker 400.000 IOP´s) und kam bei Messungen nicht über eine Last von 4.000 (!) IOP

Ich habe dann einen Gutachter kommen lassen, der hat die SW komplett "zerlegt" und einen Sniffer laufen lassen, dabei kam u.A. heraus, das die SW nur einen Core vom 24 (!) möglichen Core von den TS verwendet.

Weiter will ich gar nicht in die Tiefe gehen - machmal zeigen performante Systeme die Schwachstellen der Programmierer / Software sehr deutlich...

 

N :D


Mfg aus Bremen

 

Norbert (der andere :))

MVP Exchange Server


#3 Dunkelmann

Dunkelmann

    Expert Member

  • 1.862 Beiträge

 

Geschrieben 07. Juni 2016 - 06:34

Moin,

 

Du könntest mal mit dem MS Netzwerkmonitor bzw. Message Analyzer den Netzwerkverkehr der Anwendung beobachten. Timeouts, Requests ohne Response etc.


Keep It Small - Keep It Simple


#4 jostrn

jostrn

    Member

  • 232 Beiträge

 

Geschrieben 15. Juni 2016 - 14:30   Lösung

Servus, wirklich in den Stream reinschauen konnte ich nicht, da TLS-verschlüsselt.

 

Der Software-Anbieter hat das Ticket intern eskalieren lassen und jetzt(!) festgestellt, dass das Arbeitsspeicher-Limit für den Kunden am Limit war. Die Fachabteilung hat da wohl ein mächtiges DW aufgebaut, das komplett im RAM liegt ;-)

 

Damit kann ich die Leitungen wohl ausschließen :-)

 

Vielen Dank und viele Grüße