Zum Inhalt wechseln


Foto

Clients mittels SCCM Updaten


  • Bitte melde dich an um zu Antworten
11 Antworten in diesem Thema

#1 matze-it

matze-it

    Board Veteran

  • 475 Beiträge

 

Geschrieben 23. September 2014 - 05:59

Hallo zusammen,

 

ich plage mich momentan mit der Updaterei der Win7 Clients mittels SCCM 2012R2 rum.

 

In der Clientpolicy habe ich den Reboot auf 480min (8h) gestellt, somit erhalten die Clients nach den Updates nun das Fensterchen mit der Zeitanzeige.

Es gibt aber Clients, die rund um die Uhr laufen und nicht neugestartet werden sollen. Wie geh ich nun damit um ?

Im Deployment habe ich "Supress reboot" angegeben, das unterdrückt aber nur das Fenster mit der Zeitanzeige, der Reboot wird dann nach Ablauf der 8 Stunden einfach so, ohne Vorwarnung, ausgeführt.

 

Jemand ne Idee wo ich meinen Knoten im Kopf habe ?

 

Danke vorab und Gruss



#2 ssd_rider

ssd_rider

    Senior Member

  • 334 Beiträge

 

Geschrieben 23. September 2014 - 06:33

Vielleicht einfach eine neue Collection erstellen und diese Clients da rein packen, oder irre ich mich da jetzt und verwechsle was?

Theoretisch müsste das ja dann passen wenn man dann der Collection das so zuweißt, oder?


Im Zweifelsfall - Tu es!  - Grace Hopper

 


#3 matze-it

matze-it

    Board Veteran

  • 475 Beiträge

 

Geschrieben 23. September 2014 - 07:11

Entsprechende Collections dafür gibt es, das Deployment habe ich auch in alle Richtungen verändert um zu testen, allerdings komme ich um den Neustart einfach nicht rum, da liegt mein Problem.



#4 Doso

Doso

    Board Veteran

  • 2.488 Beiträge

 

Geschrieben 23. September 2014 - 07:45

Nun, wenn du Updates installieren möchtest, müssen die PCs irgendwann neu gestartet werden - da führt kein Weg daran vorbei.



#5 ssd_rider

ssd_rider

    Senior Member

  • 334 Beiträge

 

Geschrieben 23. September 2014 - 10:47

Was sind das für PCs?


Im Zweifelsfall - Tu es!  - Grace Hopper

 


#6 matze-it

matze-it

    Board Veteran

  • 475 Beiträge

 

Geschrieben 23. September 2014 - 11:49

Das sind z.T. PCs, die im Schichtdienst benutzt werden bzw. von Konstrukteuren.



#7 TorstenM

TorstenM

    Senior Member

  • 459 Beiträge

 

Geschrieben 23. September 2014 - 16:56

Im Deployment habe ich "Supress reboot" angegeben, das unterdrückt aber nur das Fenster mit der Zeitanzeige, der Reboot wird dann nach Ablauf der 8 Stunden einfach so, ohne Vorwarnung, ausgeführt.

 

Genau diese Einstellung sollte aber den Reboot unterdrücken. Kann es sein, dass "nach 8h" bedeutet, dass der Reboot gegen 2 oder 3 Uhr nachts passiert? Wenn ja dann wird er vom Windows Update Client Agent durchgeführt, aber nicht von ConfigMgr.


MCSA 2000/2003/2012, MCSE NT 4.0/2000/2003/2012, MCITP:EA, MCTS SCCM, Microsoft MVP - SCCM, http://www.mssccmfaq.de


#8 matze-it

matze-it

    Board Veteran

  • 475 Beiträge

 

Geschrieben 24. September 2014 - 07:46

Hallo Torsten,

 

den Gedanken hatte ich auch. Habe einen Nagelneuen Rechner genommen. Hier die OEM Installation fertiggestellt und in die Domäne aufgenommen. GPOs werden gezogen, SCCM Client ist drauf. also kein Hinweis auf die vorherige WSUS Config. Dann habe ich die Updates auf den Rechner losgelassen. Die Meldung, dass ein Neustart erforderlich ist kam nach der Installation, eine Uhrzeit und wurde nicht angezeigt. Soweit also Ok. Allerdings hat sich der Rechner Nachts wirklich neu gestartet, wie du sagst um ca. 3 Uhr Nachts.

Wie kommt die Kiste aber auf die Idee ? Habe ich an der Policy irgendwas falsch gemacht ? Habe eine GPO in der nur der Server angegeben wird, sonst keine Einstellungen. RSOP zeigt mir auch nichts anderes an.

 

Danke und Gruss



#9 TorstenM

TorstenM

    Senior Member

  • 459 Beiträge

 

Geschrieben 24. September 2014 - 16:46

Der Windows Update Client Agent sieht diesen ausstehenden Reboot und führt den dann durch. Abhilfe: GPO: Configure Automatic Updates -> Disabled.


  • RHaneberg gefällt das

MCSA 2000/2003/2012, MCSE NT 4.0/2000/2003/2012, MCITP:EA, MCTS SCCM, Microsoft MVP - SCCM, http://www.mssccmfaq.de


#10 matze-it

matze-it

    Board Veteran

  • 475 Beiträge

 

Geschrieben 25. September 2014 - 05:30

Vielen Dank für den Tipp bzw. die Bestätigung. Hatte die Info gestern in einem Blog gefunden, allerdings etwas widersprüchlich. Habe es trotzdem mal umgesetzt und siehe da, der Rechner hat heute Nacht nicht neu gestartet.

Gibt es sonst noch Einstellungen für die GPO, die relevant sind ? Ein Best Practice für die GPO habe ich nicht gefunden.



#11 TorstenM

TorstenM

    Senior Member

  • 459 Beiträge

 

Geschrieben 29. September 2014 - 18:49

Ein Best Practice für die GPO habe ich nicht gefunden.

 

Meiner Meinung gibt es sowas auch gar nicht. Die Anforderungen sind jwls viel zu unterschiedlich.


MCSA 2000/2003/2012, MCSE NT 4.0/2000/2003/2012, MCITP:EA, MCTS SCCM, Microsoft MVP - SCCM, http://www.mssccmfaq.de


#12 ssd_rider

ssd_rider

    Senior Member

  • 334 Beiträge

 

Geschrieben 06. Oktober 2014 - 05:34

Ich empfehle dir für weitere Details in GPOs http://www.gruppenrichtlinien.de


Im Zweifelsfall - Tu es!  - Grace Hopper