Jump to content

Zwei Netze mit zwei 801 über ISDN verbinden?


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo,

 

ich möchte zwei Netze mittels zweier 801er und einer ISDN Wählverbindung miteinander verbinden.

Die PCs im zweiten Netz sollen dabei die Internetverbindung der ersten Netzes bei Bedarf mitbenutzen können.

D.h. wenn ein Rechner aus dem 2. Netz auf´s Internet zugreifen möchte, baut der Router eine Verbindung zum 1. Netz auf und routet die Verbindung auf den dortigen Standard-Gateway. Wird die Verbindung nicht mehr benötigt, soll sie automatisch getrennt werden.

 

Hat zufällig jemand eine Beispielkonfiguration zur Hand ? Eigentlich sollte das doch keine sooo seltene Anwendung sein...

Schön wäre es noch, wenn dabei beide Netze den gleichen IP-Bereich benutzen könnten.

 

Bin für jeden Tip sehr dankbar.

 

Freundliche Grüße

 

Stefan

Link to post

Naja, wenn man ehrlich ist muss man sagen ISDN-Wählverbindungen sind echt teuer, besonders wenn sie für die normale Arbeit genutzt werden.

DSL-Leitungen sind heute echt nicht mehr teuer, haben eine höhere Bandbreite und per VPN ist das auch sicher.

 

Falls du es doch machen willst solltest du statt des Bridging (beide seiten gleiches Subnetz) lieber ein Routing nutzen sonst hast du sobald irgendein Gerät einen Broadcast sendet die Verbindung offen.

Da Broadcasts für die Kommunikation im Netzwerk gebraucht werden lassen die sich auch nicht ganz sperren(per ACL oder so).

Link to post

Hallo,

 

ich würd nichts lieber tun, als eine DSL-Verbindung zu nutzen. Leider gibt es aber noch immer Orte, in denen kein DSL verfügbar ist. Am Standort von Netz 2 ist aber schon ein ISDN-Anschluß mit XXL-Freetime vorhanden, den man nur auf XXL-Fulltime upgraden müsste. Dann sind die Kosten eher günstig. Relativ viel telefoniert wird da sowieso.

Wir nutzen das jetzt schon so, allerdings nur mit einem Router auf Seite 1 und nur einem PC auf Seite 2. Da wählt der sich also einfach ein, bekommt seine IP und schon funktionierts. Nun sollen dort aber 3 vernetzte PCs laufen... daher also der zweite Router.

Viel Bandbreite ist nicht erfordelich, da die PCs nur regelmässig Mails senden und empfangen müssen.

Auf Seite von Netz 1 haben wir natürlich ´ne DSL-Flatrate.

Das mit den Broadcasts ist natürlich ein Argument für´s Routing, statt des Brigding. Hab ich so bisher nicht bedacht.

Aber wie konfiguriere ich nun den 2. Router? Die Beispielkonfigurationen, die ich bisher gefunden habe, funktionieren nicht wirklich ..

 

Gruß Stefan

Link to post

Hi,

ich versuch mal die wichtigsten Befehle zusammenzuschreiben:

 

 

ROUTER 1 (wo internetverbindung ist):

 

aaa new-model

aaa authentication ppp default local

username Router_2 password geheim

int e0

ip add 10.10.10.254 255.255.255.0

int bri0

isdn switch-type basic-net3

dialer pool-member 1

enc ppp

 

int dialer0

ip add 172.16.0.1 255.255.255.252

enc ppp

ppp authentication chap

dialer-group 1

dialer pool 1

dialer caller 1234567 -->anrufende Nummer von Aussenstelle

ppp chap hostname Router_1

ppp chap password geheim

dialer idle-timeout 180

 

dialer-list 1 protocol ip permit

ip route 0.0.0.0 0.0.0.0 10.10.10.250 --> dein Router (oder Interface) Richtung Internet

ip route 20.20.20.0 255.255.255.0 172.16.0.2

 

ROUTER 2:

 

 

aaa new-model

aaa authentication ppp default local

username Router_1 password geheim

int e0

ip add 20.20.20.254 255.255.255.0

int bri0

isdn switch-type basic-net3

dialer pool-member 1

enc ppp

 

int dialer0

ip add 172.16.0.2 255.255.255.252

enc ppp

ppp authentication chap

dialer-group 1

dialer pool 1

dialer string 9999999 -->anzurufende Nummer der Haupstelle

ppp chap hostname Router_2

ppp chap password geheim

dialer idle-timeout 180

 

dialer-list 1 protocol ip permit --> definiert den "intresting" traffic

ip route 0.0.0.0 0.0.0.0 172.16.0.2

 

In dieser Config wird immer nur die Aussenstelle den Call generieren. Ansonsten müsstest du auch einnen dialer string dem zentralen Router angeben (und den dialer caller) an der Aussenstelle..

 

Hoffe es hilft.

 

Grüsse

Thomas

Link to post
Hi,

 

 

ROUTER 1 (wo internetverbindung ist):

 

aaa new-model

aaa authentication ppp default local

username Router_2 password geheim

 

Hallo,

 

nur mal eine kurze Frage.

 

Kann man das

 

aaa new-model

aaa authentication ppp default local

 

nicht weglassen? PPP Chap Authentifizierung klappt doch auch so über

einfach

 

username Router_2 password geheim

 

, oder?

 

fu

Link to post

Guten Morgen,

 

ich habs mit dieser Konfiguration mal probiert, aber leider ohne Erfolg. Die Aussenstelle wählt sich nicht ein.

 

Ich hab daraufhin mal mit ConfigMaker eine Konfiguration gebastelt, die schon etwas besser funktioniert. Es wird eine Verbindung aufgebaut und ich kann den "gegnerischen" Router schon mal anpingen. Allerdings funktioniert die Interverbindung noch nicht.

 

Kurz zu den Umgebungsvariablen:

Netz 1: Adressbereich 192.168.0.xx, ISDN Router 192.168.0.222, DSL-Router mit DNS 192.168.0.254.

Netz 2: Adressbereich 192.168.2.xx, ISDN Router 192.168.2.254, sollte auch als DHCP-Server für dieses Netz arbeiten. Standardgateway für Netz 2 soll 192.168.0.254 aus Netz 1 sein. Idealerweise sollte die Verbingung nur von Netz 2 zu Netz 1 und nur bei Internetzugriffen aufgebaut werden.

 

Die ConfigMaker-Config sieht so aus:

 

Netz 1 (Hauptstelle mit Internetverbindung)

 

 

service timestamps debug uptime

service timestamps log uptime

service password-encryption

no service tcp-small-servers

no service udp-small-servers

!

hostname router1

!

enable password geheim

username router2 password geheim

!

ip name-server 192.168.0.254

!

isdn switch-type basic-net3

!

ip subnet-zero

ip domain-lookup

ip routing

!

interface Dialer 1

description connected to router2

ip address 192.168.1.2 255.255.255.0

no ip split-horizon

encapsulation ppp

dialer in-band

dialer idle-timeout 120

dialer map snapshot 1 name router2 broadcast "Nummer der Aussenstelle"

dialer map ip 192.168.1.1 name router2 speed 64 broadcast "Nummer der Aussenstelle"

dialer-group 1

ppp authentication chap

no ppp multilink

snapshot server 15 dialer

no cdp enable

!

interface Ethernet 0

no shutdown

description connected to EthernetLAN_1

ip address 192.168.0.222 255.255.255.0

keepalive 10

!

interface BRI 0

no shutdown

description connected to router2

no ip address

dialer rotary-group 1

!

! Dialer Control List 1

!

no dialer-list 1

dialer-list 1 protocol ip permit

!

router rip

version 2

network 192.168.1.0

network 192.168.0.0

no auto-summary

!

!

ip classless

ip http server

snmp-server community public RO

no snmp-server location

no snmp-server contact

!

line console 0

exec-timeout 0 0

password geheim

login

!

line vty 0 4

password geheim

login

!

end

 

 

Fortsetzung im nächsten posting....

Link to post

...

 

Netz 2 (Aussenstelle):

 

 

!

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

no service tcp-small-servers

no service udp-small-servers

!

hostname router2

!

enable password geheim

username router1 password geheim

!

ip name-server 192.168.0.254

!

isdn switch-type basic-net3

!

ip subnet-zero

ip domain-lookup

ip routing

!

interface Dialer 1

description connected to router1

ip address 192.168.1.1 255.255.255.0

no ip split-horizon

encapsulation ppp

dialer in-band

dialer idle-timeout 120

dialer hold-queue 10

dialer map snapshot 1 name router1 broadcast "anzurufende Nummer der Hauptstelle"

dialer map ip 192.168.1.2 name router1 speed 64 broadcast "anzurufende Nummer der Hauptstelle"

dialer-group 1

ppp authentication chap

no ppp multilink

snapshot client 15 360 suppress-statechange-update dialer

no cdp enable

!

interface Ethernet 0

no shutdown

description connected to EthernetLAN

ip address 192.168.2.254 255.255.255.0

no ip directed-broadcast

keepalive 10

!

interface BRI 0

no shutdown

description connected to router1

no ip address

dialer rotary-group 1

!

! Dialer Control List 1

!

no dialer-list 1

dialer-list 1 protocol ip permit

!

! DHCP Server

!

service dhcp

ip dhcp pool 1

network 192.168.2.0 255.255.255.0

default-router 192.168.2.254

!

router rip

version 2

network 192.168.1.0

network 192.168.2.0

no auto-summary

!

!

ip classless

ip http server

snmp-server community public RO

no snmp-server location

no snmp-server contact

!

line console 0

exec-timeout 0 0

password geheim

login

transport input none

!

line vty 0

password geheim

login

!

end

 

 

Sicherlich wird darin einiges überflüssig sein, aber irgenwas scheint auch noch nicht zu stimmen.

Bin für jeden Tip sehr dankbar.

 

Danke!

 

Gruß Stefan

Link to post

Wie sehen denn die Routen auf den beiden Routern aus?

 

show ip route

??

Gibt es überhaupt eine default-route?

 

ehrlich gesagt würde ich für ein Netzwerk mit 2 Routern und 2 Subnetzen kein Routingprotokoll verwenden.

 

EDIT:

Muss mich meinem Nachfolger anschließen. Hast doch noch nix drin in der Konfig, oder?

Mußt doch eigentlich nur einen weiteren Dialer, mit einer default Route anlegen...

Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...