Jump to content
Sign in to follow this  
Jwinter78

Inkonsistente Exchange2003 Datenbank

Recommended Posts

Hallo Profis!

 

Ich habe folgendes Problem:

Wir haben in der Firma einen SBS2003 mit Exchange2003 laufen! Seit heute morgen ist es allerdings nicht mehr möglich, sich am Exchange-Server anzumelden! Ein Blick in die Ereignisanzeige ergab unter anderem, daß die Datei "priv1.edb" korrupt sei! Nach einigen Recherchen im Netz kam ich auf das Tool "eseutil"! Ich lies diese Datenbank überprüfen und es wurde mir ein "dirty shutdown" angezeigt! In diesem Moment fiel mir ein, daß wir vor 3 Tagen einen Stromausfall hatten! Die am Server angeschlossene USV fing diesen Ausfall zwar auf, jedoch konnte ich den Server nicht normal runter fahren, da ich während des Shutdown des Servers einen Bluescreen erhielt. Also blieb mir nix anderes übrig, als ihn einfach auszuschalten! Zwar lief einen Tag später alles noch, doch bin ich der Meinung, daß es was damit zu tun hat! Es ist mir auch nicht möglich, mittels "eseutil" ein recovery dieser Datenbank zu fahren! Ich bekomme jedesmal die Fehlermeldung, daß besagte Datei gesperrt oder noch in Benutzung ist! Wir sichern zwar auf Band aber genau diese Daten eben nicht! :mad: Frage: Kann ich die Datenbank irgendwie wieder retten?? Unsere ganzen E-Mails stecken fest und auch der Outlook-Kalender, den wir für Termine und ähnliches verwenden geht logischerweise auch nicht!

Hat jemand einen Tipp für mich?? Ich habe mich mit Exchange nocht nicht ganz so dolle beschäftigt, darum kümmert sich ein Kollege! Wie es aber bei "Murphy's Law" halt so ist, ist besagter Kollege im Urlaub und ich bin im Moment der Einzige, der sich mit solchen Sachen beschäftigt! (Hätte ich mir doch nur einen anderen Job gesucht! :p )

Share this post


Link to post

Hallo,

 

als erstes würde ich die Datenbank weg kopieren - um überhaupt eine Sicherung zu haben, wenn man mit den ganzen Tools an der Datenbank Hand anlegt.

 

Hier mal etwas Literatur zu den Tools bzw. wie man damit umzugehen hat:

 

http://www.msexchangefaq.de/tools/eseutil.htm

 

http://www.msexchangefaq.de/notfall/korrupt.htm

 

http://www.msexchangeforum.de/modules/smartfaq/faq.php?faqid=16

 

User7070

Share this post


Link to post

Danke erstmal! Werde mir das mal zu Gemüte führen. Es muss doch möglich sein, die Datenbank wieder zum Leben zu erwecken!

 

Mfg. J.Winter

Share this post


Link to post

Wenn du Esutil nutzt, solltest du den Informationsspeicher deaktivieren und User7070 die Datenbankdateien kopieren, falls doch was schief geht hast du immer eine Grundlage.

 

Sichert ihr denn die Datenbank gar nicht weg?

 

gruß

Ronny

Share this post


Link to post

Guten Morgen!

Doch wir sichern aber eben nicht diese Dateien, da Exchange sehr viel später eingerichtet wurde, als die Sicherung, wurde eben vergessen, es nachträglich mit dazu zu nehmen!

Und den Informationsspeicher kann ich nicht beenden, weil ich ihn erst gar nicht starten kann! Genau das ist ja das Problem. Wenn ich versuche, den Informationsspeicher zu starten, bekomme ich folgende Fehlermeldung:

"Interner Verarbeitungsfehler. Starten Sie Exchange-System-Manager oder den Microsoft Exchange-Informationspeicherdienst oder beide Programme neu. Überprüfen Sie das Anwendungsprotokoll auf mit diesem Fehler zusammenhängende Ereignisse.....

ID-Nr.: c1041724 Exchange-System-Manager

Share this post


Link to post
Und den Informationsspeicher kann ich nicht beenden, weil ich ihn erst gar nicht starten kann! Genau das ist ja das Problem.

 

Wo ist jetzt das Problem bzw. was hast Du vor? :suspect:

 

User7070

Share this post


Link to post

ID-Nr.: c1041724 Exchange-System-Manager[/b]

 

 

Genau den hatten wir auch gestern. Kuck mal hier: What to Do When an Exchange Store Won't Mount

 

Versuch eine Softrecovery der Logfiles oder Spiel die Datenbanken der Storage Group von einem Backup zurück. Wenn Symantec BE eingestzt wird kann man mit der Option "No loss restore" die noch bestehenden Logs wider einspielen lassen. Bei uns geschah das alles automatisch - praktisch kein Datenverlust.:wink2:

Share this post


Link to post

Also wie ich am Anfang schon schrieb, gibt es von diesen Daten kein Backup! Das ist ja das ****e! Wenn ich mittels eseutil versuche, ein Defrag der Datenbank zu machen, bekomme ich die Meldung "This database was not cleanly shutdown." und ich soll ein Soft-Recovery machen, um sie richtig abzuschließen! Das würde ja das Problem schon beheben, denke ich aber auch ein Recovery mittels eseutil ist nicht möglich! Dann bekomme ich die Meldung, daß die Datei entweder gesperrt oder in Benutzung ist! Selbst wenn ich im absgesicherten Modus starte?! Welcher Prozess hat hier noch die Finger drinne??

Share this post


Link to post

Also mit der rumschreierei und den vilen (!) kommst du schon mal gar nicht weiter....

 

 

P.S.: Du sollst Sie nicht defragmentieren, das macht man eher mit einer gesunden Datenbank. Kannst du sie wenigsten physisch, als die *.edb und *.stm wegkopieren (wurde übrigens schon zweimal erwähnt!)? Dann könnte man ein eseutil /d /p probieren....

Share this post


Link to post

Hallo lieber JWinter,

 

stoppe alle Exchangedienste und auch die der Datensicherung und denAntivirus, (nimm vorher den rechner vom Netz).

 

danach setzte alle Dienste auf Manuell und reboote den Server.

 

dann nimm die priv.etb, die .stm auch die pub.etb und die dazugehöhrige .stm und kopiere sie in eine anderes Verzeichniss (zur Sicherheit)

 

danach starte eine Reparatur mit Eseutil

 

wirst sehen dan funkt des.

 

lg

Pentium

Share this post


Link to post

@Velius

Wieso rumschreien?? Wenn ich was schlimmes gesagt haben sollte dann sorry!

Und ja, die priv1.edb/.stm und die pub1.edb/.stm habe ich vorher in ein anderes Verzeichnis kopiert, sicher ist sicher. ;)

 

@user7070

Hab ich das richtig verstanden? Datenbanken kopieren in anderes DIR (ist ja schon geschehen) und dort dann versuchen zu reparieren?

Das mit den Diensten werde ich tun. Ich hoffe sehr daß das klappt.

 

Noch ne andere Frage: Auf die Gefahr hin, daß ich beide Datenbanken nicht retten kann, wie bringe ich den Exchange-Server wenigstens wieder dazu ab sofort zu laufen, also sozusagen neue Datenbanken anzulegen?

 

Btw.: Schon mal gaaanz herzlichen Dank für die schnellen Antworten!

Share this post


Link to post

Noch ne andere Frage: Auf die Gefahr hin, daß ich beide Datenbanken nicht retten kann, wie bringe ich den Exchange-Server wenigstens wieder dazu ab sofort zu laufen, also sozusagen neue Datenbanken anzulegen?

 

Btw.: Schon mal gaaanz herzlichen Dank für die schnellen Antworten!

 

 

Ich nehme an, dass die DBs in der selben Storage Group waren, oder? Wenn die Rep. fehlschlagen sollte und die Logs auch nicht konsistent sind (teilweise gelöscht o.ä.) dann musst du die anderen DBs vom Backup weiderherstellen, da die Logs pro Storage Group geschrieben werden.

Share this post


Link to post
...dann musst du die anderen DBs vom Backup weiderherstellen, da die Logs pro Storage Group geschrieben werden.

Na toll. Gibt es irgendwo im System evtl. Sicherheitskopien davon? Denn wie schon erwähnt, wurden die Exchange-Daten nicht explizit mit gesichert. Wenn ich ein Backup hätte wäre das ja gar nicht so schlimm aber ein solches existiert eben nicht. Im Falle eines Misserfolges bleibt dann also nur noch ein Neuaufsetzen des Exchange-Servers? :shock:

Ich krieg das Grauen, denn das Einrichten war schon ein Krampf.

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...