Jump to content
Sign in to follow this  
il_principe

Win XP Remotedesktop Druckermapping geht nicht

Recommended Posts

Hi Leute,

 

Ich hab ein ganz komsiches Phänomen mit einer Workstation XP SP2 aktuelle Updates.

Diese geht per RDP auf einen Win2k Terminalserver. Auf der Workstation ist ein Drucker per Netzwerk installiert.

Jedoch wird dieser nicht am Terminal verbunden, auch kein Eventlog Eintrag z.B. dass kein Treiber da ist usw...

Von anderen Rechnern am selben Standort geht das ohne Probleme, auch mit demselben Benutzer.

Ich hab's auch mit einem anderen Programm (Visionapp) probiert. Selbes Ergebnis.

 

Bin für jeden Tipp dankbar

 

lg

il_principe

Share this post


Link to post

hmmm. klingt doof, aber manchmal sieht man den wald vor lauter bäumen nicht...

 

ist denn in dem mstsc client überhaupt Lokale Geräte automatisch verbinden der Drucker aktiviert?

 

also mstsc -> optionen -> lokale ressourcen -> lokale geräte?

Share this post


Link to post

Hmmm,

 

vielleicht eine Gruppenrichtlinie, PC in unterschiedlichen OU's?

 

Drucker per Netzwerk, also kein lokaler Drucker? Werden denn nicht nur lokale Drucker

verbunden, also Drucker mit einem lokalen Anschluß (darf aber auch TCP/IP sein)? :confused:

 

Gruß Kai

Share this post


Link to post

Ist der Treiber für den Drucker vorhanden? Mußte neulich auch Clients an einen TS anbinden (XP+w2k3), die einen Netzwerkdrucker hatten und ohne den Treiber am TS ging garnichts.. (Kyo KM2550KX)..

Share this post


Link to post

Ich habe mich vielleicht etwas schlecht ausgedrückt,

 

funktionierende Clients: Netzwerkdrucker lokal installiert

nicht funktionierender Client: Netzwerkdrucker als Netzwerkdrucker (Benutzer) gemappt,

der mit dem Kabel im Icon drunter.

Share this post


Link to post

Hallöchen,

 

selbes Problem hatten wir bei einem Kunden, der auf unseren Terminalservern arbeitet.

 

Wäre der Treiber nicht vorhanden, käme in der Ereignisanzeige eine Meldung, daß der Treiber nicht bekannt ist und der Drucker nicht eingerichtet wurde (kann man dann entweder durch Installation des Treibers oder Treibermapping beheben). Das war hier allerdings nicht der Fall.

 

Telefonisch war das ganze nicht zu lösen.

2 PCs gleich eingerichtet, gleicher Drucker, Druckertreiber bei uns gemappt: Bei einem geht's, beim anderen nicht.

 

 

Da mir auch nichts weiter eingefallen ist und ich nichts finden konnte, hab ich mir das vor Ort angeschaut und nach einiger Suche auch den kleinen, aber feinen Unterschied gefunden:

 

Bei dem PC, auf dem es funktionierte, war der Drucker als Netzwerkdrucker (also nicht als TCP/IP-Drucker!) angelegt.

Bei dem anderen PC war derselbe Drucker, mit demselben Namen, als TCP/IP-Drucker angelegt (mir ist einfach der Zusatz "an <Printserver>" nicht aufgefallen). Nachdem wir den Drucker hier auch als Netzwerkdrucker eingerichtet hatten, hat es funktioniert.

 

Ausführlichere Tests hier bei mir haben dann ergeben, daß der RDP-Client TCP/IP-Drucker scheinbar ignoriert (egal ob freigegeben oder nicht, ob mit IP-Adresse oder DNS-Namen angelegt).

 

Was ich dann bei weiteren Suchen gefunden habe, war folgendes Dokument, was darüber einigen Aufschluß gibt:

http://download.microsoft.com/download/6/a/b/6abeacd8-ee27-417a-ba1c-36cbedbaeb2e/Fragen_und_Antworten_zum_Webcast_09062005.pdf

 

Zum Thema Drucker und RDP-Client steht in etwa drin:

Drucker, deren Port nicht mit COM, LPT oder USB beginnt, werden nicht über den RDP-Client angelegt.

Lösungsmöglichkeit wäre hier, den vorgeschlagenen Port des TCP/IP-Druckers (wenn es einer ist), beim Anlegen von IP_blabla in USB_IP_blabla umzubenennen. Wenn es ein Multifunktionsdrucker mit eigenem Port (DOT4 z.B.) ist, dann müßte man den Drucker (laut MS) auf Port LPT1 umstellen, wobei man aber die Multifunktionsfunktionen (doofes Wort...) verlieren würde.

 

Eine umfassendere Lösung wäre ein Registry-Eintrag unter HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\AddIns\RDPDR den DWORD-Wert FilterQueueType mit dem Wert FFFFFFFF.

Quelle: Printers That Use Ports That Do Not Begin With COM, LPT, or USB Are Not Redirected in a Remote Desktop or Terminal Services Session

 

 

Ich hoffe, das hilft einigen, die sich mit diesen Problemen rumschlagen müssen. Ich bin froh, daß ich zu dem Thema endlich was gefunden habe :)

 

 

Edit: Ihr habt nen ganz schön pingeligen Filter (zensiert b.l.o.e.d, aber nicht doof) :)

 

Gruß

Timo

Share this post


Link to post

@llzwerg

 

danke für den tipp mit dem reg eintrag... hab ich auch vor einer woche gefunden... damit hat's dann auch bei mir gefunzt... hab den Tipp auch im Forum gepostet aber vergessen diesen Beitrag zu schließen.

 

lg

il_principe

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...