Jump to content
Sign in to follow this  
jani_brb

Windows Server + Apache und DNS auflösung

Recommended Posts

Hallo,

 

ich habe eine Frage zum setzen von DNS Namen die auf ein unterverzeichnis im Apache verweisen.

 

Beispiel: Ich habe unter Windows Server einen Apache2 laufen. Läuft wunderbar. Habe im meinem Root-Verzeichnis "c:\web\apache2\htdocs" ein Unterverzeichnis mit den Namen "Test". In diesem Unterordner liegt eine eigenständige Webseite.

 

Um diese aufzurufen muss ich ja immer "http://localhost/test" eingeben. Ich möchte jedoch das dies per Name aufgelöst wird zB einfach "http://test". Wenn ich eine Alias im DNS setze und das auf die IP verweise, komme ich nur ins Root-Verzeichnis.

 

Kann ich das irgendwie umgehen oder korrekt anlegen? Danke für eure hilfe

 

mfg

Share this post


Link to post

Ah ok, das ist schon mein ein Schritt weiter :) Danke

 

Ich habe nun mal gegooglt um zu schauen wie ich sowas anlegen muss. Habe meine config angepasst, allerdings startet dann mein apache nicht mehr. muss ich irgendetwas beachten?

 

hier der auszug aus meiner config:

 

VirtualHost *:80>

ServerName primus.domainname.de

ServerAdmin administrator@domain.de

DocumentRoot D:/Web/xampp/htdocs

ErrorLog D:/Web/xampp/logs/error_log

CustomLog D:/Web/xampp/logs/access_log common

</VirtualHost>

 

<VirtualHost *:80>

ServerName upload.domain.de

ServerAdmin administrator@domain.de

DocumentRoot D:/Web/xampp/htdocs/upload

ErrorLog D:/Web/xampp/logs/upload.error_log

CustomLog D:/Web/xampp/logs/upload.access_log common

</VirtualHost>

Share this post


Link to post
Ich habe nun mal gegooglt um zu schauen wie ich sowas anlegen muss. Habe meine config angepasst, allerdings startet dann mein apache nicht mehr. muss ich irgendetwas beachten?

 

Hast du dir mal die Apache Dokumentation angeschaut?

Share this post


Link to post

hi jani

 

hatte grade mit dem exakt gleichen problem zu tun. (ebenfalls xampp)

 

Also ich hatte das customlog im virtualhost eintrag gelöscht und dann ging der apache wieder... und unter namedvirtualhost habe ich *:80 eingetragen.

 

und habe noch das modul:

LoadModule vhost_alias_module modules/mod_vhost_alias.so

in der httpd.conf aktiviert.

 

Dann hat es geklappt.

 

meine httpd-vhosts.conf:

 

#
# Virtual Hosts
#
# If you want to maintain multiple domains/hostnames on your
# machine you can setup VirtualHost containers for them. Most configurations
# use only name-based virtual hosts so the server doesn't need to worry about
# IP addresses. This is indicated by the asterisks in the directives below.
#
# Please see the documentation at 
# <URL:http://httpd.apache.org/docs/2.2/vhosts/>
# for further details before you try to setup virtual hosts.
#
# You may use the command line option '-S' to verify your virtual host
# configuration.

#
# Use name-based virtual hosting.
#
NameVirtualHost *:80

<VirtualHost *:80>
   ServerAdmin webmaster@dummy-host.example.com
   DocumentRoot "F:/Webdata/Apache1"
   ServerName apache1.mydomain.ch
   ServerAlias apache1.mydomain.ch
<Directory />
   Options FollowSymLinks
   AllowOverride None
   Order deny,allow
   allow from all
</Directory>

</VirtualHost>

<VirtualHost *:80>

   DocumentRoot "F:/Webdata/Apache2"
   ServerName apache2.mydomain.ch
   ServerAlias apache2.mydomain.ch

<Directory />
   Options FollowSymLinks
   AllowOverride None
   Order deny,allow
   allow from all
</Directory>

 

 

 

 

Grüsse

 

Darkmind

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...