Jump to content
Sign in to follow this  
kingof

DMA Modus HDD lässt sich nicht aktivieren

Recommended Posts

Hallo zusammen,

 

erstmal bin ich beruhigt, dass Deutschland gewonnen hat. So, jetzt zu meinem Problem:

 

Wie schon in der Überschrift steht, lässt sich der DMA-Modus bei meinem Notebook für die HDD nicht aktivieren. Im Gerätemanager unter Primärer IDE Kanal ist für Gerät 0 (das ist die HDD) DMA, wenn verfügbar akiviert. Auch im BIOS ist DMA für die HDD aktiviert. Jedoch steht nun unter Aktueller Übertragungsmodus nur der langsame PIO-Modus. Kurze Info zum System: IBM Thinkpad R52 mit tagesaktuellen Treibern und BIOS, Win XP SP2 voll gepatcht. Das System ist dadurch extrem langsam, speziell natürlich bei Festplattenzugriffen und beim Booten. Mit einem Benchmark lässt sich feststellen, dass die Festplatte nur ca 1/5 ihrer eigentlichen Geschwindigkeit erreicht. Die HDD an sich ist i.O., auch das habe ich geprüft. Das Ganze scheint ein Windows-problem zu sein; die Ursache ist laut einem Microsoft-KB-Artikel (siehe Punkt 2) der Ruhezustand.

 

Nun zu den Maßnahmen, die ich bereits durchgeführt habe:

1. Auf Raten des IBM-Supports: Deinstallieren des IDE-Controllers bzw. des Primären IDE-Kanals -> Ausschalten des Systems-> vom Netz und von der Batterie trennen-> Starten-> Bluescreen in normalen und abgesicherten Modus-> Last known good configuration->bootet wieder, aber mit den vorherigen Einstellungen, also kein Erfolg

 

2. Folgende Vorgehensweise, wie in einem Microsoft KB-Artikel beschrieben http://support.microsoft.com/default.aspx?scid=kb;de;817472

(der zugehörige Patch ist in SP2 enthalten):

"

1. Klicken Sie auf Start, klicken Sie auf Ausführen, geben Sie regedit ein, und klicken Sie anschließend auf OK.

2. Suchen Sie den folgenden Registrierungsschlüssel, und klicken Sie darauf:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0001

3. Zeigen Sie im Menü Bearbeiten auf Neu, und klicken Sie anschließend auf DWORD-Wert.

4. Geben Sie ResetErrorCountersOnSuccess ein, und drücken Sie anschließend die [EINGABETASTE].

5. Klicken Sie im Menü Bearbeiten auf Ändern.

6. Geben Sie 1 ein, und klicken Sie auf OK.

Gehen Sie wie nachstehend beschrieben vor, und beenden Sie anschließend den Registrierungseditor:

1. Klicken Sie auf Start, klicken Sie auf Ausführen, geben Sie regedit ein, und klicken Sie anschließend auf OK.

2. Suchen Sie den folgenden Registrierungsschlüssel, und klicken Sie darauf:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0002

3. Zeigen Sie im Menü Bearbeiten auf Neu, und klicken Sie anschließend auf DWORD-Wert.

4. Geben Sie ResetErrorCountersOnSuccess ein, und drücken Sie anschließend die [EINGABETASTE].

5. Klicken Sie im Menü Bearbeiten auf Ändern.

6. Geben Sie 1 ein, und klicken Sie auf OK."

 

Auch das brachte keinen Erfolg, weiterhin PIO-Modus

 

Nun sehe ich noch folgende zwei Möglichkeiten:

1. Direktes Ändern des Registryeintrags unter: HKEY LOCAL MACHINE\Hardware\Devicemap\SCSI\SCSI Port 0\ den Wert "DMAEnabled" auf 1 setzen (ist auf 0) Könnte das überhaupt was bringen? Und ja, ich habe ein Image gamacht ;-)

 

2. Ich habe ein Tool gefunden, was mit den DMA-Modus angeblich wieder aktiviert namens DMACHECK.EXE, was in den Support-Tools von Win NT dabei ist, aber angeblich auch mit XP funktionieren soll

 

3. Eure Vorschläge ;-)

Share this post


Link to post
Share on other sites

Laut dem Artikel von Microsoft scheint das aber ein Windows-Problem zu sein. Die IBM-Software, wie z.B. Access Connections ist im Business-Umfeld eigentlich sehr hilfreich muss ich sagen, da bin ich nicht so ganz deiner Meinung.

Share this post


Link to post
Share on other sites

Meinte es auch nicht direkt negativ, aber wenn ich ein frisches Win vor mir habe (und dazu noch ein Notebook, was ja von Haus aus sooooo performant ist), geht mir schon der Hut hoch, wenn ~30 Tools und Treiber und Goodies und blablabla installiert sind.....

 

Getreu nach dem Multimedia-Erfinder-Hype: Was gemacht werden KANN wird gemacht....ob´s IRGENDEINER mal irgendwann brauchen kann ist egal! :D

Will jetzt hier aber keine Diskussion anregen ;)

 

Grundlegend ist es ja auch kein falscher Ansatz aufgrund wiederkehrender I/O-Probleme die Performance zu drosseln....

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...