Jump to content
Sign in to follow this  
Anakim

VLAN Database - Befehl nicht vorhanden

Recommended Posts

Tach auch,

 

hab hier schon mal auf mein Problem hingewiesen. Das ursprüngliche das meine VLAN's nicht funktionieren ist erst mal nebensächlich.

 

Mein Hauptproblem ist, dass ich die VLAN's nicht konfigurieren kann weil sämtliche Befehle die mit VLAN zu tun haben bei mir nicht funktionieren, weil schlicht VLAN unter "conf t" nicht existiert.

 

Da die VLAN's (ich habe zwei) aber konfiguriert sind gehe ich davon aus, dass entweder der Befehl wo anders zu finden ist und oder auch anders heißt oder dass was mit meiner Software nicht stimmt..

 

Hier noch mal mein Versionsauszug:

C3548XL(config)#?
Configure commands:
 aaa                         Authentication, Authorization and Accounting.
 access-list                 Add an access list entry
 alias                       Create command alias

.... gekürzt...

 spanning-tree               Spanning Tree Subsystem
 stackmaker                  Specify stack name and add its member
 tftp-server                 Provide TFTP service for netload requests
 time-range                  Define time range entries
 username                    Establish User Name Authentication

C3548XL#sh ver
Cisco Internetwork Operating System Software
IOS (tm) C3500XL Software (C3500XL-C3H2-M), Version 12.0(5.1)XP, MAINTENANCE INTERIM SOFTWARE
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Fri 10-Dec-99 11:18 by cchang
Image text-base: 0x00003000, data-base: 0x002A0538

ROM: Bootstrap program is C3500XL boot loader

C3548XL uptime is 4 days, 12 hours, 41 minutes
System returned to ROM by power-on
System image file is "flash:c3500XL-c3h2-mz-120.5.1-XP.bin"


cisco WS-C3548-XL (PowerPC403) processor (revision 0x01) with 16384K/1024K bytes of memory.
Processor board ID 0x17, with hardware revision 0x00
Last reset from power-on

Processor is running Standard Edition Software
Cluster command switch capable
Cluster member switch capable
48 FastEthernet/IEEE 802.3 interface(s)
2 Gigabit Ethernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:01:96:0F:CE:00
Motherboard assembly number: 73-3903-04
Power supply part number: 34-0971-01
Motherboard serial number: FAA04109F0X
Power supply serial number: PAC040801RU
Model revision number: A0
Motherboard revision number: 01
Model number: WS-C3548-XL-A
System serial number: FAA0411F0FA
Configuration register is 0xF

C3548XL#

 

Wei man sehen kann fehlt in der Auflistung "vlan". Ich hoffe mir kann das jemand beantworten. :confused:

 

Viele Grüße & Danke

Anakim

Share this post


Link to post
Share on other sites

Also soweit ich das weiss wird ein VLAN über den Interface Kommand konfiguriert:

Conf t

inter VLAN xx

ip add x.x.x.x x.x.x.x

 

Damit legts du ein VLAN auf dem 3548 an

Bei älternen Catalyst gab es da weis mit VLAN-Database

 

 

Wenn das VLAN angleget ist dann im ENA MODE

sh vlan

Share this post


Link to post
Share on other sites

aha ...

 

das mit inter vlan .... funktioniert.

 

Scheinbar hab ich ne neure Version oder was ?? Seltsam, alle im Board schreiben hier immer vlan-database.. kann ich fast nicht vorstellen, das mein altes Krückending so fortschritlich ist. :confused:

 

aber ok ...

 

Anlegen ist jetzt kein Thema. Das sind sie schon. Wie kann ich jetzt z.B. den GW prüfen und den DNS Eintrag auf dem VLAN prüfen/setzen ?

 

Weiterhin bekomm ich immer bei der eingabe von z.B. dns eingebe...

 

C3548XL#dns
Translating "dns"...domain server (192.168.0.254)
% Unknown command or computer name, or unable to find computer address
C3548XL#

 

das er den domain server (IP meines DNS Routers) wohl absucht aber kein Auflösung durchführen kann. interne Namensauflösung findet auch nicht statt..

 

Geht das überhaupt ? dass ich interne Rechner über diese Namensauflösung erreichen kann ? .. also sprich ...XY .. und .. dann sollte ne Antwort kommen 192... usw..

 

Grüße

Anakim

Share this post


Link to post
Share on other sites

Einfach "dns" eingeben bringt nix. Er schaut ob es ein Kommando "dns" gibt, findet es nicht und dann versucht er den Namen "dns" aufzuloesen. Mach doch mal lieber "ping dnseintragdenesgibt" :) Gateway kannste natuerlich auch mit ping rausfinden obs funktioniert ;)

Share this post


Link to post
Share on other sites

hy,

 

dns war vielleicht ein schlechtes Beispiel aber ping DNSNAME gehtl leider auch nicht. Weiß nur nicht obs am Switch liegt oder/und auch am Router :confused:

 

Grüße

Anakim

Share this post


Link to post
Share on other sites

hast du den dns server am switch eingetragen, denn ohne kannst du ja keinen namen pingen wenn der switch nicht weiss aufwelchen dns server zugreifen soll.

 

bei meinem 3750 geht das über configure terminal -> ip name-server XXX.XXX.XXX.XXX = IP des Nameservers.

 

mfg

onedread

Share this post


Link to post
Share on other sites

@ondread

 

Hy.. also der Nameserver ist eingetragen. Zumindestesn zeigt mir das die Konfig an. Also sollte er wissen wos lang geht .. :D

 

Anakim

Share this post


Link to post
Share on other sites

@Wordo

 

das mit der ACL hört sich auch gut an. Kann ich mir vorstellen. (Switch wurde von einer Fachabteilung bzgl. Switchtes in einem großen Unternehmen eingerichtet).. ;)

 

Wie kann ich die den die ACL überprüfen ?!? Sorry aber ich hab was Befehle angeht noch keinen Plan und bin noch am lernen mit dem Teil.

 

Gruß

Anakim

Share this post


Link to post
Share on other sites

Hi Anakim

 

Info :

 

"vlan database" ist kein terminal command !

 

Schon mal in die "dir" geschaut ?

oder "sh flash" ?

Da sollte eine vlan.dat liegen, wenn nicht, dann hast Du bis jetzt nur nen

L3 Interface Vlan X gebaut.

 

Choose :

 

Switch#vlan database

Switch(vlan)#?

VLAN database editing buffer manipulation commands:

abort Exit mode without applying the changes

apply Apply current changes and bump revision number

exit Apply changes, bump revision number, and exit mode

no Negate a command or set its defaults

reset Abandon current changes and reread current database

show Show database information

vlan Add, delete, or modify values associated with a single VLAN

vtp Perform VTP administrative functions.

 

Switch(vlan)#

 

Nur so baut man ein Vlan auf L2 Ebene !

 

Greez

 

Mr. Oiso

Share this post


Link to post
Share on other sites

@mr._oiso

 

Tach.. :)

 

Hi Anakim

 

Info :

 

"vlan database" ist kein terminal command !

 

Schon mal in die "dir" geschaut ?

oder "sh flash" ?

Da sollte eine vlan.dat liegen, wenn nicht, dann hast Du bis jetzt nur nen

L3 Interface Vlan X gebaut.Mr. Oiso

 

Also die vlan.dat hab ich nicht. Dass ich nur ein L3 Interfache habe (gebaut wurde) sehe ich jetzt auch, aber was hat das für Konsequnenzen ? Oder wo liegen die Unterschiede ? Hat es Nachteile ? ... :confused:

 

Choose :

 

Switch#vlan database

Switch(vlan)#?

VLAN database editing buffer manipulation commands:

abort Exit mode without applying the changes

apply Apply current changes and bump revision number

exit Apply changes, bump revision number, and exit mode

no Negate a command or set its defaults

reset Abandon current changes and reread current database

show Show database information

vlan Add, delete, or modify values associated with a single VLAN

vtp Perform VTP administrative functions.

 

Switch(vlan)#

 

Nur so baut man ein Vlan auf L2 Ebene !

 

Also wenn ich das richtig verstanden habe kann ich das VLAN auf L2 Ebene nur mit dem Befehl "vlan database" editieren ? Da ich es aber nicht habe gehts auch nicht ! Aber wie editieren ich dann mein L3 Ebene VLAN ?...

 

Oh Mann.. ich wollt doch nur mal kurz das VLAN checken.. seh schon größere Geschichte.. :(

 

Gruß

Anakim

Share this post


Link to post
Share on other sites
Einfach mal die Config posten (sh run)

Hier noch mal die Config:

 

sh run
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname C3548XL
!
no logging buffered
no logging console
enable secret 5 **
enable password **
!
username ** privilege 15 password 0 ***
!
!
!
!
!
ip subnet-zero
ip domain-list localhost
ip domain-name tmp.com
ip name-server 192.168.0.254
no cgmp
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface FastEthernet0/25
!
interface FastEthernet0/26
!
interface FastEthernet0/27
!
interface FastEthernet0/28
!
interface FastEthernet0/29
!
interface FastEthernet0/30
!
interface FastEthernet0/31
!
interface FastEthernet0/32
!
interface FastEthernet0/33
!
interface FastEthernet0/34
!
interface FastEthernet0/35
!
interface FastEthernet0/36
!
interface FastEthernet0/37
switchport access vlan 2
!
interface FastEthernet0/38
switchport access vlan 2
!
interface FastEthernet0/39
switchport access vlan 2
!
interface FastEthernet0/40
switchport access vlan 2
!
interface FastEthernet0/41
switchport access vlan 2
!
interface FastEthernet0/42
switchport access vlan 2
!
interface FastEthernet0/43
switchport access vlan 2
!
interface FastEthernet0/44
switchport access vlan 2
!
interface FastEthernet0/45
switchport access vlan 2
!
interface FastEthernet0/46
switchport access vlan 2
!
interface FastEthernet0/47
switchport access vlan 2
!
interface FastEthernet0/48
switchport access vlan 2
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
ip address 192.168.0.100 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
interface VLAN2
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
no ip route-cache
shutdown
!
ip default-gateway 192.168.0.254
ip http port 8080
!
!
end

C3548XL#

Gruß

Anakim

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...