Jump to content
Sign in to follow this  
Peter.Kippes

[Exchange 2003] Relay verbieten

Recommended Posts

Hallo,

 

bisher habe ich mich nur in der NT-Welt bewegt, jetzt bin ich umgestiegen auf 2003.

Leider bringt das einige Probleme mit sich die ich noch nciht lösen kann.

 

Problem:

Wir haben eine Standleitung mit fester IP-Adresse und empfangen unsere Mails direkt.

Wir hatten unseren "alten" Exchange 5.5 so konfiguriert, daß wir alle externen Mails empfangen konnten, aber unser Server nicht als "Spam-Verteiler" mißbraucht werden konnte. Leider habe ich Probleme diese Konfiguration auf den Exchange 2003 zu übernehmen. Ich schaffe es nur, den Server entweder so zu konfigurieren, daß wir Mails von extern empfangen können, aber dann ist der Exchange offen wie ein Scheunentor und wir werden als Spam-Relay benutzt. Oder aber ich verbiete das Relaying, aber dann empfangen wir überhaupt keine Mails von extern mehr.

 

Ich hoffe, daß Problem wurde ausreichend klar geschildert. Ich suche jetzt schon seit zwei Tagen im Netz, werde aber nicht so recht fündig.

 

Grüße

Peter Kippes

Share this post


Link to post
Share on other sites

Hi

 

In den Eigenschaften des virtuellen SMTP Servers im SystemManager findest Du unter Zugriff den Punkt Relayeinschränkungen. Da kannst Du definieren, daß nur der angegebene Rechner (Dein Exchange) Mails senden darf.

 

Gruß

Dirk

Share this post


Link to post
Share on other sites

Hi,

 

Dirk_privat hat recht. Man sollte aber auch den SMTP Konnektor richtig konfigurieren.

 

Beim Adressraum * sagen, dass an diesen Adressraum nicht relayed werden darf.

 

Christoph

Share this post


Link to post
Share on other sites
Leider habe ich Probleme diese Konfiguration auf den Exchange 2003 zu übernehmen. Ich schaffe es nur, den Server entweder so zu konfigurieren, daß wir Mails von extern empfangen können, aber dann ist der Exchange offen wie ein Scheunentor und wir werden als Spam-Relay benutzt. Oder aber ich verbiete das Relaying, aber dann empfangen wir überhaupt keine Mails von extern mehr.

 

hallo Peter,

 

willkommen an Board.

 

zunächst sei mitgeteilt, dass der Exchange2003 standartmäßig das Relayen verbietet. insofern ist da von Deiner seite aus gar nichts zu konfigurieren, sondern die Kiste ist out-of-the-box schon keine "Spamschleuder".

 

daher meine Frage:

Was genau hast Du denn da konfiguriert? Und woher weist Du, dass die Installation offen wie ein Scheuentor ist?

 

Eine sehr gute Anlaufstelle für Exchange ist im Übrigen auch http://www.msxfaq.de

 

grüße

 

dippas

Share this post


Link to post
Share on other sites

Danke für Eure Antworten....

 

@dippas: Leider muß ich zu meiner Schande gestehen, daß ich die Standardeinstellungen verstellt habe, weil ich dachte ich bekomme das so hin. Leider was ich da wohl etwas vermessen.

Ich weiß das ich offen bin, weil ich verschiedene Relaytester (z.B. ORDB.ORG) benutzt habe um mich zu prüfen.

 

@Christoph35: Im SMTP-Connector habe ich als Adressraum * konfiguriert und die Option "Weitergabe an diese Domäne per Realy erlauben" nicht angeklickt.

Ist das die richtige Einstellung?

 

@Dirk_privat: Wie kann ich das einstellen?

Wenn ich unter den Relayeinstellungen "Alle mit Ausnahme der Liste" dann fungiert der Server als offenes Relay.

Wenn ich "Nur Computern in der Liste" anklicke kommen keine Mails mehr ins System.

Die Option "Jeder Computer der erfolgreich authentifiziert ist..." ist immer angeklickt.

 

 

Danke und Grüße

Peter Kippes

Share this post


Link to post
Share on other sites

@Christoph35: Im SMTP-Connector habe ich als Adressraum * konfiguriert und die Option "Weitergabe an diese Domäne per Realy erlauben" nicht angeklickt.

Ist das die richtige Einstellung?

 

Ja, so ist das korrekt.

 

Wenn ich "Nur Computern in der Liste" anklicke kommen keine Mails mehr ins System.

 

Du mußt natürlich mindestens einen Mailserver angeben, der Dir mails schicken darf ;)

 

Wie sieht denn eure Mail-Landschaft aus? Ist der Exchange der einzige Mailserver bei euch? Oder gibt es vorgeschaltet noch ein SMTP-Gateway?

 

/edit:

Hier gibts jede Menge Whitepapers zu Exchange. Besonders der Transport and Routing Guide könnte für dich interessant sein.

 

Christoph

Share this post


Link to post
Share on other sites

Hi,

 

zuerst einmal die Antwort auf Deine Frage:

Wir haben nur einen einzigen Mailserver. Unser Mailserver nimmt die Mails direkt aus dem Internet an. Welchen Mailserver sollte ich denn angeben?

 

Aber ich glaube ich habe die Lösung für mein Problem gefunden:

Ich habe im SMTP-Connector, unter Adressraum nicht mehr * sondern unseren Domänennamen angegeben und unten die Weitergabe an diese Domäne erlaubt.

Jetzt sagen mir die Relay-Tester, daß ich kein offenes Relay bin. Mails kann ich aber empfangen.

 

 

Grüße

Peter Kippes

Share this post


Link to post
Share on other sites
Ich habe im SMTP-Connector, unter Adressraum nicht mehr * sondern unseren Domänennamen angegeben und unten die Weitergabe an diese Domäne erlaubt.

 

Und kannst du noch Mails verschicken :confused:

 

Christoph

Share this post


Link to post
Share on other sites

Ja kann ich.

 

Aber ist das nicht logisch?

Ich sage dem Server, doch nichts anderes, als das es nur für die lokale Adresse erlaubt ist zu relayen. Alle anderen Adressen sind verboten.

 

Das verschicken Intern nach Extern läuft doch über die Autentifizierung, oder irre ich mich da?

 

Gruß

Peter Kippes

Share this post


Link to post
Share on other sites

Und Exchange liefert die Mails auch aus?

 

Wie ist der SMTP Connector genau konfiguriert?

 

Verschickt ihr über Smarthost (an den SMTP eures ISP)? Oder direkt mit DNS Auflösung?

 

Und welche Einträge stehen jetzt auf Adressraum?

 

Christopoh

Share this post


Link to post
Share on other sites

Ja der Exchange liefert die Mails auch aus.

Habe es mit einem privaten externen Account und mit web.de getestet. Die Mails kommen tadelos an.

 

Konfiguration SMTP Connector:

Reiter Allgemein:

"DNS für Weiterleitung über Connector verwenden" ist angeklickt

Lokale Bridgeheads, dort steht der Name unseres Servers drin

Der Rest ist nicht angeklickt.

 

Reiter Adressraum:

Unter Adressraum ist der Name unserer Domäne eingetragen.

Hier bei meine ich den Namen der öffentlichen Domäne (xxx.de) und

nicht den Namen der internen Domäne (xxx.local)

Connectorbereich -> Gesamte Organisation

Weitergabe von Nachrichten an diese Domäne... ist angeklickt

 

Reiter Routinggruppe

Hier habe ich keine Einträge.

 

Auch beim Rest habe ich nichts eingetellt, alles auf Standard gelassen.

 

 

Versand erfolgt über DNS-Auflösung

Und wir versenden nicht über einen SmartHost.

 

Beantwortet das Deine Fragen?

 

Grüße

Peter Kippes

Share this post


Link to post
Share on other sites

Ja, beantwortet es :D

 

Das sieht alles gut aus. Dann frag ich mich nur, warum dein Exchange als Spam-Schleuder gebrandmarkt wurde...

 

Moment, eine Idee hab ich noch....

 

In dem von Dirk erwähnten Dialog gibts noch das Häkchen für

"Jedem Computer der erfolgreich authentifiziert..."

 

Ist das gesetzt? Und gleichzeitig "anonymer Zugriff" gestattet, wenn Du unter "Zugriffskontrolle" auf "Authentfizierung" klickst?

 

Christoph

Share this post


Link to post
Share on other sites

Du meinst die Einstellungen im Virtuellen Standardserver?

 

Reiter Zugriff -> Relay

Dort habe ich "Nur Computer in der Liste angeklickt" und unsere Netzmaske eingetragen.

Unten ist der Haken bei Jedem Computer, der erfolgreich authentifiziert ist... gesetzt.

 

Unter Authentifizierung habe ich Anonymen Zugriff erlaubt.

 

 

Meine Einstellungen waren vorher anders, ich habe sie durch ausprobieren und viel lesen angepaßt. Jetzt ist mein Server keine Spam-Schleuder mehr. :-) Habe bei verschiedenen Webseiten Tests durchgeführt und alle gängigen Möglichkeiten über den Server zu versenden schlagen jetzt fehlt. Vorher hat unser Server einfach alles weitergeleitet. Egal woher es kam und wohin es ging. :-(

 

Gruß Peter

 

PS: Danke für die offenen Ohren und die Hinweise....

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...