Jump to content

suffixe über dhcp


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

hallo zusammen,

 

ich glaub ich sitz grad irgendwie auf der leitung - ich möchte meinenm dhcp sagen, er soll bei der ip-vergabe auch gleich 2 dns-suffixe bei den clients mit eintragen. kann mir da jemand helfen?

 

das muss eigentlich ganz einfach sein - aber ich sitz jetzt schon ne weile dran und hab auch schon in foren und bei ms gesucht. wird wahrscheinlich schrecklich peinlich wenn mir jemand sagt wie ich das anstelle aber ich komm halt nicht weiter :(

 

thx bandit

Link to comment

WOW - das ging aber fix :p - Danke

 

option 15 hab ich auch schon gedacht, aber noch nicht versucht, da ich da ja nur einen eintrag vornehmen kann. oder kann ich da auch mehrere einträge mit semikolon getrennt - oder so - reinschreiben?

es sollte halt bei den client in der suchreihenfolge intra.dom1.de und dom1.com stehen, damit bei bei der namensauflösung nicht der fqdn benötigt wird.

 

info:

2 dns - zonen - eine unix und eine windows. windows leitet an den unix weiter

Link to comment

Servus,

 

also ich habs jetzt mal versucht (option 15) - wir haben ja noch netbios (was ich eigentlich los werden will :wink2: )

 

er trägt das dann in "Verbindungsspezifisches DNS-Suffix:" ein (sagt ipconfig /all).

ich wollte die einträge aber in "DNS-Suffixsuchliste" haben.

in den erweiterten tcp/ip einstellungen taucht der eintrag gar nicht auf (bzw. ist auf "primäre und verbindungsspezifische suffixe anhängen eingestellt")

ich müsste also erst den schalter finden, der mir das auf "diese dns-suffixe anhängen" umstellt.

ich werd jetzt mal deinen vorschlag testen - wär mir ja auch schon mit geholfen :D

 

g. bandit

Link to comment

Soooo,

 

wie zu erwarten überschreibt die bereichsoption die server option. klar option 15 gibbet halt nur einmal.

semikolon, komma oder leerzeichen getrennte einträge übernimmt er als string voll :(

er kann dann keinen von beiden mehr auflösen - schätzungsweise lautet seine anfrage am dns dann "kiste1.intra.dom1.de;dom1.com" - und das kann nat. keiner der beiden dns auflösen :mad:

 

steht da nur intra.dom1.de kann er die suchanfrage entsprechend weiterleiten, und bekommt die korrekte ip - steht da nur dom1.com kann er es selbst auflösen und beantworten.

 

so und jetzt ???

ich kann ja schlecht meinem dns sagen, wenn du kiste1.dom1.com nicht findest, dann frag dns2 nach kiste1.intra.dom1.de - oder?

 

vielleicht noch ne Idee, wie ich den schalter auf "diese dns-suffixe anhängen" beim dhcp lege?

 

g. bandit

Link to comment

feierabend ist schon längst vorbei, und hock immer noch hier :cry:

 

scheint doch nicht so einfach zu sein :mad: :mad:

 

ich hab jetzt alle dns-zonen gelöscht, und neu erstellt (aktive dir integriert -> vielleicht liegt hier noch mein denkfehler)

den anderen dns hab ich als nameserver eingetragen und gleich auch noch ne revers-looupzone erstellt. funzt alles rund.

Dhcp übergibt Option (015) dns-domänenname: intra.dom1.de, (003) gateway und (006) dns (meiner)

 

jetzt hab ich folgendes phänomen:

ip config /all zeigt jetzt folgendes:

Primäres DNS-Suffix . . . . . . . : dom1.com

Knotentyp . . . . . . . . . . . . : Broadcastadapter

IP-Routing aktiviert. . . . . . . : Nein

WINS-Proxy aktiviert. . . . . . . : Nein

DNS-Suffixsuchliste . . . . . . . : dom1.com

............................................ intra.dom1.de

Ethernetadapter "LAN-Verbindung":

Verbindungsspezifisches DNS-Suffix: intra.dom1.de

 

nehmen wir jetzt einmal an:

fqdn: kiste1.dom1.com (eintrag in meinem dns)

fqdn: intra1.intra.dom1.de (eintrag im anderen dns)

 

wenn ich jetzt mit nslookup kiste1 suche löst mein dns ihn auf

suche ich nach intra1 löst mein dns ihn nicht auf

suche ich nach intra1.intra.dom1.de kann er wieder aufgelöst werden

 

stelle ich an dem rechner nun bei "erweiterte tcp ip einstellungen" von "primäre verbindungsspezifische dns suffixe anhängen" auf "diese dns suffixe anhängen" und trage dort sowohl dom1.com als auch intra.dom1.de löst er mir sowohl kiste1 als auch intra1 auf. bei ipconfig /all erscheint aber das tupfen gleiche. wo ist mein denkfehler ???????

dabei spielt es keine rolle ob der abfragende pc mitglied der domäne dom1.com ist oder in einer arbeitsgruppe steckt - gleiche symptomatik.

 

eigentlich wollte ich keine anmeldescripte verwenden - glaubst du nicht dass das irgendwie anders geht? wenn ich mir anschaue was ipconfig /all jetzt bringt (DNS-Suffixsuchliste) bin ich doch schon fast am ziel. oder gibt es bei dem dns noch ein rädchen das man drehen kann (außer dem zusätzlichen nameserver) wo ich noch nicht draufgekommen bin? ich mein er leitet ja schon weiter - aber eben nur mit fqdn-namen.

 

@ :cry::cry: grissly "warum?" - weil ich einfach nur wissen wollte wie ich dem dhcp sagen kann dass er "diese dns suffixe anhängen" an die clients übergibt. ich dachte das wär ganz einfach. ein haken und 2 einträge. so wie option 15 !!! ;). ausserdem wollte ich nicht gleich mit einer flut von infos kommen.

 

seit 8 hock ich hier - und jetzt mach ich ers ma feierabend - morgen ist auch nochn´ tach.

 

vg bandit

Link to comment
feierabend ist schon längst vorbei, und hock immer noch hier :cry:

 

scheint doch nicht so einfach zu sein :mad: :mad:

 

ich hab jetzt alle dns-zonen gelöscht, und neu erstellt (aktive dir integriert -> vielleicht liegt hier noch mein denkfehler)

den anderen dns hab ich als nameserver eingetragen und gleich auch noch ne revers-looupzone erstellt. funzt alles rund.

Dhcp übergibt Option (015) dns-domänenname: intra.dom1.de, (003) gateway und (006) dns (meiner)

 

jetzt hab ich folgendes phänomen:

ip config /all zeigt jetzt folgendes:

Primäres DNS-Suffix . . . . . . . : dom1.com

Knotentyp . . . . . . . . . . . . : Broadcastadapter

IP-Routing aktiviert. . . . . . . : Nein

WINS-Proxy aktiviert. . . . . . . : Nein

DNS-Suffixsuchliste . . . . . . . : dom1.com

............................................ intra.dom1.de

Ethernetadapter "LAN-Verbindung":

Verbindungsspezifisches DNS-Suffix: intra.dom1.de

 

nehmen wir jetzt einmal an:

fqdn: kiste1.dom1.com (eintrag in meinem dns)

fqdn: intra1.intra.dom1.de (eintrag im anderen dns)

 

wenn ich jetzt mit nslookup kiste1 suche löst mein dns ihn auf

suche ich nach intra1 löst mein dns ihn nicht auf

suche ich nach intra1.intra.dom1.de kann er wieder aufgelöst werden

 

stelle ich an dem rechner nun bei "erweiterte tcp ip einstellungen" von "primäre verbindungsspezifische dns suffixe anhängen" auf "diese dns suffixe anhängen" und trage dort sowohl dom1.com als auch intra.dom1.de löst er mir sowohl kiste1 als auch intra1 auf. bei ipconfig /all erscheint aber das tupfen gleiche. wo ist mein denkfehler ???????

dabei spielt es keine rolle ob der abfragende pc mitglied der domäne dom1.com ist oder in einer arbeitsgruppe steckt - gleiche symptomatik.

 

eigentlich wollte ich keine anmeldescripte verwenden - glaubst du nicht dass das irgendwie anders geht? wenn ich mir anschaue was ipconfig /all jetzt bringt (DNS-Suffixsuchliste) bin ich doch schon fast am ziel. oder gibt es bei dem dns noch ein rädchen das man drehen kann (außer dem zusätzlichen nameserver) wo ich noch nicht draufgekommen bin? ich mein er leitet ja schon weiter - aber eben nur mit fqdn-namen.

 

@ :cry::cry: grissly "warum?" - weil ich einfach nur wissen wollte wie ich dem dhcp sagen kann dass er "diese dns suffixe anhängen" an die clients übergibt. ich dachte das wär ganz einfach. ein haken und 2 einträge. so wie option 15 !!! ;). ausserdem wollte ich nicht gleich mit einer flut von infos kommen.

 

seit 8 hock ich hier - und jetzt mach ich ers ma feierabend - morgen ist auch nochn´ tach.

 

vg bandit

Sorry, jetzt hast du jede Menge geschrieben, aber die einfachsten Infos nicht, wie z.B, betroffene Betriebssysteme, und das ist kein Flut von Infos.

 

Brauchste jetzt aber auch nicht mehr schreiben ...

 

 

grizzly999

Link to comment

so, da bin ich wieder,

 

nur für den fall dass es noch jemanden interessiert der ein ähnliches problem hat.

@ the_brayn thx für die hilfe

ich hab jetzt mal getscheckt was in die registry eingetragen wird:

(regedit4)

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Tcpip\Parameters]

"SearchList"="dom1.com,intra.dom1.de"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]

"SearchList"="dom1.com,intra.dom1.de"

 

ich hab es mal nur mit dem 2. eintrag ausprobiert also:

regedit4

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]

"SearchList"="dom1.com,intra.dom1.de"

 

- geht und die einträge bleiben auch nach einem reboot erhalten.

als notlösung könnte man jetzt ein msi draus machen und via gpo zuweisen -oder in ein startscript als runonce-eintrag in die registry einbinden (damit er das nicht jedesmal beim booten ausführt)

 

es kennt also niemand eine elegantere lösung??????????? (dhcp oder dns modifikationen)

 

@ grizzly99 schön dass du so mit quotes umgehen kannst - aber glaubst du die leute wollen alles 2 mal lesen? sowieso wenn wenn da deiner meinung nach "jede menge" ohne "die einfachsten infos" drinnen steht. um deine frage zu beantworten:

titel des threads: w2k3 also windows 2003 server

info:

2 dns - zonen - eine unix und eine windows. windows leitet an den unix weiter

.... "erweiterte tcp ip einstellungen" von "primäre verbindungsspezifische dns suffixe anhängen"....
so heisst das ab windows2000

 

also w2k3 server mit dns, linux server mit dns und w2k workstations. vorbereitung auf: rechner der arbeitsgruppen im die Domäne zu bringen mit fliessendem übergang

 

als nächster spruch kommt - installier halt n gescheites betriebssystem - linux oder kauf dir nen MAC

Link to comment
  • 3 weeks later...
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...