Jump to content

Netzwerkprobleme


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo,

 

ich habe schon seit längerer Zeit ein großes Problem, welches ich bisher noch nicht lösen konnte und hoffe nun, von Euch Hilfe zu bekommen.

 

Ich habe (privat) ein kleines Heimnetzwerk, zwei XP, ein Linux.

 

Da ich mit meinem Linux Schwierigkeiten mit meinem DSL (USB) Modem habe, möchte ich mit einem XP Rechner ins Internet. Ich habe dort eine dynamische Arbeitsumgebung installiert und möchte mit dyndns dauerhaft erreichbar sein. Router ist keiner vorhanden.

 

Das Problem:

Ein XP Rechner habe ich (192.168.0.1) als Internetrechner eingerichtet. Dieses Netzwerk funktioniert tadellos und ohne Probleme.

 

Ich möchte jedoch mit dem anderen Rechner ins Internet. Das Problem: dann funktioniert das Netzwerk nicht mehr. Wenn ich dem anderen Rechner durch das CMD manuell die IP neu zuweise, dann funktioniert es eine Weile. Doch beim nächsten hochfahren besteht wieder das selbe Problem. Ich habe mir schon gedacht, es kann vielleicht an der Leasdauer liegen? Doch anderseits kann es das auch nicht sein. Denn oft kann ich den anderen PC nicht mal anpingen.

 

Ich weiss nicht ob ich mich nun richtig ausgedrückt habe. Fragt nur ...

 

Ich danke Euch

 

Gruß von Balduin

Link to comment

Hallo,

 

hast Du die Probleme mit dem XP oder dem Linux PC?

 

Hast Du auf dem XP-Rechner mit dem USB-Modem das Internet Connection Sharing eingerichtet? Wenn ja, sollte der doch eigentlich an alle per DHCP-Adressen verteilen so das man da nichts händisch konfigurieren muß.

 

Sind die beiden anderen PCs als DHCP-Clients eingerichtet?

 

Was ist als Standardgateway eingetragen?

 

Es grüßt

 

MF

Link to comment

Ich habe Probleme mit dem XP Rechner.

 

Ich hatte erst beide XP neu aufgesetzt, und dann meinen XP als DHCP eingerichtet (192.168.0.1) und den anderen (192.168.0.10), das Netz und die Subnet stimmt überein.

Erst mal durch den WinManager, und als das nicht funktionierte, habe ich alles handish gemacht. Auch das klappt nicht.

 

Danach, weil ich dringend das Netzwerk brauche, habe ich den anderen XP als DHCP eingesetzt. Das funktioniert tadellos. Nur ... es ist der falsche Rechner :)

Link to comment

Hallo,

 

wer macht denn da bei dir das DHCP? Ich bin mir ziemlich sicher das XP nicht als DHCP Server dienen kann. Kommen die Adressen vielleicht von dem Linux-PC (was für eine Rolle spielt der überhaupt in diesem Szenario?)?

 

Mein Vorschlag wäre: auf dem PC mit dem Modem eine Internetverbindung einrichten (schon erledigt), diese dann per ICS (Internet Connection Sharing) freigeben und die Freigabe den eigenen Bedürfnissen entsprechend konfigurieren. Daraufhin bekommt dieser PC die IP-Adresse 192.168.0.1. Jetzt den anderen XP-PC entsprechend konfigurieren, damit er diese Verbindung nutzt (Standardgateway auf 192.168.0.1 setzen).

 

Viel Erfolg

 

MF

Link to comment

Danke für Deine Hilfe, mfrank,

 

das habe ich alles schon gemacht ... klappt so einfach nicht.

 

Linux spielt da überhaupt keine Rolle. Ist nur da, um Scripte zu testen. Dieser Linuxrechner ist oft ausgeschaltet, übernimmt also keine Rolle.

 

Das Problem ist XP. Vom einen Rechner funktioniert es, und vom andern nicht!

 

XP hat schon einen kleinen DHCP integriert.

 

Standard Gateway ist: 192.168.0.1, also der Rechner, der zur Zeit ins Internet geht.

 

Von solchen Problemen habe ich noch nie gehört. Irgendwie muss das doch zu lösen sein .. :confused:

Link to comment

Hi Balduin !

Versuch mal, den Fehler systematisch einzugrenzen, eventuell auch unter Zuhilfenahme des LinuxClients,

 

Wenn der PC mit ICS das Problem ist, müßte auch der LinuxClient keinen Ping mehr an den ICS-PC bzw. ins Internet absetzen können.

 

Kann er es doch, liegt es eventuell an dem XP-ClientPC. Kann denn der LinuxPC in der beschriebenen "Streßsituation" den ClientPC noch anpingen (und umgekehrt) ?

 

Wenn ja, ist der ICS-PC das Problem, wenn nein, dann doch der XP-Client.

Und bei den beiden Clients die Einstellungen auf jeden Fall auf DHCP belassen, sonst sieht man garnicht mehr durch ! ;)

 

Die Eventlogs der XP hast Du sicher schon gecheckt ?

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...