Jump to content
Sign in to follow this  
ZoTTeL

Linuxfrage bzgl. Squid & Webmin

Recommended Posts

Sorry das ich hier was ueber Linux frage aber ich erhoffe mir einfach mal eine Antwort die nicht das ganze WE auf sich warten laesst.

 

Zum Thema: Ich habe einen Linux-Proxy (Squid) laufen.

Fuer einen der Mitarbeiter soll ich nun zur einfacheren Wartung das Konfigurationstool Webmin zum laufen bringen. Es laeuft auch aber es werden keine Aenderungen an der squid.conf vorgenommen. Wenn ich z.B. einen anderen Port via Webmin eingebe wird in der .conf nichts geaendert. Hin und wieder erscheint im Squid-Verzeichnis (/etc/squid) eine Datei squid.conf.lock, die sich jedoch nicht oeffnen laesst. Ich denke dies ist eine Tempdatei der Aenderungen.

 

In der Ereignisanzeige des Webmin steht unter den Details einer Aenderung wie z.B. der Ports "Keine Konfigurationsdateiaenderungen wurden fuer dieses Ereignis aufgezeichnet".

 

Hoffe jemand hat mit sowas Erfahrung und kann mir helfen.

 

Vielleicht muss ich ja noch einen Pfad angeben wo die .conf liegt oder so, aber ich finde nichts

 

mfg ZoTTeL

Share this post


Link to post

Hi!

Ich hatte ein ähnliches Problem mit einem Cronjob den ich über webmin administrieren wollte. Musste das System dann mal neu installieren und dann gings. (Hilft dir jetzt aber nicht weiter, is klar) ;)

 

Hast du schon mal unter /var/log die messages Datei gecheckt? Steht da was drinnen.

 

Du arbeitest mit root? ja?

Share this post


Link to post

Mach ich gerade, also in die logs schaun.

An eine Neuinstallation hab ich auch schon gedacht aber das is ja nicht so schoen.

 

Andererseits wenn es bei Dir geklappt hat

 

mfg zottel

Share this post


Link to post

hab ich erst letzte woche runtergeladen muesste eine neue version sein.

ich arbeite mit suse 9.1 pro

 

P.S: streube mich vor der neuinstallation

Share this post


Link to post

Hi again!

Der aktuellste Webmin ist 1.160 Ich würds trotzdem mal mit dem probieren - einfach die RPM runterladen.

 

Neuinstallation wäre natürlich nicht so toll , da man ja das eigentliche Problem damit nur umgeht und viel Aufwand hat.

Share this post


Link to post

vielleicht ist das die einzige moeglichkeit. der download koennte ja beschaedigt gewesen sein. hab auch gerade den squid neuinstalliert.

 

vielen dank fuer deine hilfe ich meld mich dann nochmal

Share this post


Link to post

hi dg76

 

kann das am verzeichnispfad des squid bei suse liegen. im quickstart manual steht was von /usr/local/squid.

vielleicht findet der webmin die dateien einfach nicht aber ich kann den pfad auch nicht aendern

Share this post


Link to post

Warum willst du überhaupt Webmin nutzen?

Man kann auch darauf verzichten :).

Aber ok, wie schon zuvor geschrieben wurde: versuche mal ne neuinstallation von Webmin oder nen Update. Welche Squid Version hast du ?

 

 

Viel Erfolg

Active|Director

Share this post


Link to post

Hallo ZoTTel,

 

wenn ich das richtig verstanden habe kannst du mit dem Webmin die aktuelle Konfiguration doch aber auslesen, oder? Dann müsste der Pfad ja gefunden werden.

 

Sieht mir irgendwie eher nach einem Problem mit den Zugriffsrechten aus.

 

Mit welchem Benutzer meldest du dich denn nun an?

 

Gruß Michel

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...