Jump to content
Sign in to follow this  
Lustgewinn

Finde Server mit fixer IP im lokalen LAN nicht mehr

Recommended Posts

hi leuts,

 

ich habe meinem win2003-server (stand.edt. => er ist DC & verwaltet AD) eine (beliebige) fixe IP gegeben (181.70.23.1) und diese auch als bevorzugten DNS-Server eingetragen damit das Login schnell & ohne Timeout (durch Router-IP) funtzt. Als alternative adresse habe ich die IP meines Routers angegeben. Funtzt wunderbar!

 

Das Problem:

Ich komme jetzt intern nicht mehr von einem Client-Rechner auf den Server. Wenn ich ihn pinge (ping 181.70.23.1) bekomme ich keine antwort. Anm.: Internet funkt allerdings einwandfrei!

 

Auch über den Arbeitsplatz (\\meinServer\c$ ODER \\181.70.23.1\c$) komme ich nicht hin. => bevor ich die fixe IP vergeben habe und alles dynamisch gesetzt hatte, habe ich den Server immer gleich über seinen Namen gefunden.

 

Bitte um Rat was ich machen muss damit das auch mit einer fixen IP funtzt. :rolleyes:

Share this post


Link to post

ip-pool hab ich keinen gesetzt. das macht der router komplett automatisch. bei ihm geht das kabelmodem, die drei clients und der server rein. der DHCP-Dienst vom server ist (deshalb) lt. ereignisprotokoll nicht gestartet

 

bin mir jetzt nicht sicher weil ich nicht davorsitze, aber ich glaube die subnet der clients ist 255.255.255.0 und nicht 255.255.0.0

Share this post


Link to post

Na gut, dann lüfte ih mal meinen Verdacht :)

 

Wenn Dein Server ein DC ist, dann muss der eine feste IP haben.

Du hast Deinen Text so geschrieben, als hättest Du die IP erst jetzt eingegeben. Also war es vorher anders.

 

Weiter, weil Du geschrieben hast, dass Du einfach ne beliebige IP genommen hast denke ich Du hast tatsächlich einfach eine beliebige genommen.

 

Schließe ich schon mal alleine daraus, das sie mit 181 anfängt.

 

Ich gehe davon aus, dass der Router ein gewöhnliches Standardteil ist, über welches Du Dir keinen Kopf zerbrochen hast. Ergo wird er den Clients ne IP geben in der Art von 192.168.irgendwas.

 

Und damit haben wir auch schon das Problem und die Lösung ;)

 

Dein Server ist im Netz 181.70 (schließe ich aus der Maske 255.255.0.0)

 

Deine Clients sind aber im Netz 192.168.x (schließe ich aus der Maske 255.255.255.0)

 

Damit das mal geht solltest Du dem Router DHCP sagen, vergib IP's im Bereich 181.70. mit der Maske 255.255.0.0

 

Der Router braucht dann selbst auch ne IP aus dem Bereich 181.70 mit der Maske 255.255.0.0

 

Kleiner Tip: Mach Dich evtl. vorher mit TCP/IP vertraut. Denn auch 181.70 ist nicht gerade die beste Wahl für private IP's

Share this post


Link to post

gleich vorweg: all deine Vermutungen sind RICHTIG!

 

daraus schließe ich folgendes:

 

ich gebe dem server jetzt 'ne neue IP. Und zwar: 192.168.15 (beliebig gewäht).1(ebenfalls bel.) mit subnet 255.255.255.0

=> dann ist er im selben bereich wie die clients die vom router beschickt werden und ich müßte ihn finden. Oder hab ich da was falsch verstanden?

 

ps: warum ist 181.70 nicht gut? ich dachte 192.168 sind immer router-bereiche. deshalb habe ich mich bewußt davon "wegbewegt".

Share this post


Link to post
Original geschrieben von Lustgewinn

ps: warum ist 181.70 nicht gut? ich dachte 192.168 sind immer router-bereiche. deshalb habe ich mich bewußt davon "wegbewegt".

 

181.70 ist kein für den privatgebrauch reservierter bereich.

Ausserdem wieso brauchst du nen Class B bereich ? haste soviele Hosts ?

Share this post


Link to post

Also, Du darfst nicht einfach beliebig arbeiten. Eine IP Adresse muss zwar eindeutig sein, aber Sie hat auch gewisse Gemeinsamkeiten. Das hier zu erörtern käme einem TCP/IP Kurs gleich.

 

Zu Deinem Problem:

 

Sag mir mal die IP Adresse Deines Routers und ich sage Dir einfach wie Du vorzugehen hast, ok?

Share this post


Link to post

OK,

 

Am Server:

IP: 192.168.0.1

Sub: 255.255.255.0

GW: 192.168.0.10

DNS: 192.168.0.1

 

Am Router:

DHCP konfigurieren:

Pool: 192.168.0.11 - max. 254

Sub: 255.255.255.0

DNS: 192.168.0.1 (Ich hoffe Dein Router DHCP lässt diese Einstellung zu)

 

Fertig

Share this post


Link to post

hmm, es ist mir rein logisch zwar klar wie du das meinst, aber ich weiß nicht wie ich dem Router Pool, Sub und DNS eingeben soll. Konkret: der Router steuert das Netzwerk, aber der ist ja nur Hardwaremäßig eingebunden. Software war da keine zum installieren. Ich hab den wie gesagt eingebunden und die Kommunikation war von Anfang an da.

 

Um die IP des Routers vorhin herauszufinden habe ich mir mit "ipconfig -all" die LAN-Config ausgeben lassen. Der dort befindliche Standardgateway müßte meiner Meinung nach die IP des Routers sein (oder?).

Aber wie ich ihm Deine Config "reindrücke" ist mir nach wie vor unklar. :rolleyes:

Share this post


Link to post

Na Du hast doch irgendwann mal den Router konfiguriert. z.B. wie Du die Zugangsdaten für den Provider eingegeben hast.

 

Nurmalerweise haben die Dinger eine Weboberfläche. Du gehst in Deinen Browser (des Clients) und gibst als URL die IP des Routers ein. Dann müsste ein Anmeldefenster kommen. Da Benutzer und Kennwort eintragen und Du kannst den Router konfigurieren.

 

Was ist das denn für ein Router? Hersteller? Modell?

 

Sollte es nicht gehen, den Router soweit zu konfigurieren, ich meine damit die DNS Einstellung, dann machen wir nen anderen Weg ;)

 

Aber auf die Konfig des Routers musst Du so oder so.

 

Sag mal, bevor wir hier weiter machen: Ist das Deine Spielwiese oder reden wir hier von einem produktiven Netzwerk

Share this post


Link to post

ps: warum ist 181.70 nicht gut? ich dachte 192.168 sind immer router-bereiche. deshalb habe ich mich bewußt davon "wegbewegt".

 

192.168.x.x ist kein Router Bereich, sondern ein privater Bereich.

 

Es gibt bei TCP/IP 5 Klassen (A, B, C, D, E). D und E denkst Dir jetzt einfach mal weg.

 

In den 3 Klassen gibt es je einen Bereich, der privat ist. Bei A könntest Du 16,7 Mio. Rechner in ein Netz setzen, in B 65534 und in C 254 Stück.

 

Da 192.168. ein Klasse C Netz ist und das private Netz (erkennt man an 192.168) wird das vorwiegend genommen.

 

Dazu kommt noch die Subnet Mask. In der Klasse C ist das die 255.255.255.0.

 

Ergo, Alles in Deinem Netz muss die 192.168.x.y mit der Subnet Mask 255.255.255.0 haben.

 

Wobei X noch zum Netzanteil gehört. X muss also bei allen Kisten gleich sein. Bei Dir ist es die 0.

 

Y ist der Hostanteil. Der muss bei jeder Komponente eindeutig sein. Ein Bereich zwischen 1 und 254.

 

Also verwende für alles in Deinem Netz 192.168.0.1 - 254

 

Kleine TCP/IP Lehre :)

Share this post


Link to post

hi Wildi,

 

gleich mal vorweg: es handelt sich um ein (neues 100MBit) produktives Netzwerk mit 3 Clients und dem Win2003Srv (stand.etd.) der DC (+DNS) ist und AD verwaltet.

 

Der Router ist ein grüner D-Link mit 4 Ports. Dieser ist zusammen mit unserem Kabelmodem (für permanent Internet) von unserem Anbieter gekommen. Der Techniker hat das Modem mit dem Router verbunden und alles für die kommunikation zwischen 2 Clients konfiguriert (ich war an dem Tag LEIDER nicht da!).

Den neuen Server und die dritte Workstation habe ich dann einfach an den Router dazugehängt. Was allerdings eigentartig ist: Ich komme mit dem Server nicht ins Netz (wg. den verstärkten Sicherheitsrichtlinien für den IE??). Anm.: pingen funtzt auch nicht, ABER ich konnte ein paar WindowsUpdates runterladen (hat er automatisch angeboten und durchgeführt). die interne Kommunikation funtzt einwandfrei.

 

Ob ich über die IP des Routers im Browser reinkomme muss ich noch probieren.

 

Danke für die kleine TCP/IP-Lehre. JETZT ist mir das KLAR! ;)

Ich werde die LAN-Konfig auf jeden Fall mal nach diesem Prinzip aufbauen. Dann müßte es eigentlich klappen.

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...