Jump to content
Sign in to follow this  
harzruebe

2K Server - Netzwerkdruckerproblem

Recommended Posts

Hallo zusammen!

 

Habe ein massives Problem und hoffe (nachdem mir beim letzten Mal hier schon gut geholfen werden konnte) wieder einmal auf Lösungsvorschläge von Euch.

 

Wir haben bei einem Kunden ein W2K-Netzwerk mit acht W2k-Clients und einem W2K-Server übernommen. Das Netzwerk läuft mit DHCP und mit einer Domäne und den entsprechenden Benutzerprofilen. Unser Kunde wollte nun, dass das Netzwerk erweitert und auf statische IPs umgestellt wird. Demzufolge haben wir den DHCP-Dienst deaktiviert.

 

Durch ein Hardwareproblem (Firewall und Router) verzögert sich die Umstellung jetzt um einige Wochen und wir haben das Netzwerk wieder auf DHCP umgestellt.

 

Leider funktioniert jetzt die Datei- und Druckerfreigabe nicht mehr richtig. Vom Server aus kann ich auf alle freigegebenen Verzeichnisse und Netzwerkdrucker (lokal am Server, als auch als eigenständiger Client mit eigener IP) zugreifen. Doch leider weigern sich alle Clients hartnäckig irgendwo etwas zu drucken (ausser lokal natürlich).

 

Will ich auf einen Client einen Netzwerkdrucker neu hinzufügen, komme ich vom Client zwar auf die Domäne und sehe dort auch alle freigegebenen Drucker, aber beim Klick auf "HINZUFÜGEN" erscheint die Fehlermeldung "Drucker nicht verhanden bzw. keine Verbindung möglich".

 

Greif ich mit dem WinExplorer von einem Client auf die Domäne, kommt die Fehlermeldung "Der Server ist für Transaktionen nicht konfiguriert". Die selbe Fehlermeldung kommt übrigens auch schon mit der W2K-Logon-Prozedur, wenn der Client versucht, die Zeit vom Server zu synchronisieren. Nach Durchsicht mit "NET HELPMSG" werden als Ursache fehlende IPC$-Ressourcen-Freigaben angegeben. Im Internet hab ich da inzwischen einen Tipp zum Einschalten über einen DWORD-Eintrag in der Registry gefunden.

 

Ich würde jetzt noch folgende Tipps, die ich nach zeitraubender Suche (wir sitzen jetzt bereits 4 Tage an diesem Problem) gefunden habe, ausprobieren:

- TCP/IP-Protokolle auf Server und Clients deinstallieren und dann wieder neu installieren

- Datei- und Druckerfreigabe deinstallieren und wieder installieren

- Registry-Tipps zum Einschalten der IPC$-Ressourcen

 

Was haltet ihr davon?

 

Wir haben inzwischen auch schon die Benutzerprofile und Sicherheitsrichtlinien gecheckt, aber dort haben alle Benutzer Zugriff auf alle Drucker. Auch die Microsoft Tipps mit der Installation vom SP4 brachten nix - im Gegenteil nach der Installation des SP4 kamen die Clients nicht mehr ins Internet (der W2K-Server fungiert gleichzeitig noch als Router ins Netz). Und eine Neuinstallation kann (erstmal) datenbedingt nicht durchgeführt werden.

 

Hat vielleicht noch einen ganz anderen Tipp?

 

Vielen Dank im Voraus und viele Grüße aus dem HARZ!!!

Maik

 

 

PS: Das ganze gestaltet sich insofern sehr schwierig, da natürlich zu diesem Netzwerk vom vorherigen Administrator keine Dokumentation existiert und dieser auch nicht bereit ist, da weiterzuhelfen und wir so nicht genau wissen, mit welchen Tricks und Kniffen er da gearbeitet hat.

Share this post


Link to post

Gute Frage.

Sowas muss man sich vorort angucken :)

Wie sind die Netzwerkdrucker angeschlossen Lokal am Server oder Lokal an den Clients.

Oder Sind das richtige Netzwerkdrucker mit eigenen IP´S

Wenn ja haben sich danürlich die IP´s geändert. Genau so wenn es ein Print server ist.

Das vieleicht mal Prüfen.

Kann auch sein das ihr was bei aufsetzen des DHCP´S falsch eingeställt habt. Den einfach noch mal neu installieren.

 

MFG

Active|Director

Share this post


Link to post

Erstmal Danke für Eure schnellen Antworten.

 

Also, wir haben verschiedene Drucker die auch verschieden angeschlossen sind. U.a. ein Laserdrucker, der mit eigener IP im Netzwerk hängt und auch einen Laserdrucker, der über LPT am Server angeschlossen ist.

 

Beim DHCP können wir nicht viel falsch gemacht haben, da wir nur den Dienst deaktiviert haben und mit haargenau den selben Einstellungen wieder aktiviert haben.

 

Mit DNS meinte auch schon ein Kollege zu mir, das es daran liegen könnte, aber dort ist augenscheinlich auch alles normal konfiguriert.

 

Stattdessen haben wir jetzt gerade eben folgende Entdeckung gemacht. Wenn wir über START->AUSFÜHREN \\Computername\\Verzeichnis eingeben können wir sehr wohl von einem Client auf den anderen zugreifen. Wenn wir dann per Explorer auf die übergeordneten Ebenen klicken, können wir auch die freigegebenen lokalen Drucker des jeweiligen Clienten ansteuern.

Damit sollte unser Druckerproblem schon fast gelöst sein, nur funktioniert das nicht beim lokalen Drucker des Servers, da wir dort nur mit dem Explorer auf die freigegeben Verzeichnisse, nicht aber auf den Rechner selbst und somit auch nicht auf das Druckerverzeichnis zugreifen können.

 

Hat hier jemand noch eine Idee? Meiner Meinung könnte das an den fehlenden Standardfreigaben (IPC$...) des Servers liegen, oder liege ich hier grundsätzlich falsch?

 

Grüße aus dem Harz!

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...