Jump to content
Sign in to follow this  
Joe

SCSI-Fehler: Software oder Hardwareproblem?

Recommended Posts

Hi

 

heute morgen hat sich unser (erst kürzlich frisch installierter) Server verabschiedet. Er war extrem langsam. Nach betätigen des "Herunterfahren" Knopfs hat er nach 20 Minuten noch immer kein anderes Bild angezeigt, als das Auswahlmenü beim Herunterfahren.

 

Also Hard-Reset. Nach dem Neustart habe ich zuerst mal alles gecheckt und (zum Glück) keine Daten-Fehler gefunden. Also ran an die Ursachenforschung und siehe da, gestartet hat das Problem mit folgendem Eventlog-Eintrag:

 

Quelle: adpu320, Ereigniskennung 9: Das Gerät \Device\Scsi\adpu3202 hat innerhalb der Fehlerwartezeit nicht geantwortet.

 

Danach kommen mehrere Einträge wie folgt:

 

Quelle: Disk, Ereigniskennung 51: Bei einem Auslagerungsvorgang wurde ein Fehler festgestellt. Betroffen ist Gerät \Device\Harddisk1

 

und nach jeder 5. Meldung kommt:

 

Quelle: Application Popup, Ereigniskennung 26: Anwendungspopup: Windows - Datenverlust beim Schreiben: Nicht alle Daten für die Datei E:\$BitMap konnten gespeichert werden. Daten gingen verloren. ...

 

Die 2 Festplattenmeldungen deuten auf ein Problem mit der Sicherungsfestplatte hin, auf die in jeder Nacht per Scheduled-Job die aktuellen Daten des Vortags kopiert werden. Dabei gehe ich davon aus, dass die 1 bei Harddisk1 für die 2. Festplatte steht. Ergo wechsle ich am WE die Festplatte aus. Was aber soll ich mit der Meldung des Adaptec-Controllers (ein 29320-R) anfangen? Es könnte ja auch sien, dass der Controller ein falsches Signal gesendet hat und dadurch die Festplatte durcheinandergekommen ist...

 

Was ist eure Meinung? Und warum habe ich keine Fehlermeldung bezgl der C-Festplatte? Normalerweise sollte darauf doch auch ab und zu geschrieben werden -> das stützt meine Theorie der defekten 2. Festplatte.

 

Bin für jeden Hinweis & Tipp dankbar, wie ich das Problem noch näher einkreisen kann.

 

Gruss

 

Joe

Share this post


Link to post

Hallo,

 

das muss man sich genauer ansehen, dazu gibt es ein paar nützliche KB Artikel, die einem helfen, die codes zu entschlüsseln:

 

Event ID 9 & 11 sind meistens ein Indiz für Hardwareprobleme:

http://support.microsoft.com/?id=154690

 

Informationen zu Ereignis-ID 51

http://support.microsoft.com/?id=244780

 

INFO: Format of Event Log Data Created by ScsiPortLogError

http://support.microsoft.com/?id=182335

 

 

Mit ein wenig Mühe findet man die Ursache :wink2:

Share this post


Link to post

Hallo Joe,

auch wenn über die Sache mittlerweile schon etwas Gras gewachsen ist: Was war das denn damals mit diesem Fehler? Ich such mir hier zur Zeit einen Wolf mit einer sporadisch auftretenden Fehlermeldung fogenden Inhaltes:

 

Das Gerät \Device\Scsi\adpu3202 hat innerhalb der Fehlerwartezeit nicht geantwortet.

 

Es handelt sich um einen IBM x236 Server unter w2k3 mit 2 Adaptec 7902B onboard, die in meinem System als Nicht-RAID-Konfiguration arbeiten. Allerdings wird nur ein Kanal genutzt, es laufen vier physikalische Devices drauf. (HDUs mit SCA/Hotplug)

 

Wäre sehr dankbar für einen Hinweis.

 

Beste Grüße,

Kapinski (der neu hier ist)

Share this post


Link to post
Hallo Joe,

auch wenn über die Sache mittlerweile schon etwas Gras gewachsen ist: Was war das denn damals mit diesem Fehler? Ich such mir hier zur Zeit einen Wolf mit einer sporadisch auftretenden Fehlermeldung fogenden Inhaltes:

Bei mir war es die defekte Festplatte. Nach Austausch der 2. Festplatte waren keine weiteren Fehler mehr feststellbar. Schau mal in deinem Ereignislog nach, ob du auch Hinweise auf I/O-Fehler bei einer Festplatte findest (analog zu meiner Meldung oben).

Gruss,

Jochen

Off-Topic:

Auch ein 4 Jahre alter Thread kann hilfreich sein. Sonst verweist man doch auch immer auf die Suche... ;)

Share this post


Link to post

Habe in der Zwischenzeit den Fehler isolieren können. :cool: Es war eine defekte Disk - zwar neu, aber offensichtlich fehlerhaft. Aufgrund des Fehlercodes und des Systemverhaltens gehe ich davon aus, dass der SCSI-Controller auf der HDU defekt ist und zeitweise den Datenverkehr auf dem SCSI-Bus blockiert hat.

 

Ärgerlich war halt, dass der Fehler nur sporadisch auftrat und dass die SCSI-Systemarchitektur nicht in der Lage ist, mit eigenen Resourcen derartige Protokollverletzungen zu erkennen und Diagnoseansätze zu bieten. Also im Zweifelsfalle immer mal die Platten raus bzw. wechseln. Der nächste Ansatz wäre der Wechsel der SCSI-Backplane gewesen, aber so war die Lösung eigentlich recht einfach.

 

Danke für das Interesse und für den Input und weiterhin viel Erfolg bei der Administration :wink2:

 

Kapinski

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...