Jump to content
Sign in to follow this  
Tom_L3

Kennt sich jemand in Apertum aus?

Recommended Posts

Hallo,

 

ich weiss das dies absolut OT ist :) suche jemanden der sich in MS-Apertum auskennt - geht um eine bewegung der Datenbank auf einen neuen Server - soweit alles klar mit Neuinstall usw. - ich kriege das ****e Ding aber nicht gestartet - Fehler 20033 - was auch immer das ist... Connect zur DB steht, sonst wäre es ein F 20016 ... mir gehen langsam die Ideen aus und es wird spät :D

 

Grüße

Tom

Share this post


Link to post

Kein Thema, ist nicht soo OT.

 

Sorry, ich kenne Great Plains / Apertum nur vom Hörensagen, aber vielleicht hat jemand mehr Infos für Dich...

Share this post


Link to post

Hallo,

 

schilder dein Problem bitte mal etwas detailierter, Ich habe auch Apertum im Einsatz mit einer Oracle DB 8i.

 

Welche Datenbank hast du ?

 

Welche Apertum Version ?

 

Wie sieht die sql.ini aus ?

 

Wie hast du DB und Apertum installiert ?

 

Wie greifst du auf die DB zu ?

 

Hast du einen TS im Einsatz ?

Share this post


Link to post

Hi,

 

ist ein MS-SQL Server mit nur einer Instanz für das Apertum 4.0 - DB Name ist Lager - sql.ini sieht folgendes aus:

 

[win32client.dll]

comdll=sqlodb32

[win32client]

setzerolengthstringstonull=on

[odbcrtr]

REMOTEDBNAME=lager,DSN=DSNlager

 

was ist eigentlich das DSN?

 

Apertum läuft als komplette Installation auf einem Client - dort ist die Apertum DB als Alias in der SQL-Client-Konfiguration eingetragen.

 

DB Zugriff läuft über TCP/IP auf Port 1433

 

das ist soweit alles OK - also der Zugang zur DB steht, sonst bekomme ich den 016er Fehler - das Prob ist, ich habe die Apertum DB von einem alten Server portiert per kopieren/attach und dann per DTS die User rübergespielt - beim Start kriege ich jetzt jedesmall den 20033 Fehler... switche ich das Alias auf den alten Server funktioniert alles Problemlos...

 

Hast du vielleicht einen Vorschlag?

 

Grüße

Tom

Share this post


Link to post

Hallo,

 

der 20033 weist auf Security deiner Datenbankuser hin. Der SQL-Server gibt der Datenbank seine SID mit. Beim Übertrag auf einen neuen Server taucht dann dieser Fehler auf. Du kannst es ja mal testen, lösche im Inst-Modul einen DB-User weg und lege den User neu an und es funktioniert. Um dies zu vermeiden verwenden wir ein SQL-Script, das wir bei DB-Übertrag auf einen neuen Server im Query-Analyzer über die DB laufen lassen. Dieses Skript nimmt die SID aus der DB. Das funktioniert sehr gut.

 

Viel Erfolg

 

Bye Tommy

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...